www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik 40V Impuls auf 11V aufschalten


Autor: loop-loop (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe die im Anhang gezeigte Schaltung aufgebaut und hatte mir 
folgendes dabei gedacht.

Als Eingang habe ein ein 0V und ein -8,5V Signal. Also 0V dauerhaft und 
die Schaltung wird mit -8,5V Impulsen angesteuert.

Am Ausgang sollen dauerhaft ca. 11V anliegen. Das habe ich per 
Widerstandsteiler und Diode gelöst.

Nun soll bei einem Impuls der Ausgang kurzzeitig auf ca. 40V gehen. 
Danach soll er wieder auf die 11V zurück fallen.

Ich dachte mir Folgendes:
Q2 ist dauerhaft durchgeschaltet und zieht den Kondonsator auf -20V. Q1 
wird über den Pullup R8 am Eingang auf 20V gehalten und schaltet so 
nicht durch. Sobald ein Eingangsimpuls kommt, schaltet Q1 durch und der 
Kondensator wird auf 40V aufgeladen...

Nun habe ich das Problem, dass ich das Verhalten korrekt am Kondensator 
C52(Transistor seitig) messen kann. Auch die ca. 11V liegen 
Ausgangsseitig an. Nur leider sind dort dauerhaft 11V und die 40V sind 
direkt am Ausgang nicht messbar.

Nun wollte ich fragen, ob jemand meinen Denkfehler sieht. Kann die 
Schaltung so funktionieren? ODer habe ich generall was falsch gemacht?

Vielen Dank!!!

MfG

Autor: Michael (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Komisch. Ich habe die Schaltung schnell einmal in LTspice eingegeben. 
Und sie funktioniert - nicht besonders präzise, aber prinzipiell.

Autor: Kompensator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, rechnerisch ergibt sich da: Null Volt am Minuspol von C52
oder irre ich...

Autor: loop-loop (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung muss nicht sonderlich präzise sein. Es reicht ein kurzer 
40V Impuls...

Wenn es in der Simulation stimmt, frage ich mich, was ich falsch gemacht 
haben könnte.

C52 scheint den 40V Impuls einfach zu verschlucken, so dass wieterhin 
die 11V am Ausgang anliegen

Autor: loop-loop (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung muss nicht sonderlich präzise sein. Es reicht ein kurzer 
40V Impuls...

Wenn es in der Simulation stimmt, frage ich mich, was ich falsch gemacht 
haben könnte.

C52 scheint den 40V Impuls einfach zu verschlucken, so dass wieterhin 
die 11V am Ausgang anliegen.

Danke für die Mühe, die die Simulation gemacht hat :)

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Möglichkeit wäre die Ansteuerung. Ist diese wirklich so niederohmig 
wie in der Simulation? Wie hoch sind die Impulsspannungen vor C51 und 
C53 wirklich? Macht der Knoten zwischen Q1 und Q2 was er soll?

Autor: Kompensator (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
komisch sieht das mit V2 aus, -20 sind plötzlich Gnd.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> komisch sieht das mit V2 aus, -20 sind plötzlich Gnd.

Meine Güte, ich war halt zu faul, 2 mal crtl-r zu drücken und habe statt 
dessen als DC-Spannungswert -20 eingegeben. 'tschuldigung!

Autor: loop-loop (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich teste gerade noch mit Impulsen, erzeugt mit einem Draht, den ich an 
die entsprechenden Potentiale halte. der 0 Ohm Widerstand ist derzeit 
nicht bestückt, um die Schaltung vom uC zu trennen. Der Draht ist also 
vor C51/53 angelötet und erfüllt seine Funktion.

Der Knoten macht was er soll... er ist auf -20V und geht dann, wenn der 
Impuls kommt, auch +20V hoch... macht in Summe 40V. Aber nach meinen 
Messungen eben nur am Knoten zwischen den Transistoren und nicht hinter 
C52, wo dauerhaft 11V anliegen. :(

DANKE !!!

PS: HAst du die Simulation gespeichert und könntest es fix auch noch 
einmal mit einem +9V auf -8,8V Impuls versuchen?

Autor: loop-loop (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS2: Ich werde es jetzt noch einmal versuchen, indem ich einen 20k 
Pullup auf +9V lege und dann den Draht auf -8,5V lege. Denn beim Wechsel 
zwischen +9V und -8,5V ist der Zustand des EInganges ja wieder 
undefiniert. Ich teste es gleich mal aus!

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> PS: HAst du die Simulation gespeichert und könntest es fix auch noch
> einmal mit einem +9V auf -8,8V Impuls versuchen?

Es funktioniert auch mit 9V --> -8.8V Impulsen. Zu deiner Ansteuerung 
mit einem Draht: Du weißt schon, dass die Impulse am Ausgang maximal 
20µs lang sind - auch wenn die Eingangsimpulse breiter sind?
Falls diese kurzen Impulse das Problem sind: Einfach C51 und C53 
vergrößern!

Autor: loop-loop (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ja das ist mir bewußt, dass es nur kurze Impulse sind, genau die reichen 
auch aus.

Ich habe den Fehler gefunden. Es lag wirklich daran, dass ich beim 
Umsetzen von 9V => -8,5V einen undefinierten Zustand hatte und somit die 
Schaltung nicht funktioniert hat.

Mit einem 20k Pullup auf 9V und dann den Draht am Eingang auf -8,5V und 
die Schaltung geht wunderbar, wie in der Simulation...

Ich habe aber Spannungsspitzen von 77V gemessen, die beim Anstieg auf 
40V überschwingen. Wie kann ich die etwas glatt bügeln? Reicht da ein 
kleiner 1000pF Kondensator mit entsprechender Spannungsfestigkeit?

VIELEN DANK!!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.