www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LM723 Netzteil, Transistoren brennen ab


Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe grad ein 2Kanal Netzteil mit 2 LM723 und 2x30V Trafo aufgebaut. 
Nur leider brennt mir bei einem Strom von 2A ein transisor ab. 
Kühlkörper ist dran. Das gleiche passierte beim anderen Kanal. Die 
Spannung am Ausgang war klein, einige Volt, also schon eine ziemliche 
Verlustleistung.

Weis jemand wie ich das Problem lösen kann? ich habe nur den Trafo, und 
der hat keine Mittelanzapfung, also kann ich die Eingangsspannung nicht 
verringern. Die Transistoren sind BD249 bzw. TIC132. Im plastikgehäuse, 
größer als TO220, weiß jetzt nicht wies genau heißt. Bringt es mir was, 
wenn ich an Stelle der Transistoren FETs verwende?, ok, kleinerer 
Innenwiderstand, aber wie müsste ich die Schaltung hierfür anpassen?

Das ärgert mich echt, da das Teil schon fast fertig ist, und samt 
selbsgebauten Alu-gehäuse recht gut ausschaut, aber halt zur Zeit nichts 
weiter ist als eine stinkende Heizung

Gruß und Dank

Philipp

Autor: Michael J. (jogibaer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schau mal ins SOA Diagramm der Transistoren
oder die Kühlung ist nicht ausreichend.

Jogibär

Autor: Thomas Decker (t0mmy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das mit den MosFETs bringt nichts. Wenn du die komplett durchschaltest 
(nur dann geringer InnenR), hast du ja die Trafospanngung am Ausgang -> 
es wird nichts geregelt.
Da die MosFETs also genauso regeln sollen wie die Transistoren, wird an 
ihnen die gleiche Verlustleistung auftreten.

Wenn du bei 5V Ausgangsspannung 2A fließen lässt, verbrätst du ja an 
einem Transistor ((30V*1,4) - 5V) * 2A = 74W - das will schon ordentlich 
gekühlt werden.

-> Besser kühlen, Transistor mit größerem Gehäuse nehmen zur besseren 
Wärmeableitung.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Philipp Putzer schrieb:
> Ich habe grad ein 2Kanal Netzteil mit 2 LM723 und 2x30V Trafo aufgebaut.
> Nur leider brennt mir bei einem Strom von 2A ein transisor ab.
> Kühlkörper ist dran. Das gleiche passierte beim anderen Kanal. Die
> Spannung am Ausgang war klein, einige Volt, also schon eine ziemliche
> Verlustleistung.
Drück die Verlustleistun doch mal in konkreten Zahlen aus...
30V ~ sind vermutlich rund 40 V Gleichspannung am Ladeelko bei 2A Last, 
je nach Trafo, das weißt aber nur Du, wir kennen weder Trafodaten noch 
tatsächliche Spannung.
Was sind "einige Volt"? Tolle Angabe. Nehmen wir mal 5V an.
Dann ist die Verlustleitung also rund 40V-5V = 35V * 2A = 70 Watt.
Kühlkörper ist dran. Tolle Info...

Der BD249 hat ein Rthjc von 1 Grad/Watt.

Bei zulässigen 150 Grad Junction-Temperatur und 30 Grad Umgebung sind es 
also rund 150-30 = 120 Grad. 120 Grad / 70W sind 1,7 Grad je Watt.
1,7G/W - 1G/W macht 0,7 G/W Wärmewiderstand für Montage und Kühlkörper.

Gibt theoretisch einen netten Kühlklotz, praktisch unmöglich.
Jetzt kommt noch die Power Derating Kurve ins Spiel:
Schon bei 120 Grad Junctiontemperatur sind nur noch run 30W maximale 
Verlustleistung zulässig, das Teil macht also genau, was im Datenblatt 
steht: es brennt ab.

>
> Weis jemand wie ich das Problem lösen kann? ich habe nur den Trafo, und
> der hat keine Mittelanzapfung, also kann ich die Eingangsspannung nicht
> verringern. Die Transistoren sind BD249 bzw. TIC132. Im plastikgehäuse,
> größer als TO220, weiß jetzt nicht wies genau heißt. Bringt es mir was,
> wenn ich an Stelle der Transistoren FETs verwende?, ok, kleinerer
> Innenwiderstand, aber wie müsste ich die Schaltung hierfür anpassen?
>
> Das ärgert mich echt, da das Teil schon fast fertig ist, und samt
> selbsgebauten Alu-gehäuse recht gut ausschaut, aber halt zur Zeit nichts
> weiter ist als eine stinkende Heizung

Du hättest vorher über die Zusammenhänge nachdenken sollen...

PS: Ungenauigkeiten der Rechnung sind inbegriffen, keine Lust, das genau 
auszurechnen, ist nicht mein Netzteil. ;-)

Gruß aus Berlin
Michael

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, die rechnung leuchtet mir ein.

Kurze infos noch: Trafo 2x30V AC sind dann ca. 40V an den Kondensatoren.
Pro Kanal sind zwei BD249 über einen Widerstand parallel geschalten. Die 
Verlustleistung würde sich dann ja aufteilen auf die beiden. Deshalb kam 
ich auf einen Wert der vielleicht grad noch machbar war für einen 
Kühlkörper. Daten vom KK sind mir nicht bekannt, Abmessungen ca. 125mm x 
200mm. Das derating hab ich aber übersehen, das geb ich zu.

Würde ich noch einen BD249 parallel schalten, würde sich die 
Verlustleistung pro TRansitor doch weiter verringern, oder täusche ich 
mich?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Pro Kanal sind zwei BD249 über einen Widerstand parallel geschalten.

Wo ist der Widerstand?
Als Emitterwiderstand - ja. In den Basisleitungen wäre falsch.

>Würde ich noch einen BD249 parallel schalten...

Ja ist richtig.

>Daten vom KK sind mir nicht bekannt, Abmessungen ca. 125mm x 200mm.

Und die 3. Dimension?

Autor: besserwisser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeig doch mal dein Schaltplan

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achso, ca. 25mm tief, gerippt klarerweise.

Schaltplan hab ich grad keine da, nur in papierform aber am montag kann 
ich den rein stellen.

Ich bin grad am überlegen, dass es wohl das beste wäre, wenn ich mir 
einen neuen Trafo zulege und die eingangsspannung dann je nach 
gewünschter ausgangsspannung erhöhe. So hab ich im unteren Bereich nur 
maximal ca. 17V als eingangsspannung. Ich denke das funktioniert dann 
auch, was meint ihr?

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für Passivkühlung aus dem Bauch raus zu klein für die Wärme. Aktiv mit 
Lüfter könnte reichen. Aber nur für einen Kanal. Für beide zu klein.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Würde ich noch einen BD249 parallel schalten, würde sich die
>Verlustleistung pro TRansitor doch weiter verringern, oder täusche ich mich?

Nein. Die Verlustleistung ist P = U I und bei gleichbleibendem U und I 
bleibt auch P gleich, selbst wenn Du fünfhundert Transistoren 
zusammenschaltest. Es führt kein Weg daran vorbei, P irgendwie thermisch 
von den Transistoren wegzubringen. Standardmäßig entweder durch einen 
riesigen passiven Kühlkörper oder durch einen kleineren mit Lüfter 
drauf. Fünfhundert Transistoren gingen theoretisch auch, aber nur wegen 
ihrer gemeinsamen großen Oberfläche, d. h. der Grund ist thermischer, 
nicht elektrischer Natur. Ein Transistor plus riesen Kühlkörper ist 
dazu äquivalent, aber billiger.

Alles klar? :-)

PS: Manchmal schaltet man allerdings doch mehrere Transistoren in so 
einer Endstufe zusammen. Das aber deswegen, weil ein Transistor alleine 
den Strom nicht packt. Hat also primär nichts mit der Verlustleistung 
zu tun.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>PS: Manchmal schaltet man allerdings doch mehrere Transistoren in so
>einer Endstufe zusammen. Das aber deswegen, weil ein Transistor alleine
>den Strom nicht packt. Hat also primär nichts mit der Verlustleistung
>zu tun.

Genau das ist falsch, es geht um die Verlustleistung dabei, die ein 
Transistor nicht schafft.

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
genau, so hätt ich mir das auch gedacht, der strom teilt sich auf 500 
transistoren auf, oder auch nur drei, und die Leistung pro Transistor 
wird kleiner. meine Transistoren varabschieden sich nach ein paar 
Sekunden, es liegt also nicht direkt daran dass der Kühlkörper die Wärme 
nicht an die Umgebung abgeben kann, vielmehr scheiterts am Weg von den 
Transistoren zum Kühlkörper. Dort ist noch eine Silikonfolie zur 
Isolation dazwischen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Transistoren parallel zu schalten verringert zwar nicht die 
Verlustleistung, verkleinert aber den Kühlkörper. Grund: Die 
Temperaturdifferenz zwischen Sperrschicht und Kühlkörper halbiert sich, 
folglich darf der Kühlkörper wärmer werden.

Von Michels Rechung ausgehend (70W, Rthjc=1K/W): Gesamtwärmewiderstand 
ist 1,7K/W. Davon gehen 1K/W für Rthjc weg, bleiben 0,7K/W für den 
Kühlkörper. Bei zwei Transistoren halbiert sich Rthjc, daher muss der 
Kühlkörper nur für 1,2K/W dimensioniert werden.

Diese Rechnung ist übrigens etwas idealisiert. Der Übergangswiderstand 
zwischen Transistor und Kühlkörper fehlt, und 30°C sind etwas tief 
angesetzt.

Autor: Arno H. (arno_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die Befestigungsschrauben auch isoliert?
Foto?

Arno

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, die drücken bei dem Gehäuse des BD249 auf das Plastik, bei den 
kleineren TO220 sind PLastikunterlegscheiben (reichelt) drinnen. habs 
auch sicherheitshalber nachgemessen, die haben untereinander keinen 
Kontakt über den KK

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Silikonfolie dürfte so um die 0,5-1,5K/W beitragen. Dieser Wert 
vergrössert effektiv Rthjc, teilt sich also bei mehreren Transistoren 
entsprechend auf.

Wenn also die 1K/W des Transistors und ~1K/W für die Isofolie zusammen 
kommen, dann sind es bei 70W und 25°C in der Mitte vom Kühlkörper an der 
Sperrschicht bereits 165°C. Egal wie gross der Kühlkörper ist. Ungut.

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, überschlägig meine Rechnung:
Ich möchte bei 2V 5A liefern können. (reine Annahme).
Das macht bei 2 Tr 2,5A; Pv = 38V*2,5A = 95W bei einem Rthj von 
1(Tr)+1(Folie) = 2K/W ergibt eine Endtemperatur zusätlich zur 
Umgebungstemp. von ca. 190°C. Laut extrapolation des Derating Diagramms 
müsst ich dem Tr dann -50W geben. aha. oder er verabschiedet sich mit 
schall und rauch...

Die gleiche Annahme nun aber mit einer Eingangsspannung von 12Vac macht 
am Elko ca. 17V. Pv = (17V-2V)*2,5A = 38W. Bei gleichem Rthj = 2K/W 
macht das eine Endübertemp von ca. 100°C. Laut Derating Diagramm kann 
der Transistor bei 100°C noch 50W verarbeiten. Somit sollte das dann 
eigentlich passen.

Der Kühlkörper ist außen, innen wird durch einen Lüfter für 
Wärmeaustausch gesorgt.

Ich denke die beste Möglichkeit wird die stufenweise verringerung der 
Versorgungsspannung sein.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manche Leistungstransistoren sind bis zu einer Sperrschichttemperator 
von 200°C einsetzbar. Das kann einen recht deutlichen Einfluss auf die 
Kühlung haben. In Frage käme hier beispielsweise der 2N3772.

Wenn man dann noch Reichelts Datasheet zu den Glimmerscheiben vergleicht 
(zu Silikon habe ich grad nix da), dann steht da 0,35K/W für TO-3 und 
0,8K/W für TOP-3. Wird ein bischen kompensiert durch den grösseren Wert 
von Rthjc bei TO-3 Typen, aber da bleibt trotzdem was über.

Um die obige Rechnung diesmal für 2 Stück 2N3772 fortzusetzen: 
(200°C-30°C)/70W = 2,4K/W. Rthjc=1,17K/W, Rglimmer=0,35K/W, 
Reff=(1,17+0,35)/2=0,76K/W. Bleiben 1,6K/W für den Kühlkörper. Der ist 
nicht einmal halb so gross wie in der ursprünglichen Auslegung.

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm, ja bei dem 2N3772 kommt mir die befestigung schwer vor. Am besten 
wären fertige KK mit den entsprechenden fehlenden Rippen um das Ding 
gscheide festzumachen. Die kleinen Dinger die es bei reichelt da gibt 
schaun mir nicht grad vertauenserweckend aus.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die üblichen Geräte dieser Art gehen bis 30 V Ausgangsspannung bei 
maximal 3 A Strom. Wenn der Trafo dann noch eine Mittelanzapfung hat, 
auf die bei kleinen Ausgagnsspannungen automatisch per Relais 
umgeschaltet wird, ist die Kühlung der Regeltransistoren auch noch gut 
zu packen.

38 V Eingangsspannung und 5 A sind für ne Längsregelung IMHO einfach 
schon grenzwertig. Du wirst einen leitzordnergroßen Kühlkörper brauchen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Philipp Putzer schrieb:

> hm, ja bei dem 2N3772 kommt mir die befestigung schwer vor.

Yep, da TO-3 etwas aus der Mode gekommen ist, sind passende KKs in 
dieser K/W-Klasse auch nicht mehr ganz so verbreitet.

Autor: Philipp Putzer (putzer_philipp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, dann weis ich jetzt was ich machen muss. Das mit der Mittelanzapfung 
war auch mal vorgesehen, nur irgendwie dann doch nicht zu ende gebracht 
worden

Vielen Dank an euch für die Hilfe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.