www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Problem mit Transistorschaltung


Autor: Artur B (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe ein Problem.
Ich muss mit 5V 12V schalten, (ja ich weiss Highside Switch und so 
weiter, habe keine Mosfets), allerdings habe ich bei der beschriebenen 
Schaltung das Problem, dass ich nicht über 11V am Ausgang hinauskomme, 
obwohl ich 12 brauche. Die Spannungsversorgung muss durch einen 
Controller schaltbar sein, und es werden auch nur weniger als 1 mA 
gebraucht (weiss leider nicht genau  wieviel, da es sich um eine 
Programmierspannung handelt und im Datenblatt nichts steht.) Ich habe 
hier viele alte ICs, allerdings kenne ich mich nicht so sehr aus als 
dass ich einen rausgreifen könnte (30 modelle aus der 74 HC Reihe etc.). 
Vlt kann mich jemand auf meinen Fehler bei der Dimensionierung 
aufmerksam machen. Die Transistoren sind BC 337.
Gruss und Danke
Artur

: Verschoben durch Admin
Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
du musst die Last gegen die 12V schalten. Und wahrscheinlich reicht dann 
auch ein Transistor.

Gruß

Autor: smed_de (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: smed_de (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Je nach Last kann der 1k am T2 schon ziemlich viel Spannungsabfall 
haben!
Eine komplementäre Schaltung mit pnp-Transistor wäre evtl. auch eine 
Idee?

Autor: Artur B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Kurt
Ich weiss nicht genau was du meinst.
Mein Fall: Ich habe einen Chip, der 5V braucht, man aber, um in den 
Programmiermodus zu kommen, an einen Pin 12V anlegen muss. Dies wird 
durch einen Pin des Parallelports gesteuert.

@smed_de
werde mir das mal anschauen, danke.

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich weiss nicht genau was du meinst.

Diese Schaltung
http://www.sprut.de/electronic/pic/grund/o4.gif
aus obiger Quelle.

Autor: Artur B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe grade das: http://www.sprut.de/electronic/pic/grund/o4.gif 
nachgebaut, allerdings mit bc547 und 557, und die Maxspannung stimmt, 
jedoch geht er nicht runter richtung 0V, sondern bleibt bei 3.8V. Als 
Scheinlast habe ich einmal 120 Ohm und einmal 47K genommen, selbes 
Ergebnis. Ich kriege langsam die Pimpanellen... wir habe hier sehr viele 
Logikteile, allerdings habe ich keine Fets oder ähnliches gefunden.
Gruss und danke schonmal
Atrur

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Artur,

>jedoch geht er nicht runter richtung 0V, sondern bleibt bei 3.8V.

Schalt mal einen 10k Widerstand vom Kollektor des BC557 mach Masse.

Soll der Pin überhaupt auf 0V heruntergehen, oder vielleicht auf 5V?

Kai Klaas

Autor: olibert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> jedoch geht er nicht runter richtung 0V, sondern bleibt bei 3.8V

Das ist gut moeglich, da du beim Sperren des PNP-Tranistors 
wahrscheinlich kein Massepotential hast. Verbinde den Kollektor des 
PNP-Transistors ueber einen Widerstand (10k) mit Masse.

Falls die du dann immer nicht bei 0V sein solltest, wuerde ich die 
Ansteuerung von hinten (Last) nach vorn (PIC) durchmessen.

Autor: Artur B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
danke für die Tipps, es lag an unterschiedlicher Beschaltung im 
Datenblatt und der Realität.
Gruss

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.