www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Über TL082 an Max127


Autor: Sebastian-nicolae Matei (snmatei)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe den Schaltungsaufbau, der in der angehängten Datei dargstellt 
wird, mit der Funktion eines nichtinvertierenden Verstärkers.
Das Problem ist, sobald ich einen Eingang des MAX127 zum auslesen der 
Spannung am OP benutze, steigt die Spannung auf einen konstanten Wert 
von 2,30V.
Mit einem Spannungsmessgerät, ohne angeschlossenen MAX127, kann ich 
jedoch unterschiedliche Ausgangsspannungen bei unterschiedlichen 
Eingangsspannungen messen.

Woran liegts?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind das wirklich 10R und 300R in der Gegenkopplung??

Kai Klaas

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Sind das wirklich 10R und 300R in der Gegenkopplung??

Jupp.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Jupp

Dann ist das mal viiiiiiiiiiiiiiiiiiiiiel zu wenig! Bei maximaler 
Ausgangsspannung sollten nicht mehr als 1mA aus dem Ausgang fließen, 
alles andere wäre Verschwendung.

Zusätzlich ist zu überlegen, ob nicht auch die eingestellte Verstärkung 
von (300+10)/10 = 31 zu groß ist. Was ist denn deine 
Nutzsignalbandbreite?

Kai Klaas

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Zusätzlich ist zu überlegen, ob nicht auch die eingestellte Verstärkung
> von (300+10)/10 = 31 zu groß ist. Was ist denn deine
> Nutzsignalbandbreite?

Das ganze soll ein PH-Messverstärker werden. Eingangsspannungen von 
-300mV bis 300mV bei 10 Hoch 12 Ohm.

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch bei folgender Beschaltung des TL082 
http://www.66pacific.com/ph/images/simplest_ph_met... 
springt mir der MAX127 hin und her bei der ausgelesenen Spannung. Werte 
zwischen 1,0345... und 1,6839... werden angezeigt.
Mit einem Voltmeter ist die anliegende Spannung im mV Bereich jedoch zu 
messen.

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frage zu den Widerständen:

Wäre die richtige Verstärkung mit Widerständen im kOhm Bereich zu 
erwarten?
Nur was wäre dann mit dem MAX, würde der auch noch eine Spannung auf die 
Leitung bringen oder nicht?

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keine weiteren Ideen zu o.g. Themen?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Keine weiteren Ideen zu o.g. Themen?

Du misst irgendeine Brummspannung mit 50Hz oder sowas?
Scheiss Schaltungsaufbau?

>Mit einem Voltmeter ist die anliegende Spannung im mV Bereich jedoch zu
>messen.

Das misst ja auch nur einen Mittelwert. Solltest du auch tun.

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
>>Keine weiteren Ideen zu o.g. Themen?
>
> Du misst irgendeine Brummspannung mit 50Hz oder sowas?
> Scheiss Schaltungsaufbau?
Die Spannung kommt von einer PH-Sonde. Habe dazu noch nie etwas zum 
Thema Brummspannung gelesen.

>>Mit einem Voltmeter ist die anliegende Spannung im mV Bereich jedoch zu
>>messen.
>
> Das misst ja auch nur einen Mittelwert. Solltest du auch tun.
Funktioniert auch, wie berichtet, nur sobald ein MAX127 dran ist habe 
ich die oben beschriebenen Spannungsschwankungen.

Autor: Christian Funke (funke)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier mal 1k und 30k Widerstände

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Das misst ja auch nur einen Mittelwert. Solltest du auch tun.
>Funktioniert auch, wie berichtet, nur sobald ein MAX127 dran ist habe
>ich die oben beschriebenen Spannungsschwankungen.

Der MAX127 gibt keine Spannung auf seine Eingänge.
Hast du überhaupt eine Masseverbindung?

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
> Der MAX127 gibt keine Spannung auf seine Eingänge.
> Hast du überhaupt eine Masseverbindung?

Masse ist vorhanden. In einem vorherigen Beitrag wurde erwähnt, die 
Widerstände seien zu klein gewählt, nur müsste ich bei diesem Aufbau
http://www.66pacific.com/ph/images/simplest_ph_met...
nicht auch mit dem MAX messen können?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hängt da am Eingang vom TL081 noch was dran, wenn du mißt?

Probiere mal 10k vom Eingang nach Masse zuschalten.

Kai

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Hängt da am Eingang vom TL081 noch was dran, wenn du mißt?
>
> Probiere mal 10k vom Eingang nach Masse zuschalten.
>
> Kai

Am Eingang kommt nur die PH-Sondenspannung rein. Gemäss 
http://www.66pacific.com/ph/images/simplest_ph_met...
Morgen werd ich mir mal Widerstände im kOhm Bereich zulegen und schauen 
was sich ergibt. Nur kann ich über die Schaltung aus o.g. Link auch 
nichts messen mit dem MAX. Mit einem Voltmeter ist das aber kein Problem 
und funktioniert einwandfrei.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Nur kann ich über die Schaltung aus o.g. Link auch
>nichts messen mit dem MAX. Mit einem Voltmeter ist das aber kein Problem
>und funktioniert einwandfrei.

Dann vergiss doch mal den OP und gib auf den Eingang vom
MAX mal 0,5V. Kannst du die richtig messen (Mit dem MAX)?
Wenn nein ist deine Schaltung mit dem MAX Schrott.

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
>>Nur kann ich über die Schaltung aus o.g. Link auch
>>nichts messen mit dem MAX. Mit einem Voltmeter ist das aber kein Problem
>>und funktioniert einwandfrei.
>
> Dann vergiss doch mal den OP und gib auf den Eingang vom
> MAX mal 0,5V. Kannst du die richtig messen (Mit dem MAX)?
> Wenn nein ist deine Schaltung mit dem MAX Schrott.

Mit dem MAX ist alles bestens. Die Schaltung davor isses. Warum kann ich 
die resultierende Spannung aus dieser Schaltung nicht messen?
http://www.66pacific.com/ph/images/simplest_ph_met...

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Warum kann ich die resultierende Spannung aus dieser Schaltung nicht
>messen?

Wie weit ist der PH-Sensor vom TL081 und der TL081 vom MAX127 enfernt?

Kai

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
>>Warum kann ich die resultierende Spannung aus dieser Schaltung nicht
>>messen?
>
> Wie weit ist der PH-Sensor vom TL081 und der TL081 vom MAX127 enfernt?
>
> Kai

Es handelt sich um eine gekauft PH-Sonde mit BNC-Anschluss an einem 1m 
Kabel. Die Sonde ist nicht die Fehlerquelle, auch ist mit dem MAX127 
alles OK. Zu suchen ist um den TL082 herum.

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht denn die Stromversorgung des TL082 aus?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmals, wie weit sind die Sachen voneinander entfernt??

Du hast keinerlei Schwingschutz am Eingang, am Ausgang und an den 
Versorgungsspannungsanschlüssen des TL081. Wenn jetzt die Teile weit von 
einander entfernt sind und vielleicht noch irgendwo die Schirmung fehlt, 
fängt das Ganze an zu schwingen. Oder du fängst massiv 100Hz Brumm aus 
der Umgebung auf, was ebenfalls deine Messung verfälschen kann.

Kai Klaas

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Nochmals, wie weit sind die Sachen voneinander entfernt??
>
> Du hast keinerlei Schwingschutz am Eingang, am Ausgang und an den
> Versorgungsspannungsanschlüssen des TL081. Wenn jetzt die Teile weit von
> einander entfernt sind und vielleicht noch irgendwo die Schirmung fehlt,
> fängt das Ganze an zu schwingen. Oder du fängst massiv 100Hz Brumm aus
> der Umgebung auf, was ebenfalls deine Messung verfälschen kann.
>
> Kai Klaas

Die PH-Sonde ist an einem Kable mit 1,5m länge.

Das mit dem Schwingschutz klingt interessant. Könnte es sein, dass ich 
die Spannung deswegen mit einem Voltmeter messen konnte, nicht aber mit 
dem MAX?
Wie wäre ein Schwingschutz zu realisieren?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sebastian,

>Wie wäre ein Schwingschutz zu realisieren?

Direkt am Eingang des TL081 einen Widerstand von 10k und einen 100nF 
Kondensator plazieren, und zwar so, daß die beiden Bauteile wie ein 
Tiefpaßfilter wirken.

Zusätzlich, an den beiden Anschlüssen für die Versorgungsspannung des 
TL081 jeweils einen 100nF Kondensator nach Masse.

Alle Teile direkt beim TL081 und mit kürzesten Anschlüssen!

Kai Klaas

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für die Antwort. Werd mal schauen was das bringt. Die Frage ist 
auch, ob ich bei einem TL082 bleibe oder auf ein LMC6001 + LMC6041 
umsteige.
Laut PDF wird dieses auch in PH-Metern verbaut, somit scheint es noch 
geeigneter. Habe auch an anderen Stellen gelesen, das TL082 wäre nicht 
unbedingt erste Wahl.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sebastian,

>Laut PDF wird dieses auch in PH-Metern verbaut, somit scheint es noch
>geeigneter. Habe auch an anderen Stellen gelesen, das TL082 wäre nicht
>unbedingt erste Wahl

Das hängt immer von den genauen Eigenschaften ab, die deine Schaltung 
aufweisen soll. Eventuell tut es auch ein TLC277?

Kai Klaas

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Hallo Sebastian,
>
>>Laut PDF wird dieses auch in PH-Metern verbaut, somit scheint es noch
>>geeigneter. Habe auch an anderen Stellen gelesen, das TL082 wäre nicht
>>unbedingt erste Wahl
>
> Das hängt immer von den genauen Eigenschaften ab, die deine Schaltung
> aufweisen soll. Eventuell tut es auch ein TLC277?
>
> Kai Klaas

Klingt auch interessant. Habe hier im Forum genau zum Thema PH-Messung 
auch etwas zum TLC277 gelesen.
Im ELV, sowie Reichelt ist der auch zu finden. Den LMC6001 hätte ich 
direkt von national bestellen müssen oder digikey.
Danke für den Hinweis.

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich werde wohl zu einem LMC6001 umsteigen.

Meine Frage dazu jedoch:
Wenn ich die Spannung direkt und unverstärkt auslesen möchte, den 
Widerstand R1 mit 100k 3500ppm zur Temperaturkompensation nutzen möchte 
(LMC6001 pdf Seite 11), brauche ich dann einen Widerstand an R2 oder 
kann ich auch nur mit R1 arbeiten.

Überlegung: 1 + (1000:0) = 1

Habe ich irgend etwas dabei nicht berücksichtigt?

Gruss,
Sebastian.

Autor: Sebastian-nicolae Matei (snmatei)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Niemand online, der dazu etwas sagen könnte (siehe letzten Beitrag im 
Thread)?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.