www.mikrocontroller.net

Forum: Platinen Problem beim FPGA - Projekt im Altium Designer


Autor: Dete Kosschlovsski (dete)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,


ich hoffe es kann mir jemand bei meinen Problem helfen. Es handelt sich 
um ein FPGA Projekt im altium Designer.
Die Beschreibung der Problem ist etwas schwierig aber ich versuche es 
genau zu beschreiben:

Ich arbeite seit einigen Tagen an einem FPGA Projekt im Altium Designer. 
D.h. Projekt angelegt - Schematic hinzugefügt usw.
In das Schematic habe ich Sheet Symbols eingefügt um bestehende *.vhd 
Dateien einzubinden + ports verbinden usw. Compilierung , Synthese , 
Build und dann auf das NB2 aufgespielt.

--> also die übliche vergehensweise
 die auch immer ohne Probleme geklappt hat.

doch seit kurzen tritt nun ein für mich nicht nachvollziehbares Problem 
auf:

Um das Projekt auf das NB2 zu spielen muß es Compiliert werden. Dabei 
erscheinen Fehlermeldungnen das alle port nicht mit einander verbunden 
sind obwohl sie es ja im schematic sind.

Fehlermeldung: z.B.

Sheet-Entry data3(7 .. 0) no matched to port 870,370

diese fehlermeldung wird für alle verbindungen (sowohl Leitungen als 
auch Busse) angezeigt. --> Der port an den die Leitung angeschloßen ist, 
wird mit einer roten wellen linien unterstrichen. bewegt man den 
mauszeiger auf diese wellenlinie wird die sich dahinter verbergende 
Fehlermeldung angezeigt:

Sheet-Entry data3(7 .. 0) (bidirectional)    net: NETU4_IOB(7 .. 0)
ERROR:  Shhet-Entry not linked to child sheet

Was bedeutet das? ich habe alles mit bekannte überprüft udn keine felher 
endeckt und warum kommmen diese Meldungen jetzt? vorher konnte ich das 
selbe projekt ohne Probleme auf das NB2 spielen


Gruß Dete

: Verschoben durch Admin
Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja, ist mehr für

[http://www.mikrocontroller.net/forum/platinen]

als hier, oder ? Egal.

Hast du net / bus umbenannt ?

Und was ist "Shhet-Entry" - wenn du jetzt copy paste der fehler meldung 
gemacht hast dann hast du irgendwo statt sheet Shhet" geschrieben ?

Autor: Dete Kosschlovsski (dete)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein habe kein copy/paste gemacht - das habe ich abgeschrieben , daher 
auch der schreibfehler


was meinst du mit:  Hast du net / bus umbenannt ?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.