www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ext. Int bei ATMEGA funzt nicht


Autor: Buchmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich  hab ne 4*4 Tastatur an meinen ATMega gehängt. bei fallender
Flanke sollen je nach taste die ext. interrupts 0-3 des mega128
ausgelöst werden.. ich hab die pegel am controller nachgemessen. wenn
keine taste gedrückt wurde, liegen am pin 4.92V an, bei gedrückter
taste 0.65.. bei 5V Versorgungsspannung darf die max. Spg. für ein LOW
nicht über 0.2*Vcc = 1V gehen.. aber der Interrupt wird nicht
ausgelöst.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, ohne Codeschnipsel bleibt es ein Sinnlos-Posting ...

Autor: Buchmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat sich erledigt

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.