www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Warum brennen mir die Mosfets durch?


Autor: Andi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Habe ein Prob.(siehe Anhang)
Bei der Schaltung A brennen mir die Mosfet innerhalb ca.15s durch
(werden richtig heiss).
Das Prob. konnte ich nur umgehen indem ich den AVR (und somit auch die
Gate´s) einen eigenen Trafo spendiert habe.(Schaltung B)

1. Warum ist das so ?(kann leider nichts messen da ja in ca.15s alles
vorbei ist)
2. Wie kann man solche Fehler bei der Entwicklung auf Papier schon
erkennen? (ohne das man die Schaltung aufbaut)
3. Gibt es einen andere Möglichkeit als das man einen 2.Trafo
hernimmt?

4.Anderes Thema: Wie entstört man soeine Schaltung?
  wenn ich ca.10cm mit dem Telefonhörer drankomme "hört man das Pwm
Sigal"  (PWM=1KHz)

Danke für eure Antworten.

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es mal mit einem Siebelko ?
Du hast da ein Schaltnetzteil gebaut, da sich jede Stromänderung in der
Schaltung direkt auf den Trafo auswirkt und so dein AVR sicher auch bald
den Geist aufgibt, denn der Trafo erzeugt so schöne Spannungsspitzen im
kV Bereich...

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Siebelkos haben nichts genützt.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
leider steht nicht da, welche Mosfets du verwendest und auch nicht,
welchen AVR.
Wird wohl ein Problem der Stromversorgung sein, die Spannung am Elko
sinkt bei Vollast und Nulldurchgängen der Wechselspannung zuweit ein,
um den AVR noch volle 5V zu spendieren. Dann bekommen die Mosfets zu
wenig Gatespannung -> mehr Verluste bis zum Tod.
Weitere Möglichkeit könnte fehlerhafte Masseverdrahtung sein, bei 9A
können schon erhebliche Spannungsverluste auf der Masseleitung
auftreten. Steigt das Massepotential an den Fets, sinkt die wirksame
Gatespannung am Mosfet.
Vielleicht auch eine Kombination aus beidem.
Was kannst du tun:
-logic-level-Fets verwenden
-Masse ordentlich führen
-low-drop-Regler verwenden
-den Regler durch eine weitere Diode und Elko vom Lastkreis entkoppeln

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die Mosfet´s sind die irlr2905 (logik level).
avr ist mega8535 (ist aber egal, wenn ich es mit normalen Schaltern
mache ist es das gleiche)
Das mit der Diode werde ich mal ausprobieren.

Autor: Mario (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mann, irgendwie nervt das. Musst du für so ne Pisschaltung so ein riesen
JPEG hier ins Forum stellen ? Nicht jeder hat DSL und ich Idiot habs
jetzt auch noch runtergeladen in der Hoffnung das es was bringt. Im
Anhang noch mal die Schaltung für arme Modembesitzer.

Mario

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entschuldigung, habe nicht dran gedacht das es noch Modembesitzer gibt.

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
zur 4.Frage: Wie mache ich die Entstörung? Ist das bei der Schaltung
überhaupt möglich?

Autor: Thany (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fehler ist nich AVR, sondern die Ausgangsteuerung.
probiere mit einem Wiederstand (1k) von der Gate gegen Masse,
damit die Restladung bei der Sperrphase entlädt.

Gruss

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andi,

wenn Du keine speziellen Logiklevel Fet's benutzt hast, dann benötigen
alle anderen Fet's mindestent 10V Ugs um niederohmig durchzusteuern.
Einen Ladeelko (habe ich Die schon im anderen Posting empfohlen)
brauchst Du in jedem Fall für eine ordentliche Schaltungsauslegung.

MfG  Manfred Glahe

Autor: Benedikt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>zur 4.Frage: Wie mache ich die Entstörung? Ist das bei der Schaltung
>überhaupt möglich?

Ich denke das ist erstmal das geringste Problem. Versuch erstmal die
Schaltung zum Laufen zu bekommen, dann kann sich das Problem von selbst
lösen.
Ändere mal die Software so, dass alle Lampen dauerhaft an sind und mess
dann die Spannungen am MOSFET:
Drain-Source
Gate-Siurce

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK, Ladeelkos hänge ich auch noch dran.
Der irlr2905 ist ein Logiklevel Fet.

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung funktioniert auch prima, aber nur wenn ich einen 2.Trafo
einsetze.

Autor: Patric (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- Du brauchst direkt hinter dem Gleichrichter einen Elko zum glätten,
sonst hast du jede Netzschwankung 1:1 in deiner Schaltung

http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.9

- Zum Entstören der Versorgung setzt Du vor jeden Versorgungspin des
AVR einen 100n Kerko (nach Masse). So wie du das schon eingezeichnet
hast, aber direkt an den Pin. Auch AREF, AVCC falls es die bei deinem
AVR gibt.

- Bei MOSFETs setzt man in die Gatezuleitung einen kleinen Widerstand
(10-50 Ohm) um unschöne Schwingungen zu vermeiden. Die Induktivität der
Gatezuleitung und die Gatekapazität bilden einen Schwingkreis. Diesen
dämpft man mit einem Gatevorwiderstand.

Autor: Thany (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem bei der Schaltung ist die Ausgangsteuerung. Wo soll
bitte die Restladung bei der Sperrphase hin fliessen ?
Wie wärs wenn du mit einem Widerstand (ca. 1k) von der Gate gegen Masse
anschliesst ?

Gruss

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit den Widerstand "Gate gegen Masse" werde ich mal ausprobieren, habe
vorher 56k dringehabt hat aber nichts genützt.
Werde mal 1k ausprobieren.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
daran liegts nicht, zumindest nicht, wenn der AVR-Pin als Ausgang
definiert bleibt (DDRx=1).

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andi,

da mußt Du mal die GS Spannung messen mit dem Oszi. Desweiteren die DS
Spannung um zu sehen ob die Schaltung schwingt.
Alles andere nur zu probieren ist ab nun nicht mehr sinnvoll.

MfG  Manfred Glahe

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Manfred.
Das würde ich ja gerne(Oszi habe ich), aber wenn in nur ca.15s alles
durchbrennt,kommt ich ja mit dem nachkaufen und löten der fet´s nicht
mehr raus.
Werde wohl oder übel der Schaltung einen 2.Trafo spendieren müssen.
Gehört zwar nicht hierher ,aber habe schon mal das selbe Prob.bei
direkt geheizten Röhren gehabt,musset auch jede Heizung an eine eigene
Trafowicklung hängen.
Wie sieht es mit der Entstörung aus? Reicht es ein Snubber(300nf,10
Ohm) an drain und masse zulegen?

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andi,

hatte ich noch vergessen, beachtest du den Spitzenstrom des Fet? Die
Lampen haben im kalten zustand Fast 0R. Beim Erwärmen der Lampen kann
(vor allem wenn der Fet nicht richtig Durgesteuert wird) der Fet schon
überlastet werden. Schalte doch einfach mal 2 Lampen in Reihe und miß
die GS und DS Spannung. Du brauchst dafür nur einmal E/A schalten und
das zerstört ihn ja nicht. Ohne messen tappst du im Dunkeln.

MfG  Manfred glahe

Autor: Heinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halogenlampen?
Die sind kalt extrem niederohmig...
Glühlampen sind sowiso Kaltleiter, da muss man auch an den
Einschaltstrom denken, der ein Vielfaches des Dauerstroms (warm)
beträgt. Deine MOSFETS müssen also mehr als 3A aushalten.

Auch dein Trafo wird beim Einschalten der kalten Lampen etwas in die
Knie gehen, das kann er zwar ab, aber seine Spannung bricht ein.

Deshalb unbedingt eine Diode von + (da wo der Ladeelko hin muss) zum
Spannungsregler und dort noch einen Elko zum Überbrücken der
Nulldurchgänge und evtl. Spannungseinbrüche an den Reglereingang
(zusätzlich zum 100nF).

Ladeelko alleine bringt nicht sehr viel, weil den die Lampen in
Nullkommanix leerlutschen. Es muss also ein von der Last abgekoppelter
Ladeelko sein. - Oder ein zweiter Trafo... - Oder Batterien...

MfG, Heinz

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werde heute Abend den Tipp ausprobieren mit der Diode und zusätzlichen
Ladeelko zum Lastabtrennen. (Klingt ziemlich logisch)

Wie sieht es mit dem Sunbber aus?(300nf,10 Ohm) ,Habe ja noch dann das
Prob.mit der Störstrahlung.(z.b. Telefon oder PC-Brüllwürfel die in der
nähe Stehen).

@Manfred ,Der irlr2905 kann ca.50A ab.Der wird nicht mal warm, wenn ich
eine einzelne Lampe schalte (mit 2.Trafo).

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andi,

"(vor allem wenn der Fet nicht richtig Durgesteuert wird)"

Wenn Dein Problem, wie Du nun schreibst, mit einem 2. trafo nicht mehr
auftritt, dann kann es nur noch die Ansteuerung sein. Und dann eben
Spannungseinbrüche vor Regler.

MfG  Manfred Glahe

Autor: Thomas Oly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

also ich denke das bei der ersten Schaltun gentweder der Trafo zu
schwach dimensioniert ist so das die Spannung beim Schalten der Lampen
soweit runtergeht das der LM7805 nicht mehr genug Spannung erhält.
Weiterhin könnte es sein das das schalten der Lampen Induktionsspitzen
erzeugt die dann in den 7805 durchschlagen
selbst wenn die IRL's ne Diode drin haben sollte man noch jeweils eine
antiparallel zu den Lampen anschließen. Und eine
Überspannungsschutzdiode vor den LM7805 setzten damit dieser z.b. nicht
mehr wie 9V abbekommt dann muss er auch nicht so stark regeln. Es könnte
auch helfen einen großen 10.000µF Elko nach den Gleichrichter zu
setzten, dieser läßt die Spannung bei kurzzeitiger Belastung nicht so
stark einbrechen. Probier es  mal mit kleineren PWM werten. Ich hatte
mal das Problem das ein IRF540 oder war es ein BUZ11 zu heiß geworden
ist bei kelinen Frequenzen erst ab dem kHz Bereich funktionierte es.

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Leute.
Jetzt funktioniert es.
Die Diode um den Lastkreis und den 7805 zu entkoppeln hat gefehlt.
Jetzt habe ich nur noch das Prob. mit Störsignalen die,die Schaltung
verursacht.
Habe es schon mit einen Snubber versucht,aber keine erkennbare
Verbesserung.
Hat jemand eine Lösung?
Das PWM Signal hat 1Khz(ist fest,da später ein DS1050 das Pwm Signal
erzeugt)/ Spannung 12V= /Strom pro Lampe ca.3A/Last gesamt ca.9A.
Ich hoffe Ihr könnt mir wieder helfen.

Autor: Thomas Oly (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hab hier mal dein Bild etwas verändert.  Ich würde parallel zur Lampe
eine schnelle Diode hängen und dazu einen Folienkondensator mit einer
Spannungsfestigkeit von mind. 60V besser 100V das sollte schon genügen.
Dazu kannst du noch ne Diode setzten damit keine negativen
Spanungsspitzen zum Gleichrichter durchschlagen was eigentlich garnicht
mehr passieren sollte und ein Elko würde das ganze auch etwas stabiler
halten. Also probiere erstmal die parallele Diode und den
Folienkondensator das sollte schon reichen, so mach ich es immer, hatte
es mal beim Taktventil da hatte ich Spannungspitzen von -100V und es hat
beides geholfen Diode oder Folienkondensator.

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Lampe ist ein ohmscher Verbraucher, die hat nur extrem wenig
Induktivität und braucht deshalb kaum beschaltet zu werden. Wie lang
ist z.B. die Zuleitung zur Lampe, die wirkt als Sendeantenne.
Ist auf der Platine der GND ordentlich entkoppelt zwischen dem
Leistungsschalter und dem Rest der Schaltung?

MfG  Manfred Glahe

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Thomas Oly
Danke, welchen Wert für den Foli.Kond. würdest Du hernehmen ?

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Manfred Glahe
Die Leitungen sind ca.15cm pro.Lampe lang von Fet aus.
Die Spannungsversorgung ist ca.3 Meter weg.

Autor: Thomas Oly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

bei meinem Taktventil ca. 1 Ampere Stromverbrauch hatten 470nF
gerreicht. Würde dir aber eher 1-2µF empfehlen da die ja 3mal soviel
ziehen. Kannst ja die Diode in der Plusleitung ziemlich nah vor die
Lampe setzten damit deine Leitung nicht als Antenne fungiert, der große
Elko verhindert aber auch das Senden da er ja alles glettbügelt. Aber
generell die Leitungen so kurz wie möglich halten.

Autor: Andi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gut,
Hilft es auch was wenn ich die Leitungen der Lampen Abschirme (Schirm
mit GND verbunden) oder soll ich die SV Leitung auch noch Abschirmen?
(Das mit dem I2C Bus ist ja klar das der eine Schirmung braucht bei der
Länge)

Anbei der Lageplan.(Diesmal auch für Modembesitzer ;-))

Autor: Manfred Glahe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Andi

"Die Leitungen sind ca.15cm pro.Lampe lang von Fet aus.
Die Spannungsversorgung ist ca.3 Meter weg."

Das ist optimal, zusammen mit den vorgeschlagenen Stützkondensatoren,
paralell zum Elko AUCH einen 0.1µ Keramikkondensator weil nur der
extrem schnell den Startschaltstrom abgeben kann, muß das störungsfrei
funktionieren. Was ist mit den GND Rückleitungen auf der Platine? Bitte
so führen, daß ein Spannungsabfall auf diesem Leiter nicht zur Anhebung
des GND am Steuerbaustein führt.

MfG  Manfred Glahe

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, die Leiterbahnen sind breit genug,hab jetzt zwar meine Tabelle nicht
dabei,aber bei 10mm halten die ca.14A aus.

Werde mich wieder melden, wenn ich die Entstörung gemacht habe.

Autor: Alex (Gast)
Datum:
Angehängte Dateien:
  • preview image for NT.GIF
    NT.GIF
    11,3 KB, 182 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Falls das hier noch benötigt wird. Ich baue solche Netzteile so auf
(siehe Anhang). Hat noch nie gesponnen und die Teile blieben Heil.

Autor: Quark (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
finde ich sehr interessant, aber ich bin zu doof Euch zu folgen. ;-(
(wo welche Kondensator mit welcher Diode...)
Könnte jemand bitte einmal die neue Gesammtschaltung posten, wäre
wirklich nett!
Danke
Quark

Autor: Walter B (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm ein Oszi und prüfe den FET auf sauberes durchschalten. Evtl. sind
die flanken am AVR nicht steil genug. Außerdem sollte man die
Schaltrate wegen den Umschaltverlusten nicht unnötig hoch treiben. Bei
Glühlampen reichen 200Hz völlig aus.

Autor: Heinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

@Alex:
Bin mit deiner Schaltung ganz deiner Meinung, von folgenden
Kleinigkeiten mal abgesehen:

- Wozu C7? - Ich hätte Bedenken, mir damit Störspitzen auf den
  Regler zu holen, für die die Diode zu langsam ist. Die anderen
  C's hätte ich genauso dimensioniert.

- R2/R1 (R4/R3, R6/R5) hätte ich anders dimensioniert, damit mir
  nicht 1/3 der Steuerspannung verloren geht und damit die
  Möglichkeit der direkten Ansteuerung per AVR ohne FET-Treiber-IC.
  R2 etwas niederohmiger, R1 so hoch, dass der FET ohne Ansteuerung
  noch sicher sperrt, auch noch, wenn die AVR-internen Pullups
  aktiviert sind (Programmierfehler!), aber mit R1 keinen
  nennenswerten Spannungsteiler mehr bildet. Die schnelle Ableitung
  der Gate-Ladung geschieht über die auf L gelegten AVR-I/Os.

Nunja, ich denke an direkte Ansteuerung vom AVR, mit den I²C-PWM-
Chips kann das anders sein, damit habe ich mich noch nicht befasst.

Das Wichtigste an deiner Schaltung ist aber der zentrale
Massepunkt!!! Das entstellt zwar die Zeichnung etwas, ist aber
zum Verständnis so notwendig.

MfG, Heinz

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.