www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Quarzoszillator hörte auf zu schwingen - STK500 hörte auf Kontakt zu bekommen


Autor: Upi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein ziemlich blödes Problem.

Vor ein paar Tagen war ich mit dem Bestücken eines Boards fertig. 
ATMega644 mit 18.432MHz Quarz und 15pF Kondensatoren.

Dann bin ich mit dem STK500 und dem AVRStudio ran und habe mal die 
Signatur gelesen. Ging. Die Fuse für das Ausgeben des Taktes umgestellt 
und auf externen Quarz. Ging auch. An dem CLKOUT-Pin kamen die 
18....MHz.

Heute wollte ich ein Programm raufspielen. Zuerst konnte ich noch die 
Signatur lesen. Die Fuses wurden auch gelesen. Beim Programmieren waren 
ein paar Einstellungen falsch, z.B. wurde ein EEPROM-File noch von einem 
vorherigen Projekt geschrieben. Während ich so am hin- und herblättern 
war, sagte er auf einmal das er beim Programmieren die Signatur nicht 
lesen könnte. Habe manuell das lesen angefordert. Es ging. Naja, das 
STK500AVRStudio spinnt manchmal. Dann sofort wieder ein Problem.
Wieder manuelle die Signatur gelesen. Geht, geht mal nicht. Immer öfter. 
Dann nach ca. 2 Minuten garnicht mehr.

Mit dem Oszi den Takt gemessen. Kein Takt mehr. Mit dem Finger auf den 
Lastkondensatoren krieg ich den Taktausgang zum toggeln (so mit 6Hz) 
aber das war es auch schon. Lötstellen nachgesehen und nachgelötet. Geht 
nicht. Die Platine wieder aus dem Gehäuse genommen. Geht auch nicht. Ich 
habe die Lastkondensatoren entfernt. Aber leider bringt das auch nichts.

Ich bin völlig verblüfft, das die die Funktionsfähigkeit so graduell 
immer mehr abnahm und habe keine Ahnung was das sein kann.
Die Spannungen stimmen an sich.

Hat jemand eine Idee?

Autor: Upi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat sich erledigt.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was war´s denn?!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.