www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik DMX Interface von digital-enlighment läuft nicht


Autor: Die Angabe einer Email-Adresse ist freiwillig (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
mein DMX-Interface läuft leider nicht. Das heißt, es wird beim 
einstecken in die USB-Buchse nichts erkannt.

Die meisten Fehler kann ich ausschließen. Hab die Debug-Anleitung von 
dem 'Erfinder' durchgearbeitet.

Was ich nicht überprüfen kann ist die Programmierung des uPCs. Ich habe 
deshalb mal die FUSE-Anleitung angehängt. Wäre nett wenn mir jemand den 
Ponny-Prog Screenshot in AVR-Studio übersetzen kann.
Also was ist der hexwert für die L bzw die H Fuse?

Vielen Dank.

Autor: Die Angabe einer Email-Adresse ist freiwillig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann das denn wirklich keiner? dann wunderst mich nicht warum das ding 
bei mir nicht läuft...

Autor: Die Angabe einer Email-Adresse ist freiwillig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hätte ich echt nicht gedacht dass mir hier keiner helfen kann/will.

Bin sehr enttäuscht...

Autor: Die genaue Beschreibung des Problemes ist auch fre (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein 8515 mit USB?
Keine Angaben welches Interface.

Ponyprog einstelungen sind etliche im Web.

Da wundere ich mich nicht, dass da keine Antworten kommen.

Kannst auch fragen warum die LED nicht leuchtet.

Autor: Der verrückte Professor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also gut,
es tut zwar nichts zur sache, aber dennoch:

Es ist das DMX-interface von digital enlighment.
http://www.digital-enlightenment.de/usbdmx.htm

Wenn man die Komprimierte Projektdatei herrunter läd, dann ist darin ein 
pdf-file mit einer debug Beschreibung.

Der Quarz schwingt an, der USB Transiever generiert den Takt für den 
uPC.
Alle Bauteile haben Versorgungsspannung.
Das Interface beim einstecken nicht erkannt.
Das Brücken von Emittor und Collector bringt auch keine Abhilfe.

Ich denke nun das an der Programmierung des uPCs irgendwas falsch ist. 
Da ich mit AVR-Studio Programmiere würde ich mich sehr freuen, wenn mir 
irgendjemand die Ponny-Prog Fuses in die Hexadezimalen H und L Fuses ür 
AVR-Studio übersetzt.

Danke

Autor: oioioioioi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Push!

Autor: Die Angabe einer Email-Adresse ist freiwillig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Push!

Was soll denn bitte das sein?

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Angabe einer Email-Adresse ist freiwillig schrieb:
> Hätte ich echt nicht gedacht dass mir hier keiner helfen kann/will.
>
> Bin sehr enttäuscht...

Von wem denn?
Heißt das Forum etwa "Supportabteilung von digital enlighment"?
Nein!

Es gibt Milliarden von Schaltungen und Programmen, keiner kann die alle 
kennen.

Man kann im Forum ruhig alles fragen, vieleicht weiß ja doch jemand was 
dazu.
Fordern oder Drängeln bringt aber genau 0,nix. Es kann dann leicht 
passieren, daß jemand den Troll füttert.


Peter

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frag lieber bei www.dmxcontrol.de nach.
Da kennen sich genug mit dem Interface aus.

Autor: Stephan B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Frag lieber bei www.dmxcontrol.de nach.
> Da kennen sich genug mit dem Interface aus.

Hab mein DE-DMX Interface seit vorgestern Abend fertig und ein ganz 
ähnliches (wenn nicht das selbe) Problem, habe ich in dem von dir 
genannten Forum mal eine Anfrage gestellt. Danke für den Link!
Habe bisher nur an den 'Erfinder' eine Mail gesandt - aber ich befürchte 
dass 1000 andere auf die selbe Idee kommen und daher das Postfach 
ständig überläuft und so meine Mail ungesehen nach /dev/nul verschoben 
wird ;-)

Evtl. hat das ja 'Die Angabe einer Email-Adresse ist freiwillig ' auch 
weitergeholfen! :-)

Autor: Die Angabe einer Email-Adresse ist freiwillig (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und wo? Ich kann es nicht finden!!!

Autor: Michael Dreschmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Habe bisher nur an den 'Erfinder' eine Mail gesandt

Das schon gelesen?:
"Bitte haben sie Verständnis dafür, dass wir auf allgemeine Fragen zu 
Details oder Problemen mit den Projekten per E-Mail nicht antworten. 
Diese gehören ins Forum. Bitte beachten sie auch unsere FAQ's."

Aber in der Regel antworten wir sogar trotzdem auf die Mails. Ich bin 
allerdings nicht 24/7 online und mache nich hauptberuflich kostenlosen 
DE Support...

Ungefähr jeder dritte Thread in unserem Forum geht ums 
Fuse-Programmieren, incl. Aussagen wie "die Fusebytes müssen 0xBF 0xD9 
sein."

Der allererste Eintrag in der FAQ lautet:
"Beim AVR Studio 4 sind die Fuses und Logbits nicht nur per Kästchen 
einzustellen, sondern manche per Dropdownmenü. Ich möchte mir nicht 
extra noch einen low cost Programmer bauen. Kann mir jemand sagen wie 
ich die Fuses und Logbits unter AVR Studio 4 setzen muss?"

Und das steht da nicht erst seit gerade eben...

Weiterhin steht auf der Seite:
"Weiterhin möchte ich darauf hinweisen, dass sich die hier vorgestellten 
Schaltungen nicht für blutige Anfänger eignen. Man sollte schon ein 
wenig Erfahrung in Sachen Elektronik und Löten mitbringen."

Und dazu gehört auch n gewissen Grundlagenwissen im 
Mikrocontrollerprogrammieren, was man z.B. im Tut auf dieser Seite 
(mc.net) erlangen kann.
Wenn ich dann Fragen lese wie "Und ich habe auf dem Massepin eine 
Spannung von -2,19V ist das richtig???", dann ist einfach klar, dass 
hier Null Grundlagenwissen vorhanden ist und der Aufbauer besser bedient 
wäre, sich das IF zu kaufen anstatt es nachzubauen un womöglich seinen 
PC zu schrotten.

Mfg,
 der Erfinder

Autor: Stephan B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank.
Um ehrlich zu sein bin ich noch nicht auf die Idee gekommen in die FAQs 
zu schauen, bzw. ich hab sie schlicht übersehen.

Meine Aussage von oben soll nicht als Vorwurf zu versehen sein! Ich hab 
Verständnis dafür, dass man neben Hobby auch noch einen Beruf und eine 
Familie hat und die gehen vor.

Als absoluten Beginner möchte ich mich nicht bezeichnen ;-) Nach dem 
nachmessen war mir klar dass ich mich verfused haben muss!
Ist ja auch eine gemeine Stolperfalle mit mit Ponnyprog und den Fuses 
:-(
Nochmal wird mir das aber nicht passieren.

>Wenn ich dann Fragen lese wie "Und ich habe auf dem Massepin eine
>Spannung von -2,19V ist das richtig???

Die Aussage kam aber nicht von mir... ;-)

Somit 1000 Dank für die Antwort.
Cosphi

Autor: Stephan B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider kann ich meinen eigenen Beitrag nicht mehr bearbeiten.
Nun läuft es... Es war tatsächlich ein Fuse-problem.

Danke für die Hilfe!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.