www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik LM2575 Netzbrummen


Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich hab mein Problem mit dem Brummen/Pfeifen in meinem Mischpultprojekt, 
dass ich in

Beitrag "Mein Summierverstärker pfeift :-("

beschrieben hatte jetzt zu meiner Stromversorgung zurückverfolgt. Da ich 
kein Oszi habe, eben mit Kopfhörer und Poti frei Ohr sozusagen.

Ich verwende den LM2575 um aus 12V einmal 5V und einmal -5V zumachen, 
entsprechenden der Schaltungen, wie sie im Datenblatt angegeben sind.

Eingangskondensator 100µ
Ausgangskondensator 470µ

Beim Step Down eine Spule mit 330µ und beim Inverter mit 100µ

Am Ausgang der +5V höre ich nur ein ganz schwaches brummen, aber 
natürlich wäre es schön, auch das wegzubekommen.

Bei den -5V brummt es richtig heftig, eindeutig so um die 50Hz, so dass 
ich annehme dass es Netzbrummen ist. Wie kann ich meine Spannung 
filtern?

Gruß

Tom

Autor: peta (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab keine ahnung, aber vllt. mit sowas

http://de.wikipedia.org/wiki/Drossel_(Elektrotechnik)

Autor: TrippleX (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wird eine Brummschleife sein also wird es am Layout,Aufbau etc.
liegen.

Am LM2575 kann es nicht liegen da diser mit 52Khz taktet und außerhalb
des hörbaren bereich liegt.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

>Da ich kein Oszi habe, eben mit Kopfhörer und Poti frei Ohr sozusagen.

Wie hast du denn den Brumm "gemessen"? Wo hast du den Kopfhörer 
angeschlossen?

Woher hast du die 12V am Eingang der Regler? Ist die Spannung dort gut 
gesiebt, oder hast du dort schon viel Brumm?

Kai Klaas

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Kai,

ich hab den Kopfhörer einfach mit dem Poti in Reihe ziwschen -5V und GND 
angeschlossen.

Die 12V kommen von einem stabilisierten Netzteil und wie Du schon 
richtig vermutest ist auch dort schon ordentlich Brumm drauf. Diese 
verschwindet aber hinter dem LM2575 für die +5V fast komplett, hinter 
dem Inverter wird es sogar eher noch stärker.

Gruß

Tom

Autor: Georg A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das

> Die 12V kommen von einem stabilisierten Netzteil

und das

> ist auch dort schon ordentlich Brumm drauf

ist schon mal sehr verdächtig. Wo soll da insb. beim Test mit Kopfhörer 
eine Brummschleife entstehen, die so heftig hörbar sein soll?

Entweder ist bei dem -5V-Aufbau noch ein Bug (die Metallfahne ist da ja 
nicht mehr GND sondern -5V, gibts da irgendwo einen Kurzschluss?) oder 
die 12V sind so brummverseucht bis nahe 0V runter, dass der Inverter das 
nicht mehr ausregeln kann.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

>Die 12V kommen von einem stabilisierten Netzteil und wie Du schon
>richtig vermutest ist auch dort schon ordentlich Brumm drauf. Diese
>verschwindet aber hinter dem LM2575 für die +5V fast komplett, hinter
>dem Inverter wird es sogar eher noch stärker.

Häng mal alles ab, bis auf den Inverter, und schau, ob dann immer noch 
Brumm da ist. Damit überprüfst du, ob nicht doch eine Brummschleife für 
den Brumm verantwortlich ist.

Ist dir aufgefallen, daß im Datenblatt des LM2575 am Ausgang des 
Inverters ein riesiger Elko sitzt? Schalte doch mal zwei oder drei von 
deinen 470µF Elkos parallel und berichte, ob der Brumm weniger wird.

Also, ganz generell sind Switcher bei einer Analogschaltung eher nicht 
zu empfehlen, gerade wenn du beispielsweise Mikrofonverstärker speisen 
willst. Linearregler sind da die erste Wahl. Du könntest aber, wenn du 
nur diese 12V zur Verfügung hast und da nichts ändern kannst, statt der 
+/-5V besser +/-8V erzeugen und dahinter Linearregler vom Typ 7805/7905 
schalten. Dann ist der Brumm auf jeden Fall weg. Den sternförmigen 
Massepunkt wählst du dann am besten dort, wo die beiden Massepins dieser 
Linearregler ganz nahe bei einander sitzen, also "weit" weg von den 
Switchern!

Kai Klaas

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hab das ganze jetzt noch mal ganz sauber mit einem DIP16 Gehäuse 
aufgebaut und bisher ist es ruhig.

Gruß
Tom

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Also, ganz generell sind Switcher bei einer Analogschaltung eher nicht
> zu empfehlen, gerade wenn du beispielsweise Mikrofonverstärker speisen
> willst. Linearregler sind da die erste Wahl. Du könntest aber, wenn du
> nur diese 12V zur Verfügung hast und da nichts ändern kannst, statt der
> +/-5V besser +/-8V erzeugen und dahinter Linearregler vom Typ 7805/7905
> schalten.

Im Prinzip richtig, aber dann erzeugt man lieber nur so um 1V mehr und 
nimmt einen LDO-Regler (mit möglichst hoher "ripple rejection"). Es soll 
ja ein Mischpult werden und keine Heizung ;-)

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Im Prinzip richtig, aber dann erzeugt man lieber nur so um 1V mehr und
>nimmt einen LDO-Regler (mit möglichst hoher "ripple rejection"). Es soll
>ja ein Mischpult werden und keine Heizung ;-)

Du hast natürlich Recht. Aber bedenke, auch LDOs haben ihre Tücken. Die 
wollen eine ganz bestimmte Kapazität am Ausgang, sonst fangen sie an zu 
schwingen. Vielleicht nicht genau das richtige für Thomas.

Wie groß ist denn der Versorgungstrom überhaupt? Kaum mehr als 100mA, 
oder? Dann wären ja nur 300mW pro Regler zu "verheizen".

Kai Klaas

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...bei den modernen reichen aber oft schon ~4,7µ keramisch (hat dann 
Bauform 0805 oder ähnlich "gross").


Und 0,6W auf kleinem Raum können auch schon etliche Grad sein.

Mal sehen - angenommen TO220-Gehäuse ohne weitere Kühlung:
65°C/W * 0,3W = 19,5°C Temperaturerhöhung.
Nicht wirklich kritisch. Bei 500mA tut's dagegen schon weh...

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kurzes Update:

Vielen Dank für Eurer Bemühungen. Mit der neuen Stromversorgung ist 
keinerlei Rauschen oder Knistern mehr zu hören.

Auch mit dem PGA2311 läufts jetzt problemlos ohne Knistern.

Gruß
Tom

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Thomas
>Mit der neuen Stromversorgung ist keinerlei Rauschen oder Knistern mehr
>zu hören.

Was hast du jetzt genau geändert? Ich habe nur gelesen, daß du jetzt ein 
DIP16 Gehäuse verwendest. Was meinst du genau damit?

Kai Klaas

Autor: Thomas Burkhart (escamoteur)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Kai,

ich hatte bisher Regler in dem furchtbaren TO-220 verbaut gehabt und 
wild verdrahtet.

Mit den DIP16 Gehäusen geht das viel sauberer und ich hab diesmal sehr 
auf die Masseführung geachtet.

Jetzt ist so gut wie Rauschfrei, selbst nachdem ich noch weitere OPVs 
und noch einen PGA im Signalpfad habe.

Danke euch allen und lieben Gruß
Tom

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.