www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Actel A3P250 + Fox Board LX 832 Probleme beim flashen


Autor: Horst Pobes (skyline33)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin mir nicht sicher, ob man mir bei diesem Problem helfen kann, 
aber so langsam bin ich mit meinem Latein am Ende, daher versuch is mal.

Folgendes Problem: Ich versuch schon seit 3 Tagen mein Projekt, dass ich 
mit Actel Libero 8.6 erstellt habe auf den FPGA zu bringen, aber es 
funktioniert einfach nicht, da er mir zwar nach 1 sek eine Antwort gibt 
"erfolgreich geflasht", aber es ist eigentlich nichts passiert, da es 
normalerweise schon so ca 20 sek dauert bis das Programm aufgespielt 
ist.

Ich verwende diese Anleitung hier: http://foxlx.acmesystems.it/?id=121 
um das Programm aufzuspielen.

Nach 3 Tagen habe ich nun festgestellt, dass irgendwas bei der 
Erstellung der stp Datei falsch laufen muss, da wenn ich ein Programm 
von der oben genannten Homepage runterlade, das flashen einwandfrei 
funktioniert. Aber wenn ich vom gleichen Quellcode mit meinem Libero die 
stp Datei erstelle, gehts wiederum nicht.

Ich hab so ne Vermutung, dass die Libero Version die ich habe zu neu ist 
und das Fox Board, die stp nicht akzeptiert, aber ich kann keine ältere 
Libero Version finden und nen Update fürs
Foxboard gibt auch nicht...

Falls jemand ne Idee hat, wäre ich sehr dankbar:-)

Autor: Antti Lukats (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was fur software benutzt du zum flashen?
normalweise sollte man ja PDB dateien benutzen

Antti
PS bei mir gehen alle PA3 bis jetz

Autor: Horst Pobes (skyline33)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Antti,

ich benutze das Webinterface von dem Fox Board. Connecte über Firefox 
oder irgendein anderen Browser. Das klappt an sich auch alles nur das 
sich die stp. datei die ich erstellte habe nicht auf den FPGA flashen 
lässt.

Es kann gut sein, dass man mit der neuen Libero Version, nur noch mit 
der PDB Datei flashen kann, aber dafür brauch ich ja nochmal eine extra 
Hardware, oder?

gruß Jürgen

PS: Die Hardware an sich hat keinen Fehler, bei einem Baugleichen System 
tritt derselbe Fehler auf...

Autor: Ansgar Kern (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Horst,

bei mir tritt genau das gleiche Problem auf. Meine Abhilfe: Zum 
Erstellen der STP-Dateien verwende ich die Libero Version 7.1. Meine 
beidenden neuernen Versionen 8.4 und 8.6 erstellen STP-Dateien, die um 
ca. 10% groesser sind und sich nicht mit dem Web-Interface auf das FPGA 
uebertragen lassen.

Gruss,

Ansgar

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.