www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MAX6675 Phänomen


Autor: danny (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

ich habe hier ein mir unerklärliches Phänomen mit einem MAX6675.

Ich habe ein Thermoelement angeschlossen und messe bei Raumtemp. 
40Grad!?!?

Im Anhang sieht man die SPI-Kommunikation (grün=Takt, gelb=Daten)

x000010100000xxx

Wie kann das sein?

Autor: danny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, ich beantworte meine Frage jetzt mal selbst :)

Timing falsch!

Ich hatte ursprünglich (wie im Datenblatt beschrieben) die 16Bit auf die 
fallende Flanke gelesen; Jetzt lese ich auf SCK=HIGH und schon gehts!

ciao

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.