www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Lichtschranke/Stoppuhr Bausatz


Autor: DerBuddy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hoffe ich bin hier richtig und es kann mir jemand helfen. Zur 
Zeitmessung auf einer kleinen Modellbau-Rundstrecke hab ich mir einen 
Lichtschrankenbausatz von Kemo gekauft und troz mangelhafter 
Elektronikkenntnisse auch zum Funktionieren gebracht.

Hier mal ein Link mit Anleitung und Schaltplan (auf Seite 9 und 10):

http://www2.produktinfo.conrad.com/datenblaetter/1...

Das Problem ist folgendes: Die Stoppuhr auf der Platine kann per 
Unterbrechung der Lichtschranke gestartet werden, um sie dann aber 
wieder per Lichtschranke zu stoppen, muss zuerst ein Taster per Hand 
betätigt werden (S1 im Schaltplan). Es kann auch von Hand (Taster S2) 
gestartet und per Lichtschranke gestoppt werden. Starten und Stoppen per 
Lichtschranke ohne zwischendurch ein Knöpfchen zu drücken ist nicht 
möglich.

Hat irgenwer Erfahrung damit und gibt es irgendeine Möglichkeit das zu 
ändern, so dass ich ganz normal Rundenzeiten ablesen kann?
(Oder Alternativ -falls obiges nicht funktioniert- ist mit dieser 
Platine ein Anschluss an den PC möglich? Und wenn ja wie?.)


Danke schonmal und beste Grüße

: Verschoben durch Admin
Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du nicht einfach deinen "taster" mit der licht schranke 
verbinden, so dass beim start der taster gleich mit "gedrückt" wird?

wäre für mich die einfachste lösung kenne die schaltung aber nicht...

Autor: DerBuddy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wüsste jetzt nicht wie. Meinst du, dass der Taster mechanisch gedrückt 
wird? Mit nem Servo oder so?. Das wär wahrscheinlich irgendwie schon 
machbar ... aber nicht für mich ;-)... oder wenn dann nur mit viel 
Aufwand.

aber danke trotzdem, wär immerhin ne Möglichkeit; der Schaltplan is in 
dem Link vom ersten Beitrag vielleicht hat ja noch jemand ne Idee?


beste Grüße

Autor: Guido (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schöner Bausatz für Einsteiger (bis auf die "versteckten" Transistoren 
im 513D). Allerdings ist die Beschreibung beim C* etwas "traurig". Etwas 
besser Infos findest Du bei Kemet.

B232 - Infrarot-Stoppuhr
http://www.kemo-electronic.com/de/bausaetze/b232/index.htm
Vielleicht bringt der folgen Artikel etwas Licht ins Dunkel ;-)
http://www.kemo-electronic.com/eam/b232/eam_b232.pdf

Es gibt auch noch eine zusätzlich Lichtschranke
B232Z - Zusatz-Infrarot-Lichtschranke für Infrarot-Stoppuhr B232
http://www.kemo-electronic.com/de/bausaetze/b232z/index.htm
Auch hierzu einen weiterführenden Artikel
http://www.kemo-electronic.com/eam/b232z/eam_b232z.pdf

Vielleicht helfen Dir die Artikel Deine Schaltung zu verstehen und somit 
Dein Problem zu lösen.

Mit freundlichen Grüßen
Guido

PS.: Ohne mir die Schaltung allzu genau angeschaut zu haben würde ich 
sagen, das Du das FlipFlop auf dem Uhrenmodul "umbauen" musst. Ggf. zu 
einem Monoflop mit sehr kurzer Schaltzeit. Wenn Du das FlipFlop ganz 
ausbaust bekommst Du u. U. Probleme mit Mehrfachauslösungen.

Autor: DerBuddy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke für die Mühe. Die Artikel helfen mir beim Verständnis schon ein 
ganzes Stück weiter ... und der Tipp mit dem FlipFlop scheint mir 
einleuchtend. Dummerweise hab ich halt echt keine Ahnung wie ich daraus 
einen Monoflop machen kann (um ehrlich zu sein musste ich erstmal google 
befragen was das überhaupt ist ;)).
Ich versuchs weiter, wär für Hilfe aber immernoch dankbar.

Beste Grüße

Autor: Uli (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

vielleicht kann auch mir jemand helfen. Ich habe den Kemo-Bausatz 
zusammengebaut, leider macht das Uhrenmodul bei mir keinen Mucks, d.h. 
die Anzeige der Uhr bleibt einfach aus. Ich bin mir sicher, alles 
richtig bestückt und nichts gebraten zu haben. Ich habe die Platine nun 
einmal durchgemessen und die Messwerte in den Schaltplan eingetragen und 
diesen angehangen. Vielleicht findet sich jemand, der dieses Modul schon 
mal gebaut und Erfahrung damit hat.
Ich würde mich über Hilfe jeder Art sehr freuen.

Vielen Dank & viele Grüße
Uli

Autor: Oush Oush (oush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo DerBuddy,

bin über diesen Thread gestolpert, obwohl er schon paar Jährchen auf dem 
Buckel hat ;-)
Habe genau das gleiche Problem wie du.
Jemals eine Lösung gefunden?
Wäre klasse wenn du dich melden würdest.

Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.