www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MAX3232 liefert keine Daten bei angeschlossenem Kabel


Autor: domi_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

möchte einen MAX3232 RS-232-Pegelwandler an meinem STM32 Cortex-M3 
USART2 betreiben. Auf dem Oszi konnte ich bei nicht angeschlossenem 
seriellen Kabel ein Signal erkennen. Sobald ich jedoch mit dem PC die 
Daten empfangen möchte und das Kabel angeschlossen habe kommen nur noch 
Spannungsspitzen die schnell abfallen raus (die Bits sind zu erahnen, da 
gleicher Abstand und gleiche Anfangshöhe wie ohne Kabel, aber dann kommt 
gleich dieser Spannungsabfall). Habe das ganze wie im Datenblatt (3,3 
Volt) angegeben mit 0,1 µF aufgebaut und nochmal testweise mit 0,47 µF 
jedoch ohne Erfolg.

An was könnte es liegen und was könnte ich noch probieren um den Fehler 
zu finden bzw. habt ihr ne Lösung?

Gruß und danke!

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
domi_ schrieb:

> An was könnte es liegen

Angesichts der Faktenfülle deines Postings kann ich nur postulieren, 
dass du wohl etwas falsch gemacht hast. Und dass es wohl nicht die 
Kondensatoren sind.

> und was könnte ich noch probieren um den Fehler
> zu finden bzw. habt ihr ne Lösung?

Es richtig machen.

Wege dazu:
- Schaltbilder nicht in Worten beschreiben.
- Oszibilder auch nicht.
- An Fehlern im Programm lassen sich ohne Kenntnis dessen nur der 
beliebte "Fehler in Zeile 42" bemerken.

Autor: stm32-newbie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
raterunde... rxd und txd am Steckverbinder vertauscht?

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
stm32-newbie schrieb:
> raterunde... rxd und txd am Steckverbinder vertauscht?

+1

Autor: blauzahnmeister (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi.
Alle beteiligten ICs mit einem hübschen 0.1uF Condensator zwischen Vcc 
und gnd hat mir bisher immer geholfen.

Autor: TK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht denn das mit dem Spruch aus:"Wer mißt mißt Mist"??
- Wo sind die Pegel gemessen?
- Wo war GND vom Tastkopf angeschlossen?
- Welche Einstellungen waren am Oszi vorhanden?

Gruß
TK

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.