www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit dem FT2232c von FTDI


Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halli hallo an Alle,

ich habe folgendes Problem. Ich habe meinen neuen FT2232C auf die
Leiterplatte gelötet und nach dem ersten Start lief alles prima.
Treiber wurden automatisch installiert usw. Dann habe ich noch den
EEPROM programmiert...auch alles bestens. Nun habe ich mich schon
gefreut und weitere Dinge auf der Leiterplatte aufgelötet, wie den
ATMEGA128. Den konnte ich auch schon über die IPS-Schnittstelle
ansprechen. Nun habe ich noch ein paar Steckverbinder und ein bissl
Kram aufgelötet. Jetzt wollte ich alles schön ausprobieren, aber leider
wird jetzt der FT2232C nicht mehr vom USB erkannt und ich weiß nicht
wieso. Das geht folgendermaßen vor sich.
Ich stecke es am USB an. Der Computer erkennt ein USB-Gerät und will
den Rechner zwecks Treiberinstallation neu starten. Nach dem Neustart
findet aber kein Datenaustausch, zwischen dem FT2232C und dem Rechner
statt. So fragt er nicht nach den Treibern und ich kann sie nicht
installieren. In der Systemsteuerung findet man unter den USB Geräten
ein USB-Composite-Device mit einem gelben Ausrufezeichen. Unter Details
und Fehlermeldungen steht: Das Gerät konnte nicht gestartet werden(Code
10).
Das ganze habe ich auf mind. fünf verschiedenen Computern getestet und
es ist immer der gleiche Fehler. Dann habe ich alle Signale auf dem
Board nachgemessen. Bis jetzt nichts ungewöhnliches. Ich bin gerade
total ratlos und weiß nicht mehr weiter, wo da noch der Fehler liegen
könnte, vorallem weil schon einmal alles lief. Ich schicke Euch mal
meinen Schaltplan mit und ich hoffe Ihr könnt mir aus der Patsche
helfen....


Vielen Dank schon einmal im Vorraus...

Ciao Thomas

Autor: Sebastian Schatzl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das problem hatten wir auch ...
eeprom neu flashen half
(mit ft2xxst programmer !)

dann erkennt er den usb controller als unknown device
und dann mit prog2232 flashen ...

hoffe das hilft,

lg,
sebastian

Autor: Sebastian Schatzl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
is meinem kollega grad noch eingfallen:

auf der dlp design hp [1] steht noch drauf, wie du pins
kurz schliessen musst, um ein anscheinend totes device
wieder zum leben zu erwecken

lg,
sebastian

[1] http://www.dlpdesign.com/usb/faq.html

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anhang gelöscht, bitte eine vernünftige Dateigröße wählen.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Halli hallo Sebastian,

vielen Dank für Deine Antwort. Genau das könnte das Problem sein.
Leider konnte ich es noch nicht ganz ausprobieren, aber ich werde es
vielleicht gleich morgen mal testen. Zur Zeit habe ich mal den
Widerstand vom Powerenable-Pin abgelötet. So das dieser Eingang offen
ist und das Gate vom Transistor auch. Und siehe da, schon wurde es auch
wieder vom PC erkannt. Allerdings war mein EEprom auch wieder leer.
Wieso weiß ich allerdings auch nicht. Also es muss irgendwie etwas
damit zu tun haben. Ich werde es versuchen herauszufinden. Vielen Dank
für den Link und Deine Tips...

Ciao Thomas

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Computer erkennt ein USB-Gerät und will
> den Rechner zwecks Treiberinstallation neu starten.
Da ist doch irgendwas faul - wieso sollte man den Rechner wegen einer
Treiberinstallation neu starten? Was'n das für'n Betriebssystem?

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das Betriebssystem ist Windows 2000. Und beim ersten Versuch wo
alles funktionierte, war es auch so. Also ich denke es ist völlig
normal, daran sollte es nicht liegen. Es hat schon mit der EEProm-Sache
zu tun. Gebt mir noch ein wenig Zeit...

Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.