www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik kein VGA-Signal


Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Ich wollte gerne das VGA-Signal messen, jedoch kann ich den externen 
Monitor in Windows nicht aktivieren und somit auch nichts am VGA-Ausgang 
messen.

Nun meine Frage:
Gibt es irgendeinen bestimmten Pegel, oder ein Signal, welches ich 
anlegen muss, damit ein Gerät am Ausgang erkannt wird, wodurch ich dann 
den Ausgang unter Windows aktivieren könnte?

Vielen Dank schon einmal im Voraus,
Florian

Autor: Philipp Karbach (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also den Pegel kannst du doch parallel messen? Schließ einen monitor 
dran und mess die leitungen parallel durch.

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Antwort, jedoch möchte ich nach dem Messen eine 
Schaltung basteln, die auch als Gerät erkannt wird, und da mach ich die 
Messungen auch lieber schon so.

Gruß Florian

Autor: John-eric K. (mockup)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Display ist ein EPROM drinnen, der die Informationen für Windows 
bereithält.

Siehe http://de.wikipedia.org/wiki/Extended_Display_Iden...

Hier steht auch was, bei der Steckerbelegung, wegen den IDs
http://de.wikipedia.org/wiki/VGA_(Anschluss)

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, das mit der Pinbelegung und den ID's hatte ich auch gelesen, 
desshalb hatte ich Pin 11 mit Pin 10 verbunden.
Oder muss ich da einen anderen Punkt als Masse nehmen?

Danke,
Florian

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo soll das Signal auch herkommen wenn der Anschluss nicht angesteuert 
wird?

Schon mal zum Test 2.Monitor angeschlossen ?

Desktop->rechte Maustatste->Eigenschaften->
Einstellungen->Monitor auswählen-> Desktop_erweitern?

http://de.wikipedia.org/wiki/VGA_(Anschluss)
Es sollten kurze und hochwertige Kabel benutzt werden.

Über DDC werden Monitordaten ausgetauscht.

Autor: John-eric K. (mockup)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich würde Pin 5 als Masse Bezug nehmen.
Ich weiß nun nicht ob Pin 5 und 10 am Rechner gemeinsam auf Masse 
liegen,
oder getrennte Massen benutzt.

Pin 10 ist ja Masse der Sync Signale

Autor: John-eric K. (mockup)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sonst nehme dir einen I2C EPROM und flashe das hier rein.
und klemme den dann an den Port.
Ist von meinem Monitor die EDID Daten.
Es gibt auch Programme zum extrahieren der Daten.

Phoenix EDID Editor zB.

Der kann die EDID daten deiner Monitore aus der Registry von Windows 
extrahieren.

Gruß John

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch mit Pin 5 haut das erweitern nicht hin.

Ich werde gleich zur Kontrolle erstmal einen 2. Monitor anschließen, 
jedoch bin ich mir recht sicher, dass der Ausgang funktioniert.

Danke,
Florian

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Link "http://de.wikipedia.org/wiki/VGA_(Anschluss)" sollte eigentlich 
erreichbar sein?

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wiki meinte heute u.a.:

Wenn kein DDC-Signal verwendet werden kann, kann auch das ältere 
"ID"-System verwendet werden.
Pin 11 PIN 12 PIN 4 Erklärung
ID0    ID1    ID2
NC     NC     NC   kein Monitor angeschlossen
       GND         Monochrom-Monitor
GND                Farbmonitor Auflösung 800x600
GND          GND Farbmonitor Auflösung 1024x768
Je nach Auflösung(en) gibt es noch mehr Kombinationen

Ob Deine Grafikkarte und das System das erkennt weiß ich nicht. Oft 
steckt der Teufel im Detail.

Autor: Michael X. (Firma: vyuxc) (der-michl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
RGB mit jeweils 150 Ohm auf Masse.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
TV-Out wird auch erst aktiviert, nachdem man einen Abschlusswiderstand 
am Chinchstecker angeschlossen hat. (150Ohm habe ich genommen).

Nur beinm nächsten mal Einschalten war dann der proimäre Monitor auf dem 
150Ohm Widerstand "abgebildet" und mein eigentliches TFT war nur grau, 
weil war das zweite Display in diesem Mode.
Musst also bei der Konfiguration aufpassen, das deine Schaltung nachher 
nicht der erste Monitor ist.
Auch "Clone" hat nichts geholfen, ich muss den PC ohne "Schaltung" 
hochfahren und kann dann érst die Schaltung anklemmen
..
gruß
Axel

Autor: Florian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die reichlichen Antworten.
Habe das erstmal so gelöst, dass ich mit einem anderen Bildschirm den 
Anschluss angestellt habe und dann dort den TFT durch die Schaltung 
ausgetauscht habe. Jetzt empfange ich auch Signalt.
Das mit den Widerständen hab ich noch nicht ausprobiert, aber werde ich 
gleich machen.

Danke,
Florian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.