www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVRISP mkII USB zu hohe Spannung


Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, weil ich bilind einer Anleitung im Internet vertraut habe auf der 
ein Widerstand seinbar falsch berechnet war, hat mein AVRISP mkII jetzt 
die doppelte Spannung abbekommen als vorgeschrieben. Jetzt leuchtet 
keine LED mehr und wenn ich eine Verbindung herstellen will, findet mein 
PC das Gerät nicht. Nun meine Frage: Ist das Gerät jetzt schrott oder 
gibts da nen trick damit es wieder läuft (Sicherung oder so was?)
Danke schonmal für die Antworten!

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael schrieb:
> Hallo, weil ich bilind einer Anleitung im Internet vertraut habe auf der
> ein Widerstand seinbar falsch berechnet war, hat mein AVRISP mkII jetzt
> die doppelte Spannung abbekommen als vorgeschrieben.

Wie geht das denn?
Die Spannung fürs AVRISP kommt doch vom USB.

Wenn aber Dein AVR in der Schaltung schon qualmt, sollte man das AVRISP 
garnicht erst anschließen.

Ne allgemeine Bastlerregel ist, immer ein Netzteil mit Strombegrenzung 
nehmen. Je stärker ein Netzteil, umso schlechter ist damit basteln.

Für AVR-Schaltungen reicht oft ein Netzteil mit max 100mA. Dann kann 
fast garnichts passieren, egal, wie blöd man sich anstellt.

Und ehe man nen IC reinsteckt oder irgendein Gerät, immer erst die VCC 
messen!


Peter

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spannung muss extern anliegen... bei meinem zumindest hatte deswegen 
auch schon Probleme. Dachte auch erst es wäre über USB aber war dann 
anders. Der AVR hat wunderbar funktioniert aber sobald des AVRISP dran 
hang gings nicht mehr :(
habe dannach erst gemessen, war ein Fehler, aber dafür is es jetzt 
leider zu spät...

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael schrieb:
> Die Spannung muss extern anliegen... bei meinem zumindest hatte deswegen
> auch schon Probleme.

Also der AVRISP-MK2 kriegt seine Spannung immer über den USB.
Den zu programmierenden AVR versorgt er natürlich nicht, d.h. der 
braucht seine eigene VCC.
Der AVRISP-MK2 senst aber die VCC des AVR für die Pegelwandler, damit er 
auch bei VCC <5V geht.
Ich kann mir daher gut vorstellen, das VCC >5,5V den Pegelwandler des 
AVRISP zerstört.


> Der AVR hat wunderbar funktioniert

Wieviel über 5V hast Du denn dem AVR zugemutet?
Ich schätze bei >8V sollte er in die ewigen Jagdgründe eingehen.

Hast Du es schon mit einem neuen AVR an VCC <=5V probiert?


Peter

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn keine LED mehr leuchtet, hat es den SEPIC-Wandler des MKII 
geschrottet. Für Leute ohne Heißluft-Lötstation kommt dies einem 
Totalschaden gleich.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.