www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik KA3525 Mehr Spannung als erwartet


Autor: Muh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich hab mich mal mit dem KA3525 gespielt und ihn so aufgebaut wie hier 
beschrieben:

http://sound.westhost.com/project89.htm

Den Chip zum schwingen hab ich gebracht... zwar mit kleine Spikes, aber 
das ist wohl normal. Dann die FETs dahinter und den Trafo... gab 
übelstes Gekröse am Ausgang und der Eingang sah auch recht schepprig 
aus. Eine Interpretation (geht, geht nicht) vom Oszibild war nicht 
möglich... aber es hat auch nix geraucht... Dann jeweils 100nF an die 
Ausgänge der sekundären und siehe da... +/- 35V Glatt wie ein Babypopo 
(ohne Last versteht sich)

Man könnte meinen dass das gut ist, beabsichtigt waren aber +/-12V am 
Ausgang. der Trafo hat sekundär wie primär identisch viele Wicklungen

Beim Oszimessen am fertigen System hab ich gesehen, dass die primäre 
Wicklung von den Fets mit 20V Spitze angesteuert wird, was ich recht 
komisch find, weil das Netzteil an dem die ganze Sache rennt nur 10V von 
sich gibt.

Zugegeben: das ist mein erstes Mal mit SNT, drum hab ichs brav nach 
Anleitung gebaut, damits auch Idiotensicher ist... aber naja.. wie man 
sieht :-)

also.. wer weiß Rat?

Grüßle!

: Verschoben durch Admin
Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>also.. wer weiß Rat?


Ich. Schaltplan und Oszibilder posten!

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>+/- 35V Glatt wie ein Babypopo
Wie sind denn Deine Windungszahlen/Übersetzungsverhältnis? Du hast 
wahrscheinlich nach den Originalangaben gewickelt? Das 
Übersetzungsverhältnis muß an Deine 12 Volt angepasst werden.

>primäre Wicklung von den Fets mit 20V Spitze
Das ist logisch wegen den symetrischen Primärwicklungen. Wenn ein FET 
auf Masse zieht, geht der andere Drain hoch auf die doppelt 
Betriebsspannung.

Die meisten Schaltregler benötigen eine Grundlast. Häng für Deine Tests 
einen Widerstand dran und laß den mindestens 1A aus dem positiven 
Ausgang ziehen.

Mfg. Bernd

Autor: Muh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan siehe Link oben... ist der 2te ohne die Treiber... sklavisch 
befolgt... außer dem 10nF... das ist jetzt halt ein 100nF. und der 1nF 
ist ein 2n7. aber davon wirds nicht kommen nehm ich an oder?

btw: wofür sind die R1C1 und R2C2 Kombis? nen passenden R hab ich nicht 
da gehabt, jetzt sind da halt 100R drin statt den 56... kanns das sein?

Oszis gibts in mäxten Post... muss ich grad mal machen...

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die "R1C1 und R2C2 Kombis" dämpfen den Überschwinger beim Abschalten des 
FET. Durch Streuiduktivitäten zwischen Fet und Übertrager würden sonst 
Spannungsspitzen bis über 100 Volt entstehen und die FETs zerstören.

Autor: Muh (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
1.JPG = Ansteuerung Windung primär
2.JPG = Ausgang WIndung sekungär
3.JPG = Ansteuerung FET

so und jetzt?

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die RC Kombination wird so ausgelegt, daß der FET noch nicht durch 
Überspannung stirbt, jedoch auch am Widerstand nicht zu große Verluste 
entstehen.

Was auffällt, ist ein Impuls-Verhältnis von 50%, was das Maximum bei 
einer Gegentaktschaltung darstellt. Fehlt eventuell Die Gegenkopplung? 
Was mißt Du zwischen Masse und dem Schleifer des Potis? Hast Du die 
Sekundärseite galvanisch von primär getrennt?

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Schaltplan siehe Link oben...

Interessant. Ein Flusswandler ohne Glättungsdrossel und ohne 
Gegenkopplung...

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> http://sound.westhost.com/project89.htm

Das ist ja eine absolut widersinnige Schaltung.

Der SG3525 ist ein SpannungsREGLER,
aber in der Schaltung fehlt ihm jegliche Regelungsmöglichkeit,
er erfährt gar nicht, wie gross die Ausgsngasspannung ist.

Er wird hier nur als 50% Rechteckoszillator verwender, dafür
aber mit vielen vielen Bauteilen drumrum.

Deine 20V an der primären Wicklung (welche Wicklung? Da sind 2!)
entstehen vermutlich, weil die Wicklungen jeweils paarweise sind,
wird die eine zwischen 0V und 10V(12V) gelegt, entstehen an der
anderen 10V(12V) und 20V(24V) und du misst als Differenz 20V(24V).
Aber wenn das so ist, hast du schon ein gewaltiges Verständnisproblem.

Ebenso die 35V am Ausgang. Es würde nicht wundern, wenn das
gleichgerichtete Streuinduktivität ist, mach mal einen 1k Widerstand
als Belastung dran, ich hoffe auch, die 100nF waren ein Schreibfehler.

Die Schaltung ohne Gate-Treiber aber mit dicken FETs ist natürlich
Murks, doch bevor man die Gate-Zreiber dranmacht, sollte man sich
überlegen, ob man den Murks nicht gleich an der Quelle abstellt,
und entweder den SG3525 regeln lässt, oder einfach einen 50%
Rechteckgenerator ohne diesem IC aufbaut, der direkt die MOSFETs
bedient.

Autor: Muh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Galvanisch getrennt? Poti?

Wie Ihr richtig festgestellt habt, ist das Ding komplett ungeregelt... 
was ich in der Tat auch gewundert hat. die erste Version ist noch 
geregelt, die zweite garnicht mehr. Aber es hat geheißen das Teil 
läuft.. und tut es auch irgendwie...

die FETs die dran sind, sind nicht besonders dick.. der Chip hat 
genügend Dampf die zu treiben denk ich.

Bei den Oszimessungen war die Klammer immer an GND. Ich hab die 20V 
nicht zwischen den Wikungsenden gemessen. btw: ja es sind jeweils 2 
Wicklungen und zwar so aufgebaut wie im SP beschrieben.

Der Typ sagt in dem Text, dass die Ausgangsspannung beinahe komplett vom 
Windungsverhältnis abhängt (wie bei einem 50Hz trafo.. da ist ja auch 
nix geregelt) und so hab ich die Idee des Aufbaus auch verstanden.

Was sagt Ihr zu dem aufbau?

die 100nF waren übrigens kein Verschreiber. Was soll daran verkehrt 
sein?

Autor: Muh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Öhm ja... Anfängerfehler... 4K7 an die Ausgänge gehängt und schon sinds 
+/-10V... naja +10,5 und -12V... aber klingt jedenfalls plausibler als 
+/-35V.

trotzdem: alles in Allem... was haltet Ihr von der Konstruktion?

Weitere Frage: die Spannung ist ja etwas unsymmetrisch... meint Ihr, 
dass die trotzdem zum Betreiben von OPs gut ist? das Signal macht vllt. 
+/-5V, liegt also weit unter der Rails...

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ungeregelt geht natürlich schon, die Ausgangsspannung folgt dann immer 
direkt proportional der Eingangsspannung. Für OPs wirst Du außerdem 
einen ziemlichen Ripple drauf haben, welcher auf Dein Signal 
Überspricht. Der LM358 hat z.B. >=65dB Power Rejection Ratio: Bei 1V 
Ripple hast Du dann ~1mV Störungen auf den Eingängen des OPs. Deshalb 
würde ich +-15V erzeugen und noch 2 Längsregler 7805/7905 nachschalten.

Autor: Muh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm ja an Längsregler hatte ich auch schon gedacht... aber die verblasen 
ja noch ne Haufen Leistung. und es soll ja nur ne Vorstufe werden, mehr 
nicht.

Ich neh hier auch keine WuW OPs... die sind aus ner Eton Endstufe und 
haben irgend was zwischen 86 und 150 db...

Die Spannung ist bei 4K7 erstaunlich Glatt am Ausgang. Oder meinst der 
Ripple ist am Oszi nicht zu sehen?

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> und es soll ja nur ne Vorstufe werden

Dein Ding soll also viel weniger Leistung bringen ?
TL494 kann den Trafo dann drirekt ansteuern.

> die 100nF waren übrigens kein Verschreiber.
> Was soll daran verkehrt sein?

Na ja, da sind auch noch je 2 x 3300 uF, und die sind
da nicht ohne Grund, mach sie dran, auch wenn für die
Vorstufe nicht so viel Leistung notwendig ist, viele
uF dürfen es schon sein.

> naja +10,5 und -12V

Trafo schlecht gewickelt ?

> hm ja an Längsregler hatte ich auch schon gedacht...

Is ja Blödsinn, man sollte vielleicht einfach nicht
den Regelteil des ICs ungenutzt lassen.

Autor: Abdul K. (ehydra) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest deinem 3525 noch irgendeinen Schutz vorm biestigen Autonetz 
geben. Sonst wird die Schaltung nicht lange leben!

Autor: Muh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jupp Schutz gibts... aber eher zum Schutz des Autonetzes und nicht 
umgekehrt :-P die Schaltung strahlt übelst aus.

Trafo schlecht gewickelt?? natürlich... is ja noch kein Meister vom 
Himmel gefallen und ist ja mein Erster ;-) Das üb ich einfach nochmal...

TL494 hab ich mir grad mal angeguckt... nicht verkehrt, aber macht nur 
200mA soweit ich das richtig gesehen hab und das ganze nur um mir die 2 
FETs zu sparen... den 3525 hab ich halt grad da und werd den jetzt auch 
hernehmen...

Danke für Eure Hilfe :-)

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@MaWin
Zwei Längsregler nur um den Ripple wegzufiltern. Ob 10 oder 12Volt, das 
ist doch dem OP egal.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man kann Schaltregler so auslegen, dass der Ripple kleiner ist als 
erforderlich,
man braucht keine Linearregler, die bei hohen Freuqenzen eh zu langsam 
sind um noch nachreglen zu können, sondern sich dabei auf die 
angeschlossenen Kondensatoren verlassen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.