www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik RS232/Denkfehler?


Autor: Sebastian H. (electrician)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Ich habe mir gerade mit einem GPS Empfänger ein Frequenznormal gebaut.
Jetzt wollte ich die Daten noch "Zweitverwerten" und mir eine Locator- 
und Zeitanzeige dazu basteln, dazu erstmal den Ausgang des GPS an einen 
MAX232 gebastelt, Kabel zum PC -> HTerm zeigt mir einwandfrei die Daten 
($GP...usw). Zum Programmieren dann den Ausgang des GPS an das STK500 
geklemmt -> kommt nur Mist am PC an!!!
Ok, zuerst dachte ich das der MAX202 auf dem STK500 defekt ist, aber 
schreib ich Daten vom Mega8 auf die RS232 bekomme ich korrekte Ausgaben 
in HTerm. Jetzt bin ich leicht verwirrt....Wo ist mein Denkfehler/Fehler 
im Aufbau?


Dank euch

Sebastian

Autor: Volker Schulz (volkerschulz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Datenblatt GPS-Modul?

Schaltplan / Skizze Aufbau?

Volker

Autor: Stefan_KM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast du denn mit der Enable Leitung des MAX202 gemacht? Bzw. wie ist 
diese Leitung im STK500 verkabelt. So eine Leitung hat ein MAX232 nicht. 
Muss sonst vom Controller gesetzt werden, bzw. muss auf High(bzw. Low) 
gelegt werden.

Autor: Sebastian H. (electrician)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen!

Hier erstmal der Link zum Datenblatt des GPS: 
http://gpskit.nl/documents/rockwell/jupiter-gps-board.pdf
Angeschlossen hab ich PIN 11. Skizze kann ich später evt. machen.

Um das Enable Signal hab ich mich nicht gekümmert, muß gestehen das ich 
das STK zum Testen nur als Pegelwandler mißbrauchen wollte. Schau ich 
mir aber heut abend an.

Dank euch erstmal!



Sebastian

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Angeschlossen hab ich PIN 11.
Nur? Keine Masse?

Autor: Sebastian H. (electrician)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,


hat sich geklärt...bei einer der Brücken die ich verwendet habe, hab ich 
anscheinend einen Pin so s..dumm verbogen das ein Wackler entstand bzw. 
kein Kontakt mehr vorhanden war.
Dank euch für eure Mühe


Sebastian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.