www.mikrocontroller.net

Forum: Platinen (Altium Designer) Bauteil & Leiterbahn verschieben


Autor: Julian O. (jaytech)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Kurz und bündig:
Wie kann ich im Altium Designer (Sommer '09) auf meinem PCB ein Bauteil 
inkl. der bereits gerouteten Leiterbahn verschieben?
Bisher verschiebe ich immer nur das Bauteil und route dann die 
Leiterbahn neu oder ziehe sie nach.

Schon mal danke für alle Antworten.
Gruß

Autor: Ralf (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Siehe Anhang.

Ralf

Autor: Julian O. (jaytech)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Ralf,

Das Problem wurde durch die Einstellung leider nicht gelöst.
Muss ich sonst etwas beachten?

Gruß

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Das Problem wurde durch die Einstellung leider nicht gelöst.
Die Einstellung sorgt dafür, dass die Leitungs_enden_ am Bauteilpad 
haften bleiben, der Winkel etc. ändert sich natürlich entsprechend 
(ähnlich wie in EAGLE, falls du das kennst).

Deine Formulierung lässt mich leider nicht erkennen, ob die Einstellung 
wirklich nichts bewirkt hat, oder nur "nicht das was du erwartet hast" 
:(

Ralf

Autor: Julian O. (jaytech)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich hätte erwartet, dass die Leiterbahn beim verschieben des Bauteils an 
dessen Pins hängen bleibt. Jedoch bleiben die Leiterbahnen an Ort und 
Stelle wenn ich das Bauteil verschiebe...

Siehe anhang...

Gruß

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, so sollte es eigentlich auch sein, wenn du die o.g. Funktion 
aktiviert hast... WIE schiebst du denn das Bauteil? Einfach anklicken, 
Maustaste gedrückt und schieben, oder per Move->Drag bzw. Move->Move?

Ralf

Autor: Julian O. (jaytech)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Das wars, über den "Move" Befehl bleiben die Leiterbahnen am Pin 
"Kleben". Wenn ich jedoch das Bauteil mit gedrückter Maustaste 
verschiebe, bleiben die Leiterbahnen an ihrer alten Position.

Danke für die Hilfe Ralf.

Gruß
Julian

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

freut mich dass es geklappt hat.

Falls du das noch liest, probier mal, ob es einen Unterschied macht, 
wenn du:

1. das Bauteil anklickst, die Maustaste hältst und ziehst
oder
2. das Bauteil zuerst markierst, und dann Schritt 1) ausführst.

Kanns grad nicht probieren, bin nicht bei der Arbeit.

Ralf

Autor: Julian O. (jaytech)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Ralf,

Bei beiden vorgeschlagenen Methoden bleiben die Leiterbahnen nicht am 
Bauteil hängen.
Nur über die Befehle:
Move->Drag oder Move->Component
Bleiben die Leiterbahnen am Bauteil hängen und lassen sich mit 
verschieben.

Ralf schrieb:
> Kanns grad nicht probieren, bin nicht bei der Arbeit.
Muss man um die Uhrzeit auch nicht mehr sein... ;)

Gruß
Julian

Autor: Knörz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Und das ganze nun im Schematic Editor?

Da ist das gleiche Problem.
Wählt man ein Bauteil mit der linken Maustaste an und zieht es, dann 
dekonnektiert die Leiterbahn. Auch beim Wechsel der Orientierung z.B. 
von 45° auf 90° eines z.B. Widerstandes dekonnektiert die Leiterbahn.
Nur der Befehl "Menü->Edit->Move->Drag" bewegt die Leiterbahn mit. Man 
kann aber dann nicht mit Shift+Space Orientierung z.B. von 45° auf 90° 
wechseln :-(

Das ist bei LTSPice viel besser gelöst, muss ich sagen (im Menü die 
große und die kleine Hand)...

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Und das ganze nun im Schematic Editor?
> Da ist das gleiche Problem.
???

> Wählt man ein Bauteil mit der linken Maustaste an und zieht es, dann
> dekonnektiert die Leiterbahn.
Nö... Bei mir gehen auch im Schaltplan die Verbindungen mit. 
"AlwaysDrag" aktivieren! Oder bist du jetzt im Board und hast oben den 
Schaltplaneditor nur so erwähnt?

> Auch beim Wechsel der Orientierung z.B. von 45° auf 90° eines z.B.
> Widerstandes dekonnektiert die Leiterbahn.
> Nur der Befehl "Menü->Edit->Move->Drag" bewegt die Leiterbahn mit. Man
> kann aber dann nicht mit Shift+Space Orientierung z.B. von 45° auf 90°
> wechseln :-(
Korrekt, hab's grad selber noch mal nachgeguckt :)
Aber mittlerweile gehts ja relativ leicht, die Leiterbahnen neu zu 
legen, ohne dass man die "Leichen" manuell entfernen muss.
Hm... Schreib's doch dem AltiumSupport Team, die sind eigentlich recht 
offen für Vorschläge/Verbesserungen...

Ralf

Autor: Knörz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs gerade selbst gefunden:

STRG + "Maus linke Taste" = DRAG = "MOVE with connectivity"

und dazu Spacetaste für den Wechsel von z.b. 45° auf z.B 90°

Autor: Knörz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Ralf
> Und das ganze nun im Schematic Editor?
> Da ist das gleiche Problem.
>???

> Wählt man ein Bauteil mit der linken Maustaste an und zieht es, dann
> dekonnektiert die Leiterbahn.
>Nö... Bei mir gehen auch im Schaltplan die Verbindungen mit.
>"AlwaysDrag" aktivieren! Oder bist du jetzt im Board und hast oben den
>Schaltplaneditor nur so erwähnt?



Ich habe keinen "AlwaysDrag" bei den Schematic Editor EInstellungen 
unter DXP->Preferences->Schematics->General gefunden!

Autor: Julian O. (jaytech)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Hacken bei:
DXP - Preferences - Schematic - Graphical Editing - Always Darg
setzen.

Gruß

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.