www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schaltnetzteil mit LM2576-ADJ mach Geräusche


Autor: Toto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich versuche gerade mir ein eigenes Schaltnetzteil mit dem Step Down
Converter Lm2576 ( http://www.national.com/ds.cgi/LM/LM2576.pdf ) zu
bauen. Klappt auf meiner selbstgeätzten Platine soweit auch ganz gut.
Heißt die Spannungen kann ich korrekt einstellen und bei niedriger
Stromentnahme (Lüfter mit 0.13 A) ist auch nichts zu  höhren.
Als ich aber zu Testzwecken mal eine Halogenbirnchen (12V 20W
)angeschlossen habe fängt (ich glaube es ist die 100uH Drosselspule)
die Schaltung an Geräusche zu machen.
Das ganze fängt bei ca. 0.7A an und wird dann immer lauter.

Das Geräusch ist schlecht zu beschreiben, hört sich in etwa so an als
ob Wasser durch ein zu enges Rohr strömt.Sind auf jeden Fall nicht die
52khz Schaltfrequenz. Ich kann mal eine Aufnahme machen falls das
weiterhilft.
Und der Trafo fängt auch an zu brummen.

Irgendwas fängt also an zu schwingen ich weiß nur nicht woran das
liegt.

Als Induktivität hab ich eine Standart Drosselspule von Reichelt
genommen, vielleicht ist die nicht geeignet.
Die Kondensatoren sind auch Standart Elkos von Reichelt.

Ich weiß echt nicht woran das liegt sind doch nur ein paar Bauteile,
oder ist das Schaltungsdesign so Kritisch.
Sind aber schon große Masseflächen und breite kurze Leiterbahnen.

Im Anhang hab ich mal meine Schaltung die ein bisschen vom Datenblatt
abweicht. Die Eingangselkos sind um einges größer
weil ich später noch andere Sachen (Schrittmotor) mit dem Ringkern
betreiben will.
Und eine Negative Spannung soll auch noch später erzeugt werden deshalb
der Mittenabgriff am Trafo.

Vielleicht hat ja einer ne Idee wo der Fehler ist.

Autor: Toto (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bild vergessen

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Drosselspulen sind denkbar ungeeignet als Speicherdrosseln in
Schaltreglern. Grund -> Drosselspulen sollen HF-Energie vernichten.
Speicherdrosseln sollen Energie speichern und wieder abgeben.

Matthias

Autor: Toto (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wo bekommt man denn passende Speicherspulen her. Im Datenblatt stehen
eingige Hersteller(L1 — 100 µH, Pulse Eng. PE-92108),
aber die werden wohl kaum solche geringen Mengen versenden. Bei
Reichelt bin ich auch nicht fündig geworden.

Oder muss ich die Spule selber wickeln? Wenn ja welcher Kernmatrial ist
geeignet, bei Reichelt steht etwas von Referenzpermeabilität und ein
Farbcode ist angegeben (rot-grün, gelb-weiß ....). Ich kenn mich mit
dem anlogen Zeug leider nicht so gut aus. Sind doch nur 5 Bauteile mit
IC das muss doch irgendwie zu machen sein, hat denn keiner schon mal
einen Step-Down Converter mit dem lm 2576 aufgebaut.

Das gefiepe nervt mit der Zeit und wegwerfen möchte ich die schöne
Platine nicht.

Im Anhang hab ich das Geräusch mal aufgenommen, die Aufnahme ist nicht
so toll müsste aber reichen.

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

für den Pulse oder Renco 100µH würde ich Dir die PCV-2-104-10 von
Coilcraft empfehlen. Du kannst da auch ein Muster bestellen.

http://www.coilcraft.com/pcv2.cfm#table

Schaue Dir mal das Layout von ON-Semi an. So sollte es sein.

www.onsemi.co.jp/pub/Collateral/LM2576-D.PDF

Gruss

Steffen

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

die Eisenpulver-Ringkerne von Reichelt wären zumindest mal einen
Versuch wert. ISt halt Selberwickeln angesagt.

Matthias

Autor: Toto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

danke für die Links und Tipps

Habe mir jetzt mal die Samples bestellt,werde es aber auch nochmal mit
den Eisenpulver(Amidon) Ringkernen und selberwickeln versuchen.

Ich hab das Datenblatt nochmal gründlicher studiert und das
Platinenlayout scheint doch kritisch zu sein(Elkos und Widerstände).

Also das ganze wird jetzt nochmal neu geroutet mit 2- seitiger Platine
und durchgehender Massefläche und den Rückkopplungswiderständen und
Kondensatoren näher am LM2575.Hoffe das hilft dann endlich.

Grüsse

      Toto

Autor: PatrickHH (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe auch vor mir eine Schaltung mit dem lm2575-5 zu bauen. Doch ich
habe da noch ein paar Fragen:

- Wie sieht es denn mit der Wärmeentwicklung bei Belastung von 0,7A -
  1A aus (Uein=12V). Braucht man unbedingt einen Kühlkörper?
  Ich brauche eine Schaltung, die 5V und ca. 1A leistet und kaum Wärme
  erzeugt (ohne Kühlkörper wäre schön).

- Was für eine Spule kann ich für den Chip benutzen? Habe eine Spule
  bei Reichelt gefunden (siehe Anhang). Wäre die dafür zu gebrauchen?
  Und wenn nicht, was gibts für Alternativen, die leicht zu
  beschaffen sind?

Danke schon mal für eure Antworten...

Gruß PatrickHH

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@PatrickHH

Welche Spule:
lies dir nochmal die Beiträge weiter oben durch. Dort findest du die
Antwort auf deine Spule.

Wärmenetwicklung & Kühlkkörper:
zum Einarbeite in die Grundlagen
http://www.sprut.de/electronic/switch/schalt.html

Ob der LM2575 gekühlt werden muss kannst du anhand der Fromel im
Datenblatt-Anhang S.17 ausrechnen, schöne Übung.

Autor: popi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
spule vergiessen mit harz.....oder ne menge klebstoff dran

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie die Spule bezeichnet wird ist doch eigentlich egal, oder etwa nicht?
Die unterscheiden sich halt in der Induktivität, der Strombelastbarkeit
und kommen unterschiedlich schnell in die Sättigung.
Ich bin nämlich im Moment selbst auf der Suche nach einer Spule für ein
SNT und werde wohl die Eisenpulver Ringkerne mit µ=75 nehmen. Amidon
sagt, daß Ferrite leicht in die Sättigung gehen...

Autor: Toto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Das Projekt lag kurz auf Eis bis die Samples von Renco gekommen sind.
Platine neu geroutet alles zusammengelötet und..... der gleiche Fehler
wieder Geräusche.
Lange Rede kurzer Sinn nach einigem Messen Fehler gefunden. Es lag am
Eingangselko aus meiner "Grabbelkiste" der defekt war.

Neuer Standardelko und Ruhe war.
Ob es jetzt auch mit der Reichelt Drosselspule klappt kann ich nicht
sagen hatte keine Lust nochmal das Löten anzufangen.
Als Speicherelko habe ich auch Low ESR Becherelkos (alles Reichelt)
eingesetzt, wird aber warscheinlich auch mit den standard Spulen und
Elkos funktionieren.

Ich hab zwar einen Kühlkörper montiert, der wird aber bis ca 1A nicht
merklich Warm. Erst am Limit ist eine deutliche Erwärmung spürbar.
Bei einer zweiseitigen Platine kannst du ja zu Sicherheit die
Kupferfläche als Kühlung nutzen.

Ansonsten funktioniert das Ding seit 2 Wochen einwandfrei.

Noch eine Warnung, Vorsicht bei den Abständen zwischen den Pins.
Die sind ziemlich klein, also die Pads nicht zu groß machen.Hat einen
bösen Kurzschluss mit richtig schönem Lichbogen gegeben und der LM war
hinüber.Beim Messen war aber noch kein Kurzschluss vorhanden. Kann auch
am Lötfett zwischen den Pins gelegen haben das ich noch nicht entfernt
hatte weil ich mal wieder zu ungeduldig war.Oder die hohe
Schaltfrequenz begünstig die Bildung eines Lichtbogens so genau kenn
ich mich da nicht aus.

Also viel Erfolg.

mfG

 Toto

Autor: Toto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch ein kleiner Nachtrag.
Die Samples sind natürlich von Coilcraft nicht Renco aus dem Link von
Steffen.
Und die Eingangsspannung beträgt ca 40V, also bei 12 V wird 1A wird
wohl kein Kühlkörper nötig sein.

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wie die Spule bezeichnet wird ist doch eigentlich egal, oder etwa
nicht? Die unterscheiden sich halt in der Induktivität, der
Strombelastbarkeit und kommen unterschiedlich schnell in die
Sättigung.

...ja wenns so einfach wäre dass Induktivität gleich Induktivität ist
dann könnte vielleicht auch ich eines Tages diese Dinger verstehen. Es
gibt da leider noch so unangenehme Sachen wie Frequenzabhängigkeit der
Induktivität/Kernmaterials, Windungskapazitäten, Dämpfungsverluste...
es hat schon seinen Grund warum Hersteller ihren Spulen all die schönen
Beinamen geben.

Ich hab mal eine kleine Testreihe mit einer Kollektion von Spulen
gemacht. Alle geleiche (nahezu) Nenn-Induktivität jedoch
unterschiedliche Bauformen (Stab,Ringkern,Topf) und Materialien (z.T.
undefiniert aus der Krabbelkiste) in verreinfachter Flyback Schaltung.
Gemessen wurde die übertragene Leistung in abhängigkeit von f und
t-on.
Das Ergeniss war erschreckend: Leistungsübertragung variierte bis zu
Faktor 5, die jeweiligen Leistungsübertragungsmaxima lagen zwischen
10kHz und 480kHz und die zugehörigen Dutycyle zwischen 20%-78% (alles
ohne Sättigunsbegerenzung)

>Amidon sagt, daß Ferrite leicht in die Sättigung gehen...

dazu wüsste ich gern auch etwas genaueres (ausser der schwammigen
Aussage von Amidon dass Ferritringkerne bis 50W geeignet sind, bei
welcher grösse???)

Gibt es Formeln die bei gegebener Ringkerngrösse/Material die
übertragrbare Leistung angeben? Zumindest für Ferrit-77 u.
Eisenpulver-18/-26, oder zumindest Erfahrungswerte?

Autor: PatrickHH (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten, dann werde ich im neuen Jahr mal eine
Bestellung machen und mein Layout schon mal auf den LM2575 anpassen.

Als Spule werde ich mal die von Reichelt ausprobieren. Sonst muß ich
wohl eine selber wickeln.

Gruß PatrickHH

Autor: Jörn G. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt bei reichelt und ELV auch prima fertig gewickelte geeignete
Ringspulen.
jörn

Autor: Thorsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jörn

Meinst du die stromkompensierten Ringkerndrosseln? Ich dachte, die sind
eher ungeeignet für Schaltregler.

Thorsten

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, ich habe auch die Seite von Amidon studiert und nichts genaues
gefunden! Bei Reichelt gab's unter all den Ringkernen bis auf einen
einzigen (T 80-26) kein spezifisches Datenblatt. Und für's 18er
Material habe ich nichts gefunden. Ich nehme jetzt mal einfach das 26er
Material und probier's aus. Außerdem stimmen bei Reichelt die Angaben
über die Al Werte nicht (beim 18er und 26er).
Zum Beispiel wäre es nett, zu wissen, welchen Fluß man in der Spule
überhaupt hat und was das Material aushält!

Autor: Kupfer Michi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>wäre es nett, zu wissen, welchen Fluß man in der Spule...

Zur Berechnung der spulenrelevanten Parameter habe ich mir obiges
Spreadsheet gebastelt.
Aber wie gesagt ohne die Materialspezifischen Parameter wie
Maximalfluss, Verluste etc kommt man halt nicht weit...

Autor: Kupfer Michi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Al Werte

Spulen messe ich mir mit einem einfachen LC Schwingkreis aus.
(die Schaltung hab ich irgendwo aus dem Netz???)

Bei bekanntem C1 und unbekannten L1 messe ich die
LC-Schwingkreisfrequenz. Daraus ergibt sich dann L1. C1 wird variiert
um den Al(f)-verlauf im Frequenzbereich 10kHz bis 200kHz zu bekommen
(der LM311 Komerator ist nicht besonders schnell)

Misst man die Schwingkreisamplitude so hat man (im Vergleich zu
anderen) schon einen ersten Eindruck von der Güte der Spule.

Autor: Christian Wolf (clupus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hab mal unter
http://schmidt-walter.fbe.fh-darmstadt.de/smps/smps.html was zum Thema
SNT gefunden. Dort heißt es, dass ein Luftspalt in der Speicherdrossel
essentiell wäre und dass in diesem primär die Energie in der Drossel
gespeichert würde.
Reicht es dann nicht, einen Ringkern vom Reichelt mit einer guten Säge
so zu bearbeiten, dass ein klar definierter Luftspalt entsteht (Sind
die Pulver-Kerne gesintert oder riselt das Pulver dann heraus?? ;-))
Die Frage bleibt aber: Wie kann man die Kerndaten bestimmen? Kann man
von den Werten beim Reichelt ausgehen? Die Grüßen kann man ja messen.
Den Luftspalt entsprechend auch. Damit ist auch die eff. Kernlänge
gegeben, oder (Umfang des Mittelkreises - Spaltbreite)? Die Frage
bleibt der mag. Leitwert. Kann dieser vom reichelt genommen und ggf.
mit einer Korrektur (Spalt!!) verrechnet werden?

MfG
Christian

Autor: Thomas Pototschnig (pototschnig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist wohl schon 2 Jahre zu spät, aber mir ist aufgefallen, dass die
Spannung Vout an der Feedbackleitung abgegriffen wird, was so nicht
gehen kann.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Reicht es dann nicht, einen Ringkern vom Reichelt mit einer
> guten Säge so zu bearbeiten, dass ein klar definierter Luftspalt
> entsteht

Brauchst Du nicht. Die (entsprechenden) Ringkerne haben einen
sogenannten "verteilten Luftspalt". D.h. der Luftspalt ergibt sich
durch die einzeln isolierten Sintermaterialen des Ringkerns.

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt muss ich auch mal meine Erfahrungen mit dem LM2576HV-ADJ 
beitragen, vielleicht hilfts ja irgendwem (wer abkürzen will, kann sich 
auch gleich auf die Ergebnisse stürzen):

Problembeschreibung 1:
Benötigt habe ich zwei Schaltungen, welche jeweils von 48V auf 12V bzw. 
5V regeln. Die 5 Schiene wird dabei maximal mit ca. 1 Ampere belastet 
(Display), und die 12V Schiene mit max. 3 Ampere (Autoradio).
Das Layout war zunächst hinsichtlich einfacher Leitungsführung 
optimiert, da ich keine Ätzmöglichkeiten hab und deshalb mit der Hand 
verdrahte.
Jedenfalls gings nicht. Beide Schaltungen...
Ich kenne nur das Verhalten der 12V Schiene in dieser Entwicklungsphase, 
weil ich einfach zuerst versuchte diese in Betrieb zu nehmen. Leider 
kann ich hier nicht mit einem Oszillogramm dienen, aber komischerweise 
regelte der LM2576 den Spulenstrom zwischen 0,3 und 4 Ampere, indem er 
ca. 7-8 Takte (d.h. 52kHz/8 = 6,5kHz entspr. 15ms) praktisch einen 
Duty-Cicle von Null fuhr, und anschließend meist 4 Takte (= 7,5ms) voll 
durchsteuerte. Dies führte zu der großen Stromamplitude.
Ich hab das Layout zweimal geändert, und auch die Kondensatoren zweimal 
ausgetauscht, indem ich immer mehr kleinere Kondensatoren draufsetzte 
und auch Low-ESR Kondensatoren beim zweiten Mal einsetzte.
Nichts - das Verhalten blieb.
Wir dachten schon, die Logik bzw. die Sensorik vom LM2576 wäre defekt, 
als ich die Freilaufdiode noch ausgetauscht habe. Und siehe da - 
einwandfreies Betriebsverhalten. Der Wirkungsgrad stieg von 50% auf 86%. 
Der Duty-Cicle beträgt jetzt konstant ca. 25% und der Spulenstrom läuft 
zwischen 2 und 3 Ampere hin und her.

Ergebnis 1:
Obwohl ich eine Leistungs-Schottky-Diode BY251 verwendete, welche bis 3 
Ampere ausgelegt ist, war diese offensichtlich nicht ausreichend. Der 
Austausch gegen eine MBR20100CT, mit insgesamt 20 Ampere Stromtragzahl 
hats dann gebracht. Wo genau der Grund liegt muss mir ein 
Leistungselektroniker sagen.

Problembeschreibung 2:
Dann kam das 5V Netzteil dran. Hier hatte ich auch schon die gleichen 
Low-ESR Kondensatoren, gutes Layout und die fette Diode. Aber eine 
andere Induktivität. Wenn man Spannung und Strom (mit einem zusätzlichen 
Shunt in Serie) an der Spule maß, sah man die Pulse des LM2576, aber 
keinen Stromanstieg ( :-? galt hier die Physik nicht mehr?? ). Die Pulse 
waren immer zweifach. Zuerst ein kurzer Impuls ohne resultierenden 
Spulenstrom, dann ein etwas längerer, mit einem immensen Stromanstieg 
auf ca. 15-20 Ampere am Ende des Spannungspulses. Dass dieser Stromspike 
am Ende und nur sehr kurz auftrat erkläre ich mir mit dem 
Überstromschutz des LM2576, der dann halt wieder abschaltet. Nun zur 
(vermutlichen) Lösung:

Ergebnis 2:
Die Spule des 12V Reglers ist ein 220uH Speicherdrossel der Firma Würth 
mit 3 Ampere Belastbarkeit und der Typennummer 744136. Sie ist für 
Schaltwandler bis 200kHz gedacht und hinsichtlich ihrer Betriebsgrößen 
von mir anhand des Datenblattes des LM2576 ausgewählt.
Die anfängliche Drossel des 5V-Wandlers war die B82721 von Siemens mit 
2x400uH, eine Entstördrossel bis 3,6 Ampere. Auch diese anhand des 
LM2576-Datenblattes ausgewählt und mit ca. ein 8tel der Baugröße der 
anderen Drossel, was mir schon komisch vor kam. Wie Kupfer Michi weiter 
oben schon anmerkte, sind diese Dinger nicht zur Energiespeicherung 
gedacht, sondern zur Netzglättung. D.h. sie sollen hochfrequente Impulse 
vernichten, also solche wie den Takt des LM2576, was das Ding dann auch 
zuverlässig gemacht hat! Aber das wußte ich zu dem Zeitpunkt noch nicht, 
bzw. hab nicht darauf geachtet.
Das oben beschriebene Stromverhalten erkläre ich mir aktuell durch die 
Sättigung der Spule, bei welcher ja dann die Induktivität stark abnimmt 
und halt der Strom einfach frei durchpfeift. Der Austausch gegen die 
Würth-Speicherdrossel (die halt jetzt nicht optimal dimensioniert ist) 
brachte auch diesen Fehler zum verstummen. Also: Achtet auf die 
Grenzfrequenzen!

Für Kommentare bin ich jederzeit offen.
LG
Micha

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.