www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Hilfe bei Verzögerungsschaltung?


Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich brauche Hilfe bei einer Schaltung.

Ich habe ein Gerät das wird mit 15V DC betrieben, es hat auch einen Akku 
eingebaut falls das Netz ausfällt.

Nun bräuchte ich eine Schaltung die sobald das Netz (15VDC nach Trafo) 
ausfällt ein Relais für ca 15 Sekunden anzieht. Versorgt wird diese 
Schaltung über den Akku.

Kann mir wer helfen wie ich das realisieren kann?

mfg

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du brauchst ein Monoflop. Das steuert das Relais, siehe [[Relais mit 
Logik ansteuern]]. Bei 15V kann man einen NE555 nehmen, da spart man 
sich den extra Transistor.

MFG
Falk

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal nach "NE555"

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der NE555 ist doch nur ein Taktgeber oder?

Ich brauch sobald die Spannung weg ist, das ein Relais 15 Sek anzieht 
und dann wieder abfällt, fertig. Es soll dann nicht nocheinmal anziehen. 
Außer das Netz fällt nochmals aus...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Christoph (Gast)

>der NE555 ist doch nur ein Taktgeber oder?

Den man auch als Monoflop nutzen kann . . .

Lies mal den Artikel.

MFG
Falk

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber das wird ja nicht richtig funktionieren, wenn zb. die Netzspannung 
10min ausfällt soll das Relais trotzdem nur ca. 15 sek anziehen obwohl 
die Spnnung länger weg ist.

Die Schaltung soll ja dann "gestartet" werden wenn das Eingangssignal 
auf low geht.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Christoph (Gast)

>Aber das wird ja nicht richtig funktionieren,

Woher weißt du das?

> wenn zb. die Netzspannung
>10min ausfällt soll das Relais trotzdem nur ca. 15 sek anziehen obwohl
>die Spnnung länger weg ist.

Ja und? Hast du dich schon mal mit dem Monoflop beschäftigt?

>Die Schaltung soll ja dann "gestartet" werden wenn das Eingangssignal
>auf low geht.

Ja und? Das tut sie auch.

MfG
Falk

Autor: Christoph (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt die Schaltung mit dem NE555 aufgebaut.

Wenn ich nun E auf Masse lege fängt die LED an zu leuchten, geht aber 
nicht mehr aus, was hab ich da falsch gemacht??

Zeichnung ist im Anhang, die Werte der Bauteile:

R1 = 10k
R2 = 68k
R3 = 10k
R4 = 10k
C1 = 10µF
C2 = 10nF
Transistor BC546

Bei der LED ist natürlich noch ein Vorwiderstand dazwischen

VCC = 5V

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Christoph (Gast)

>Hab jetzt die Schaltung mit dem NE555 aufgebaut.

Der NE555 kann 200mA am Ausgang, da braucht man keinen Transistor.

>Wenn ich nun E auf Masse lege fängt die LED an zu leuchten, geht aber
>nicht mehr aus, was hab ich da falsch gemacht??

E darf nur ein kurzer LOW-Puls sein. Ein Kondensator in Reihe hilft hier 
;-)

>Bei der LED ist natürlich noch ein Vorwiderstand dazwischen

Und warum zeichnest du den nicht einfach ein?

MfG
Falk

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich vergessen einzuzeichnen!

Hab das mit dem Kondensator probiert aber die LED geht immer noch ein 
und geht nicht mehr aus.

Laut berechnung sollte die LED ja nur 0,8sec leuchten...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leg mal E nur kurz auf GND, dann einfach loslassen.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hab ich gemacht, geht leider nicht mehr aus...

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner schrieb:

> Der NE555 kann 200mA am Ausgang, da braucht man keinen Transistor.

Nur triggert der NE555 gerne nach, wenn der Ausgang negativ wird. Was er 
mit normaler Freilaufdiode am Relais wird. Schottky-Diode könnte 
sinnvoll sein, oder zusätzliche Diode in Serie.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hilft mir im Moment auch nicht weiter. Ich würde so oder so mit 
einem Transistor schalten und eine Freilaufdiode kommt da auch noch 
rein.

Derzeit teste ich die Schaltung aber nur mit einer LED und es 
Funktioniert nicht richtig da die LED nachdem ich E kurz auf Masse 
gelegt habe nicht mehr aufhört zu leuchten obwohl sie das nach ca 0,8sec 
machen sollte.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der 555 kann auch hinüber sein. Manchmal stirbt der Discharge Transistor 
(Pin 7) bei höheren Kapazitäten. Ich würde einen 10 Ohm Widerstand zum 
Pin 7 einfügen.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mir auch gedacht das er vielleicht kaputt ist, hab es jetzt 
schon mit 5 Verschiedene ausporbiert, geht mit keinen.
Wenn ich Spannung anlege ist die Led aus, sobald ich mit E auf Masse 
gehe, leuchtet die LED und geht nicht mehr aus...

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kann mir keiner helfen??

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab das Problem mittlerweile gelöst, die Schaltung funktioniert.


Allerdings hab ich jetzt das nächste Problem:

Ich hab die Schaltung so eingestellt das das Relais ca. 15 sec anzieht, 
das funktioniert aber nur wenn ich auf E nur einen kurzen Impuls gebe um 
die Schaltung zu starten.

Es soll aber so funktionieren, egal wie lang dieser Impuls an E anliegt 
(auch mehr als 15sec) das Releis soll nur 15 Sec anziehen!

Wie kann ich das machen das die Schaltung so funktioniert?

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Indem man z.B. einen Kondensator C vor den Eingang setzt.

Der liefert egal wie lang man das eine Ende des C ansteuert nach dem C 
nur einen kurzen Impuls an E.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.