www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Displaytech 161A keine Anzeige, defekt??


Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute habe mir letztens das Displaytech 161A von reichelt bestellt:
http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=A52...

Es wurde wiefolgt angeschlossen:
Pin1 => GND
Pin2 => +5V
Pin3 => Schleifer von 10k Poti zwischen 0 und +5V regelbar.
Pin4 => PD2 an Atmega8
Pin5 => GND
Pin6 => PD3 an Atmega8
Pin7-10 => frei, weil nur 4bit Ansteuerung.
Pin11 => PD4 an Atmega8
Pin12 => PD5 an Atmega8
Pin13 => PD6 an Atmgea8
Pin14 => PD7 an Atmega8
Pin15-16 => zunächst frei, LED-Beleuchtung noch nicht benötigt.

Allerdings zeigt das Display absolut keine Reaktion??

Supply voltage for LCD: VDD-VO | MIN:-0.3 | MAX:VDD+0.3 | V
nach dieser Formel dürfte die Kontrastspannung VO auch nicht negativ 
sein!
Was kann der Fehler sein??
Auf dem Display ist keinerlei Anzeige zu erkennen, auch keine Balken, 
Kästchen o.Ä. ?!

Vielen Dank schonmal

Gruß Christian

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Falk,
das LCD Tutorial kenne ich bereits.
Die Anschlussbelegung zur Stromversorgung habe ich ja soweit übernommen.
Und stimmen auch mit denen vom Datenblatt des Displays überein.
Allerdings müssten ja nach Einschalten der Stromversorgung schwarze 
Balken auf dem Display erscheinen, unabhängig von den restlichen 
"Datenleitungen" oder?

mfg

Autor: Michael M. (technikus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sollte zwar selbstverständlich sein, habe ich aber auch schon mal 
vergessen: Kontrastpoti ist sinnvoll eingestellt?

Servus
Michael

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael M. schrieb:
> Sollte zwar selbstverständlich sein, habe ich aber auch schon mal
> vergessen: Kontrastpoti ist sinnvoll eingestellt?

ja habe schon zwischen +1 und +4,5V ausprobiert, in keiner Stellung 
zeigt sich eine Regung.

Was kommt sonst noch in Frage?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was kommt sonst noch in Frage?
Eine Spannung unter 1V.
Evtl. ist sogar einen negative Spannung nötig :-o

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
>> Was kommt sonst noch in Frage?
> Eine Spannung unter 1V.
> Evtl. ist sogar einen negative Spannung nötig :-o

Naja aber laut der obigen Formel aus dem Datenblatt soll die 
Kontrastspannung zwischen -0,3 und +5,3V liegen.
Und es wäre unsinnig, wenn es nur unter 1V ginge.

ist das Display evtl defekt, oder kann es noch eine andere Ursache 
geben?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Und es wäre unsinnig, wenn es nur unter 1V ginge.
Wer sagt das?
Warum probierst du es nicht einfach aus?
Insbesondere bei Displays mit weitem Temperaturbereich zeiegen nur was 
an mit einer Kontrastspannung im Bereich von -3V..+1V ab.

BTW:
Ich habe meine Displays bisher alle ans Laufen bekommen ;-)

EDIT:
Auch ganz ohne Ansteuerung solltest du mit der Kontrastspannung eine 
Änderung erzielen können (schwarze Kästchen).

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  C. S. (chrisdask8)

>> Eine Spannung unter 1V.

Ja.

>> Evtl. ist sogar einen negative Spannung nötig :-o

Nicht bei den normalen Typen.

>Naja aber laut der obigen Formel aus dem Datenblatt soll die
>Kontrastspannung zwischen -0,3 und +5,3V liegen.

Nein. Die Formel ist reichlich irreführend und verwirrend, das liegt 
aber an der Schaltung im LCD. Dort ist Vcc das Bezugspotential, nicht 
wie üblich GND.

>Und es wäre unsinnig, wenn es nur unter 1V ginge.

Mach es einfach mal!!!

MfG
Falk

Autor: C. S. (chrisdask8)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Insbesondere bei Displays mit weitem Temperaturbereich zeiegen nur was
> an mit einer Kontrastspannung im Bereich von -3V..+1V ab.

DANKE Lothar, es ist wirklich so.
Habe gerade nocheinmal bis auf +0,5V herunter geregelt und siehe da, die 
Schrift ist erkennbar.
Ich hatte nur angenommen, der Kontrast sei voll zwischen O und +5V 
regelbar (im sichtbaren Bereich).

Danke nochmal, Problem hat sich gelöst!!

Gruß Christian

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau an, schau an . . .

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.