www.mikrocontroller.net

Forum: PC Hard- und Software USB Stick defekt?


Autor: Oszi Fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich hab vor knapp 2 Jahren einen USB Stick von PNY Modell Attaché 
Premium gekauft. Speicherkapazität ist 4GB.

Am Anfang war dieser USB Stick recht schnell. Also für mich völlig 
ausreichend. Nun allerdings Ist das Ding soo langsam geworden. 90mb 
brauchen ca. 6 minuten. Ist das Normal? Anzeichen eines baldigen 
Ablebens?

Daten sichern und neu formatieren hab ich schon pobiert, keine 
Besserung. Was kann man da Tun? Gibt es überhaupt eine Lösung auf mein 
Problem oder ist der Stick schrott? Man sollte vllt. noch erwähnen, dass 
der Stick in den fast 2 Jahren viel benutzt wurde.

Grüße!

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch mal vollständig formatiert bzw alles mit Nullen gefüllt?

dd if="/dev/zero" of="/dev/sdX0"

Flashspeicher braucht etwas mehr Zeit wenn er löschen muss.

Was aber auch sein kann das der Flash abgenützt ist und so die internen 
Signale der Speicherzellen nicht mehr so groß sind und die 
Auswerteelektronik dadurch länger braucht.

lg

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Teste mal an einem anderen Rechner.

Fehlertest schon mal gemacht? (HDTune z.B., auch für Geschwindigkeit)

Autor: Datensammler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
formatieren!
das hatte ich auch schon.
Ich habe den usb-stick dann unter windows (ganz normal) fomatiert, dann 
war er wieder wie neu!
Achte aber darauf, dass KEIN Häkchen bei 'Schnellformatierung' drin 
ist, sonst wird nur die Indextabelle gelöscht!

Du kannst auch mal darauf achten, dass der usb-stick, obwohl er leer 
ist, vor dem Formatieren mehr "belegten Speicherplatz" hat als nach dem 
formatieren.
Vor der Formatiern sind (obwohl keine Daten auf dem Stick sind) ein paar 
MB belegt, nach der formatierung waren es weniger als 100kB - 
offensichtlich passiert bei der formatieung also 'irgendetwas'.

Gruß

Autor: Icke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast nicht zufällig mit NTFS formatiert?

Autor: Oszi Fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nö, mit NTFS war er nicht formatiert. Der Stick läuft an allen mir 
verfügbaren PCs gleich langsam.


Nach dem Formatieren mit FAT32 sagt H2Testw  7.7mbyte/s schreiben und 
10.3 Mbyte/s Lesen. Keine Fehler.

Mal sehen ob sich jetzt was spürbar geändert hat...

grüße!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.