www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit Eclipse- Etwicklungsumgebung


Autor: Marcel K. (viewer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebes Forum,

ich habe gleich zwei Probleme mit meiner Eclipse- Umgebung.
Als erstes habe ich vor einigen Wochen die Ordnerstrukturen geändert in 
denen meine ganzen Eclipse- Projekte gespeichert sind. Dabei wurde 
lediglich ein einzelner Unterordner um zwei Buchstaben geändert. Das 
ganze ist mir aber erst aufgefallen als ich heute Morgen versucht habe 
ein alters Projekt zu öffnen. Es kam nur die Meldung, dass das 
>.project< file nicht gefunden werden kann. Naja ist mir dann schon klar 
dass dann das Projekt nicht geladen werden kann wenn der Pfad nicht mehr 
existiert. Jetzt habe ich verzweifelt versucht den Pfad zu änderen. Ich 
habe die >.project< Datei im Explorer mit einem Editor geöffnet und den 
einzigen Pfad den ich gefunden habe, korrigiert. Das hat aber leider 
nichts gebracht!
Weiß von euch jemand wie man wieder an die alten Dateien rankommt? Muss 
ich vielleicht wieder den alten Pfad herstellen und dann die Projekte 
exportieren? Aber selbst da weiß ich nicht, wie das geht.

Mein zweites Problem ist, ich wollte mit einem ATMEGA644P ein neues 
Projekt starten. Bisher habe ich nur mit dem ATMEGA16 gearbeitet. Jetzt 
habe ich in einem neuen Projekt über „Propeties\Target Hardware“ den 
MCU- Typ auslesen lassen und begonnen die UART in Betrieb zunehmen. 
Irgendwie hat’s nicht gleich geklappt. Naja dann habe ich halt einen 
alten ATMEGA16 auf das STK500 gesteckt und wollte etwas probieren wovon 
ich wusste das es beim 16er definitiv geht. Also habe ich im Projekt 
unter „Propeties\Target Hardware“ den MCU- Typ neu auslesen lassen. Der 
wurde auch erkannt. Aber in der >io.h< wird einfach nicht der 16er 
erkannt. Es bleibt immer:

#elif defined (_AVR_ATmega644P_)
#  include <avr/iom644.h>

aktiv.
Es sollte doch aber:

#elif defined (_AVR_ATmega16_)
#  include <avr/iom16.h>

aktiv sein.
Hat jemand eine Erklärung dafür, bzw. kennt jemand eine Möglichkeit wie 
ich den richtigen Controller in das Projekt bekommen?
Ich bin über jede Hilfe dankbar!!

Viele Grüße,
Marcel

Autor: Peter Hartmann (the_ride)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Vielleicht hilft dir das ja
http://www.wiki.elektronik-projekt.de/mikrocontrol...

cya The_ride

Autor: Gerd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> habe ich vor einigen Wochen die Ordnerstrukturen geändert in
denen meine ganzen Eclipse- Projekte gespeichert sind

Ordner im Workspace von Eclipse mit Explorer umbenannt? Dann könnstest 
Du folgendes versuchen: Eclipse beenden, Umbenennung rückgängig machen, 
Eclipse öffnen, Ordner in/mit Eclipse umbenennen. Wird aber vmtl. auch 
nicht gehen :) Zumindest habe ich auch schon öfter Umbenennungs-Probleme 
gehabt.

Autor: Marcel K. (viewer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
danke für eure Antworten, ich habe jetzt einen Weg gefunden. Leider 
nicht sehr unkompliziert aber wirkvoll.
Ich habe den alten Pfad noch mal hergestellt (kopiert). Dann habe ich 
nacheinander ein Projekt gelöscht, ein neues Projekt erstellt und in das 
gerede neu erstellte Projekt das aus dem alten Pfad >importiert<. War 
zwar ne menge Arbeit aber die einfachste die ich jetzt kurzfristig 
finden konnt.

Also dann Euch allen einen schönen Wochenanfang!!

grüße Marcel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.