www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 Anfänger


Autor: Tim B. (Firma: Privat) (hurdy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich mache gerade meinen Techniker und wir werden uns auch mit 
Mikrocontrollern beschäftigen. Also habe ich mal ne runde gegooglet und 
bin hier gelandet.
Ich habe mir ein Stk500 und drei atmega8 gekauft. Da ich im Bereich C 
schon Grundkentnisse habe wollte ich das AVR-GCC-Tutorial stück für 
stück durcharbeiten. Das STk500 ausgepackt den vorhanden Atmega8515 
ausgebaut und dan ging es los, in welchen Sockel wir der atmega8 
eingesetzt? (SCKT3200A2 oder SCKT3500D).
Bevor ich jetzt ein einfaches Prog schreibe (AVR Studio und AVR-GCC) 
muss ich ja noch eine Verbindung zwischen ISP6PIN und SPROG2 herstellen 
oder?

Ich hoffe meine Fragen sind nicht zu banal, aber irgendwo muss ich ja 
anfangen ;)

Lg Tim

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Bevor ich jetzt ein einfaches Prog schreibe (AVR Studio und AVR-GCC)
>muss ich ja noch eine Verbindung zwischen ISP6PIN und SPROG2 herstellen
>oder?

Ja.

MfG Spess

Autor: Albrecht H. (alieninside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tim B. schrieb:
> ...
>
> Ich hoffe meine Fragen sind nicht zu banal, aber irgendwo muss ich ja
> anfangen ;)
>

Z.B. mit dem STK500 User Guide:

Table 3-2. AVR Sockets

Autor: Tim B. (Firma: Privat) (hurdy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Albrecht H. schrieb:
>
> Z.B. mit dem STK500 User Guide:
>
> Table 3-2. AVR Sockets

Habe gerade das deutsch Handbuch aus dem Forum gefunden und werde es mir 
mal anschauen.
Ich denke da kommen trotzdem noch Fragen ;)

aber schonmal vielen Dank

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergiss das inoffizielle deutsche Handbuch. Schau im AVR Studio:
Menü -> Help -> AVR Tools User Guide

Autor: Tim B. (Firma: Privat) (hurdy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist ein neues Problem aufgetreten. Und zwar, ich habe das Bsp 
Programm aus euren Tut ins Studio kopiert und wollte es einfach mal 
übertragen. Wenn ich auf Build and Run kilcke kommt eine fehlermeldung:
"Could not connect to ISP40"

Ich bekomme aber eine verbindung zum AVR, über "Connect to AVR" bekomme 
ich eine Verbindung.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Wenn ich auf Build and Run kilcke

Das startet den (eingestellten) Debugger/Simulator.

Den Programmer wählst du mit dem 'Con'-Icon.

MfG Spess

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.