www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik TriCore & Dave


Autor: Charly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich versuche mit Dave den ADC vom TC1797 in Betrieb zu nehmen. Leider 
bisher kein Erfolg.

Auf eure sinnvollen Hinweise freue ich mich schon jetzt.

Danke.

Autor: Oktoberfestbesucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Charly schrieb:
> ich versuche mit Dave den ADC vom TC1797 in Betrieb zu nehmen. Leider
> bisher kein Erfolg.

Hallo Charly,
ich habe leider keine Erfahrung mit dem Tricore, außer das ich mal eine 
Platine auf der einer drauf war, 5 Minuten in Händen gehalten habe ;-)
Aber ich denke, du solltest schreiben wo das Problem liegt.
Ist es die Hardware oder die Software.

In jedem Fall, denke ich, das bei einem Software-Problem nur jemand 
kompetetnt ist zu antworten, der das Ding selbst schon mal in Betrieb 
genommen hat. Das dürften in der BRD so einer von einer Million Menschen 
sein. Ob einer dieser ca. 80 in Frage kommenden Leute jetzt hier mal 
vorbeischaut, und dann auch noch Lust hat, zu antworten, ist wie ein 
Lottogewinn.

Meine Erfahrung, wenn man in einer Thematik nicht gerade ein totaler 
Anfänger ist, verschwendet man hier im Forum mehr Zeit als es gebraucht 
hätte, sich die Lösung mit Google und C-Buch selber zu suchen.

Man kann kaum die kompettenten von den schwachsinnigen Antworten 
unterscheiden.
Gut wär es, wenn der Original Poster am ende mal sein Lösungslisting 
veröffentlichen würde und die schwachsinnigen Antworten gelöscht würden.
Dann würde das hier mit der Zeit zu einer 1A Datenbank für Electronik 
und Programmierlösungen werden.

Autor: Karl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
TC sind in jedem besseren automotive SG, und davon gibts ne ganze Menge 
aus De. Die Wahrscheinlichkeit hier jemanden zu finden, der Sich damit 
auskennt ist also nicht so klein ;) Was halt einfach fehlt ist die 
Problembeschreibung, aber das hat Bong, wie er meint, schon 
"eindrucksvoll" dargelegt ;).

Ach übrigens, meine Glaskugel geht nicht mehr, was hat die? Freue mich 
schon auf eure konstruktiven Antworten. SCNR.

Autor: Tante Käthe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo! Kann hier bitte der Moderator 'mal aufräumen?

Also was, wie, wo und wann?

Was verwendest Du?

Dave Dip von: 
http://de.sitestat.com/infineon/infineon/s?infineo...


Starter Kit: 
http://www.infineon.com/cms/en/product/channel.htm...


???

Autor: Charly (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Was verwendest Du?

Dave Dip von:
http://de.sitestat.com/infineon/infineon/s?infineo...

Ich verwende genau diese Dave-Version.

> Starter Kit:
http://www.infineon.com/cms/en/product/channel.htm...

Genau dieser StarterKit liegt bei mir auf dem Tisch.

Das Problem mit dem ADC ist folgender, dass er nicht sampelt.

Danke.

Autor: Carsten St. (carsten)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Charly,
kenne den TC1797 jetzt nicht so gut, habe aber schon bei den 8 u 16 
Bitter von Infineon mit dem DAvE und ADC gearbeitet. Dort muss man oft 
die AD-Wandlung einmal in Software anstoßen. Danach wandelt der ADC je 
nach Einstellung permanent oder zu bestimmten Events (z.B. PWM Flanken) 
weiter.
Hast du das irgendwann einmal gemacht (z.B. zwischen der Init und der 
while(1)-Schleife)? DAvE macht dir ja nur die Initialisierung (und 
stellt einige APIs bei), aber er erzeugt kein Programmablauf!

MFG
Carsten

Autor: klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich mich entsinne, triggert man eine A/D conversion per software, 
indem man in das CRPRx Register schreibt. Allerdings mußt du gerade beim 
ADC aufpassen dass du nicht irgendwo etwas übersehen hast, da es viele 
Register und Bits gibt welche Funktionen ein/aus-schalten.

Autor: Charly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke an Alle die sinnvolle Beiträge geliefert haben.

Der ADC funktioniert mittlerweile.

Die Dave-Einstellung war richtig. Man musste noch per Software den 
Request-Bit setzen, damit er los sampelt.

Danke.

Autor: tuho (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

könntest Du ganz kurz noch schreiben in welchem Register Du das Request 
Bit setzt?  Arbeite mit dem gleichen TC und werd auch in kürze den ADC 
in Betrieb nehmen.

Cheers,
Holger

Autor: Ghodhbani Walid (walid)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Charly schrieb:
> Danke an Alle die sinnvolle Beiträge geliefert haben.
>
> Der ADC funktioniert mittlerweile.
>
> Die Dave-Einstellung war richtig. Man musste noch per Software den
> Request-Bit setzen, damit er los sampelt.
>
> Danke.

Hallo Charly,
Kannst du bitte den ADC-Teil von dein Prjekt Posten, vor ein Problem 
stehe ich gerade auch  schon.
DAnke in Voraus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.