www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik ACS714 und stromführende Leiterbahnen unter IC?


Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
mich würde mal interessieren wie eure Einschätzung bezüglich 
stromführender Leiterbahnen unter einem ACS714 (Hall-Effekt Stromsensor) 
aussieht. Verfälscht der Strom durch die Leiterbahn unterhalb eines 
solchen ICs den Messwert? Könnte es schon helfen die stromführende 
Leiterbahn auf der anderen Platinenseite zu führen? Es geht um den 
ACS715 mit +/-5A Messbereich. Die Leiterbahn unter dem IC führt ca. 3A 
DC.

mfg
Stefan

Autor: Guido C. (guidoanalog)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan,

solche Infos stehe doch in der Regel in den Application Notes des 
Herstellers. Kennst Du die folgende Application Note?
http://www.allegromicro.com/en/Products/Design/an/...

Ich habe sie nur kurz überflogen. Aber ich denke die Leiterbahn 
unterhalb des ICs durchzuführen ist wohl keine so gute Idee. Schau Dir 
Bild 5 und den entsprechenden Text dazu an. Falls nötig wird dort sogar 
eine Abschirmung auf der Rückseite der Leiterplatte empfohlen. 
Wohlgemerkt Abschirmung nicht Leitung ;-)

Mit freundlichen Grüßen
Guido

Autor: Elektrolyt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hey stefan,

hast du schon Erfahrungen mit dem Chip, oder sind das die ersten 
Gehversuche? Ich möchte den auch für ein kleines Projekt einsetzen, bei 
mir ist unter dem Chip ausschließlich Masse. Nur bin ich noch ein wenig 
skeptisch, wegen der geringen Empfindlichkeit. 185mV/A ist nicht viel, 
darum habe ich noch ein Differenzverstärker vorgesehen. Vorher habe ich 
Ströme mit dem TI-Chip INA138 gemessen, allerdings gefällt mir da die 
Genauigkeit nicht so recht. Wenn ich den Verstärkungswiderstand zu groß 
wähle, messe ich nix brauchbares. Mal sehen was der ACS714 so kann.

Gruß Elko

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
vielen Dank für den Hinweis mit den Application Notes. Habe ich nicht 
dran gedacht das dort soetwas wichtiges drinstehen könnte. Ich habe im 
Datenblatt vermisst. Also es ist wirklich so das man es vermeiden muss 
stromführende Leiterbahnen nahe des ICs zu verlegen. Mal gucken ob ich 
meine Leiterbahn oder das IC noch umgeschoben bekomme. Nach den Angaben 
in den Application Notes sollte ein Abstand von 5mm bei meinen 3A 
reichen um den Einfluss im Messfehler unter 100mA zu bringen. Das reicht 
mir erstmal an Genauigkeit. Ich habe mit den Stromsensoren bis jetzt 
noch nichts gemacht. Ich finde die Teile aber sehr nett. Meine Leitung 
in der ich bidirektional Strom messen will wechselt das Potenzial mit 
ca. 30kHz von 0V auf 80V. Bei Messung mit Shunt und Diff-OP denke ich 
das ich Probleme bekomme, zusätzlich würde die Lösung mehr Platz und 
wahrscheinlich noch eine negative Versorgungsspannung benötigen.

mfg
Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.