www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 RS232 Spare, COM Port Zerschossen


Autor: Malte (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
da habe ich eben eifrig mit dem UART gespielt und Daten empfangen da 
passiert auf einmal nichts mehr :(.

Es funktionierte alles einwandfrei, als ich dann wiedermal, da ich nur 
einen COM Port am Rechner habe von Spare auf CTRL umgesteckte 
funktioniert nichts mehr. Er verbindet sich nicht mit dem Board...
Zum testen habe ich jetzt RXD und TXD mit einem Jumper gebrückt und mit 
Terminal v1.9b mal befehle gesendet... passieren tut da nichts :(. Ich 
hoffe ich habe das Prog. richtig eingestellt (siehe Bild).

Das ist mir gerade alles etwas schleierhaft, und der Port vom fast neuem 
PC im Eimer. So tragisch ist das nun nicht da ich eh eine PCI Karte 
kaufen wollte, aber wie kann so was passieren? Nicht das bei meinen 
weiteren arbeiten alle 2 Tage ein Port ab raucht...

lg Malte

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Das ist mir gerade alles etwas schleierhaft, und der Port vom fast neuem
>PC im Eimer. So tragisch ist das nun nicht da ich eh eine PCI Karte
>kaufen wollte, aber wie kann so was passieren? Nicht das bei meinen
>weiteren arbeiten alle 2 Tage ein Port ab raucht...

Es kann genauso gut der MAX202 vom STK sein.

MfG Spess

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so ;), habe es mit einem zweiten STK500 auch versucht. Damit konnte 
ich  keine Verbindung zu stande bringen...

Werde es gleich mal am PC meines Mitbewohners testen :(

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so ;), habe es mit einem zweiten STK500 auch versucht. Damit konnte 
ich  keine Verbindung zu stande bringen...

an einem anderen PC Funktioniert es über Terminal v1.9b...

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du vielleicht nur den betreffenden COM-Port durch eine andere 
Anwendung blockiert?

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mmm den PC habe ich schon 10 mal neu gestartet, COM Port Entfernt, neu 
Installiert, auf COM 1/2 gelegt, im Bios die IRQ umgestellt... tja mein 
Latein ist am Ende. Die PCI Karte habe ich nun bestellt und werde die 
tage dann sehen was Passiert. Es lief ja plötzlich nicht mehr, sprich 
ich habe den Schritt vorher 20 mal gemacht und beim 21 ging es nicht 
mehr. Dazwischen habe ich nichts anderes gestartet oder gemacht...

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Womit versorgst Du das STK500, mit normaler Wandwarze oder 
Schaltnetzteil?

Autor: Gast 10 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal ganz ohne STK500 versuchen.
Einfach am Kabelende Pin 2 mit 3 (9-poliger Sub-D) brücken
und mit dem Terminal-Programm Testen.

Ist das Kabel OK???? Wackelkontakt am Stecker?
Durchklingeln!

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wandwarze ;) in diesem Fall aber mehr Steckerleistenwarze mit 12V / 
0,8A...

SNT 3129 :: Stecker-Schaltnetzteil, 800mA -> Reichelt

http://www.reichelt.de/?ACTION=3;ARTICLE=42357;PROVID=2402

ja ja auf 12V gestellt ;)Sollte doch passen und lief 3 Jahre ohne murren 
:), bis ich nun mit dem UART anfing zu arbeiten und in den Spare stecken 
musste :(.

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gast 10 schrieb:
> Mal ganz ohne STK500 versuchen.
> Einfach am Kabelende Pin 2 mit 3 (9-poliger Sub-D) brücken
> und mit dem Terminal-Programm Testen.

Kabel noch nicht ausgetauscht, das STK500 Funktioniert wie gesagt an 
einem anderen PC, Pins am Kabel gebrückt und mit dem Oszy an RX/TX mal 
jeweils beim Senden vom berühmten "Hallo Welt" gemessen... nichts... ich 
kann ja noch mal unten am PC brücken :) ... gemacht funzt auch nicht :D.

Hier hat aber wohl gerade noch eine das gleiche Problem ;)

Beitrag "STK-500 - keine PC-Verbindung"

Das Board ist folgendes :), ja ja das Billigst und ich soll mich nicht 
wundern wenn mir der Port ab raucht ;)

http://www.asrock.com/mb/overview.asp?Model=M3A770DE

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Malte schrieb:
> SNT 3129 :: Stecker-Schaltnetzteil, 800mA -> Reichelt

Hmm - Schaltnetzeile neigen dazu, auf Masse der Sekundärseite bis zu 
110V Wechselspannung abzugeben, die sich aus Entstörmaßnahmen im Inneren 
des SNT ergeben. Der abgeleitete Strom ist dabei zwar nicht sehr hoch, 
aber es könnte beim Anschluß an den geerdeten PC zum Funkenüberschlag 
kommen, der dem STK oder dem PC gefährlich werden kann. Deswegen fragte 
ich.

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja gut vielleicht eine Möglichkeit... na ja morgen ist die PCI -> 
Seriell Karte da, dann werde ich mal schauen :(

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Kollege hat´s ja wieder hinbekommen: 
Beitrag "Re: STK-500 - keine PC-Verbindung"

Autor: Malte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja hat er, mein STK funktionierte aber an einem anderen PC... Jetzt mit 
PCI Karte läuft es bei mir auch wieder ;)...

Den grund für das Problem habe ich aber immer noch nicht gefunden :(

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.