www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Audioverstärker neben PC fängt sich Dreck ein


Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi zusammen,

ich habe mir für einen kleinen Rechner (JETWAY mITX) einen 
Audioverstärker auf Basis eines TDA1519B aufgebaut (2x 6W). Dummerweise 
fängt der sich ziemlich viel Mist ein. Dazu habe ich ein kleines Video 
gemacht, bei dem die Cam direkt neben einem Lautsprecher steht:
Youtube-Video "NF Störungen.wmv"


Man hört Festplattenzugriffe, Mausbewegungen, Grafikgeschichten (Fenster 
verschieben) und ein hochfrequentes Pfeiffen, das schon gar nicht mehr 
auffällt in dem ganzen Müll. Außerdem kommt ein neue Art von Fiepen, 
wenn der Rechner komplett aus ist (siehe Ende). Vermutlich hört man da 
das Netzteil? Ich benutze ein PICO-PSU WI, also einfach ein paar 
kompakte Schaltregler nebeneinander.

Das Problem ist, dass das alles in einem Gehäuse verbaut ist. Sowohl 
Pico-PSU als auch Audioverstärker sind also offen ohne Blech außenrum.

Das Kabel zwischen Soundkarte und AMP-Eingang ist ca. 40cm lang 
(unsymmetrisch) und führt wegen Platzproblemen auch ziemlich nah an 
allen anderen Komponenten vorbei. Der Abstand zwischen AMP und mainbaord 
sind aber nur 5cm...
Audio-GND, Pico-GND, ATX-GND und AMP-GND sind verbunden.


Spontan fällt mir nur ein:
Vielleicht wäre es eine Lösung, den Gain zu verringern (wie auch immer) 
und dafür das Audiosignal lauter zu stellen. Trotzdem finde ich das 
nicht schön. Und irgendwo muss der Dreck ja herkommen - dann lieber die 
Ursache beseitigen als die Symptome bekämpfen, oder?

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieses Problem kenne ich. Ich habe einfach einen Poti als 
Spannungsteiler in die Signalleitung eingeschleift und damit die 
Verstärkung verringert. Der Lautstärkenregler am PC wurde 
dementsprechend weiter aufgedreht.

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich habe vergessen zu sagen: ich habe bereits ein poti und selbst wenn 
den Eingang des AMPs auf GND zieht, sind manche der Störungen noch 
deutlich zu hören... :-(

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast extra Stromversorgung für Verstärker?

Armin schrieb:
> Audio-GND ... sind verbunden.


Audio-GND am Rechner trennen und nur einseitig am Verstärker lassen.
Dann durch probieren einen Punkt für die Masseverbindung zum Verstärker 
finden, wo die Störungen am geringsten sind.

Autor: Frank L. (hermastersvoice)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mini ITX klingt nach Onboardsound. Da wird der Dreck wohl schon vorm 
Verstärker reingekommen sein. Grad wenn man Plattenzugriffe hören kann 
ist meist ein schlechtes Layout des Boards dran schuld und man bekommt 
solche Effekte nur mit einer gesonderten Soundkarte weg.

bye

Frank

Autor: Rocker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Neben dieser elenden Katzenmusik, die Du da laufen hast, machen die 
Geräusche echt was her! Ich empfehle: Ausgang gleichrichten und Akkus 
laden.

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhh schrieb:
> Du hast extra Stromversorgung für Verstärker?

ich habe ein Laptop SNT, das als Versorgung für Rechner und AMP 
fungiert. Mein Labornetzteil liefert dummerweise nicht genug strom, 
damit das ding startet. Da das Mainboard nur einen ATX-Stecker hat, habe 
ich mir ein PICO-PSU besorgt (soll wohl beim Wirkungsgrad die Nase 
ziemlich weit vorne haben).

auf dem mainboard sind ATX-GND und Klinke GND verbunden.
im PICO PSU sind ATX-GND und SNT GND verbunden.
Und mein TDA benutzt für die Versorgung natürlich auch die Masse vom 
SNT. Außerdem ist diese Masse auch mit dem GND-Signal-Eingang des AMPs 
verbunden - ich bild mir ein, bei meinen ersten Versuchen ist mal so ein 
TDA abgeraucht, weil diese beiden Massen nicht verbunden waren (wenn ich 
das jetzt richtig in Erinnerung hab).

mhh schrieb:
> Audio-GND am Rechner trennen und nur einseitig am Verstärker lassen.
> Dann durch probieren einen Punkt für die Masseverbindung zum Verstärker
> finden, wo die Störungen am geringsten sind.

ich kann mal versuchsweise die Masseverbindung zwischen Soundkarte und 
Verstärkerplatine trennen, aber die Masseverbindung besteht trotzdem 
noch über mainboard und PICO-PSU.

Frank L. schrieb:
> Mini ITX klingt nach Onboardsound. Da wird der Dreck wohl schon vorm
> Verstärker reingekommen sein. Grad wenn man Plattenzugriffe hören kann
> ist meist ein schlechtes Layout des Boards dran schuld und man bekommt
> solche Effekte nur mit einer gesonderten Soundkarte weg.

richtig, onboardsound. Ich hatte mal ein Billignotebook, das sich 
ziemlich genauso angehört hat. Ich kann mir mal ein externes interface 
ausleihen und das testen - allerdings werd ich dafür keinen Platz haben 
- die dinger sind ja unverschämt klobig :(
Was mich nur wundert: Damals war so etwas noch zu verkraften, aber 
heutzutage, wo aus dieser Hardware Heimkino-PCs zusammengeschustert 
werden, darf die Soundkarte eigentlich keinen sonen Müll ausgeben. Ich 
versuchs mal mit Kopfhörern...
Plattenzugriffe sind aber nicht das Einzige - wie gesagt & gezeigt: man 
hört auch was, wenn der Rechner heruntergefahren ist!

Rocker schrieb:
> Katzenmusik

nächstes Mal schreibe ich vorher ein Drehbuch für son Video und poste es 
hier. Dann können wir ja vorher drüber diskutieren und solche "Fehler" 
passieren nicht ;)





Hardwarekomponenten:
Laptop SNT - http://www.reichelt.de/?ACTION=3;ARTICLE=53292;PROVID=2402
PICO PSU - 
http://www.mini-box.com/PicoPSU-120-WI-25-12-25V-D...
Mutterbrett - http://www.jetwaycomputer.com/NC81.html

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hörst du denn, wenn du den Eingang des Amps direkt an diesem 
Kurzschließt? So ließe sich schonmal eine miese Stromversorgung 
ausschließen.

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo zusammen,

ich habe heut einige Versuche gemacht und muss zugeben, ich bin mehr und 
mehr verwirrt:

Armin schrieb:
> Ich versuchs mal mit Kopfhörern...

Mit dem Kopfhörer waren keine Störungen zu hören. Das war bei meinem 
notebook damals nicht so. Da war auch direkt im Ohr ohne weitere aktive 
Bauelemente Müll zu hören.

mhh schrieb:
> Audio-GND am Rechner trennen und nur einseitig am Verstärker lassen.

Der nächste Versuch war, von den drei Audioleitungen zwischen PC und AMP 
die GND-Leitung zu trennen. Wie erwartet kam es zu keiner Veränderung, 
da ich ja bereits ein Poti hab, das das Signal auf GND ziehen kann, 
selbst da bleiben die Störungen da.

Luk4s K. schrieb:
> Was hörst du denn, wenn du den Eingang des Amps direkt an diesem
> Kurzschließt?

Mein Chip sieht so aus: GND -> Pin1, In1 -> Pin2, In2 -> Pin9
Wie man sieht, ist der Abstand und damit auch der Kabelweg von Pin1 nach 
Pin 9 ein paar cm lang (bei mir mit Klemmprüfspitzen ca. 20-30cm). Beim 
Kurzschließen sind die Störungen fast weg, nur der Speaker an Pin9 
kassiert noch leichten Rotz. Der wäre aber erträglich. Trotzdem seltsam, 
dass in der anderen Situation: "Poti zieht Eingänge auf GND" noch so 
viel eingefangen wird. Die Leiterschleife, die sich dann auf der Platine 
bildet, ist auch nicht länger.
Übrigens: läuft der Rechner, lässt sich die ankommende Störung durch 
Aufdrehen des Eingangspotis verstärken (und durch abdrehen nicht 
beseitigen). Ist er aus, ändert sich nichts an der Störung, wenn man am 
Poti dreht - also als ob da tatsächlich was über die Soundkarte kommt. 
Aber warum ist dann das, was man über einen Kopfhörer hört so sauber?
Die Pegel sind ja gleich, nur die Ströme ändern sich.

Frank L. schrieb:
> man bekommt solche Effekte nur mit einer gesonderten Soundkarte weg.

Habe ich jetzt noch keine da. Aber macht das denn Sinn hier 
weiterzutesten? Scheinbar ist das Problem beim AMP zu suchen (siehe 
Kopfhörer).


Dann habe ich noch das Surren nach dem Shutdown untersucht. Dieses ging 
weg, als ich das PicoPSU vom Netz nahm (dann hörte man nur noch mit viel 
gutem Willen ein Tacken, das vom unbelasteten SNT kam); war aber nach 
dem Anstecken vom Pico wieder da. Übrigens verschwindet dieses Surren im 
Rauschen, wenn man den gain auf Maximum dreht - wie vorhin schon 
getippt. Es wird also nicht lauter.





Kann man echt gar nichts machen? Ich finde das gerade ein bisschen 
enttäuschend. Meint ihr diese HTPCs sind ausschließlich so gedacht, dass 
der Rechner in einem Blechgehäuse sitzt? Wie war das mit Alu? Würde das 
auch helfen?

Ich find es sehr verstörend, dass man sogar Mausbewegungen hört - es 
also nur auf die Festplatte zu schieben, wäre ziemlich feige...
Ich hab sogar mal ganz mutig die Systemfestplatte im Betrieb abgesteckt 
- keine Veränderung!

Autor: Hans Mayer (hansilein)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach doch bitte mal ein Foto von dem Aufbau.

Autor: Armin (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
bin dabei...


Das Ganze soll eine art "Casemod" werden. Ein Rechner in einem alten 
Ghettoblastergehäuse aus den 80er Jahren. Zur Stromversorgung ist ein 
4s3p-Lipo-Zellensatz vorgesehen (im Moment noch nicht angeschlossen).
Mein momentaner Aufbau ist vom Abschluss der Bastelei noch weit 
entfernt. Um die Platzierung der Bauteile auszutesten habe ich mit einer 
Grundplatte aus Pressspan angefangen und sowohl oben als auch unten 
diverse Hardware angeschraubt


http://img689.imageshack.us/img689/8237/oben.jpg
auf dem ersten bild "oben.jpg" sieht man rechts unten die Unterseite der 
Verstärkerplatine mit angeschlossenen Lautsprechern. Außerdem zu sehen: 
die Festplatte in möglichst großem Abstand vom AMP (ein kürzeres 
SATA-Kabel ist bestellt) und der Lüfter für den Prozessor (unterseite).
Die Platine rechts oben übernimmt nur Verteilungsfunktionen. Hier kommen 
Audiosignale, USB vom MoBo (noch nicht angeschlossen!) und PWR/RESET 
über ein 40pol Flachbandkabel zusammen. außerdem wird hier später der 
Balancerstecker vom Akku angestöpselt (weiß)


http://img88.imageshack.us/img88/20/untenpg.jpg
das zweite bild "unten.jpg" zeigt die Rückseite der Pressspanplatte. 
Links eine Platine mit "Haudrauf-Strombegrenzung" für jede der 12 
Akkuzellen (wird wie gesagt später angeschlossen). In der Mitte das 
Mainboard mit draufgeflanschtem PicoPSU - alles wie gesagt noch eher 
provisorisch. Rechts die AMP-Platine mit 100k stereo poti.
Man verzeihe mir das Flachbandgedöns da kann man noch optimieren ^^. 
Aber wie gesagt: Der fängt sich auch was ein, wenn man das 
Eingangssignal am Poti auf komplett auf GND zieht. Nur wenn man direkt 
am Chip kurzschließt, ist Ruhe. Scheinbar macht also die Leiterschleife 
auf der Platine mehr aus, als die 30cm Flachbandkabel.


http://img48.imageshack.us/img48/286/ampi.jpg
das dritte bild "AMP.jpg" zeigt nochmal die Verstärkerplatine in groß. 
Außerdem ist da noch ein LowPower-Unterspannungsschutz für die Akkus mit 
drauf (deswegen die ganzen Megaohms).
Die USB-Maus war an einem Anschluss neben dem orangen LAN-Kabel dran.
Wie gesagt, alles etwas unfertig und in der Experimentierphase. 
Alternativ zum Klinkenstecker könnte man das audiosignal auch direkt vom 
Mainboard von den pins drüber abgreifen. Mir ist aber noch kein Argument 
eingefallen, warum es dann besser sein sollte.
Siehe auch das Layout - Ist evtl das Ground-Routing zwischen AMP und 
Poti zu schlampig? Ich mein das muss über zwei Drahtbrücken...



Falls keiner mehr eine weitere Idee hat, spiele ich für eine größere 
Dämpfung des Signals mit dem Gedanken, einfach noch zwei SMD-Widerstände 
von unten eingangsseitig auf die Platine zu pappen. Wie viel nehm ich 
da? 50k?

ps: wegen hoher auflösung sind die bilder nicht hier im board direkt als 
attachment. Hoffe, das passt so.
Falls noch irgendwas unklar ist --> hier fragen. Ich hab ja irgendwie 
interesse an einer schönen Lösung ^^

Autor: Hauke Radtki (lafkaschar) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde auch probieren den LineOut etwas zu belasten, so wie es die 
Kopfhörer tun würden.
Sonst kenne ich das Problem (und die Geräusche) von der Gitarre mit 
ordentlich Verstärkung, dann fängt die sich auch den Mist ein (offenes 
PC Gehäuse)

Von daher würde ich mir schon mal überlegen ob da nicht was mit 
Schirmung zu machen ist, Das Schirmgehäuse könntest du gleich als 
Kühlkörper für dein Audio IC nehmen.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast gerade gelernt was eine MASSESCHLEIFE ist :)
http://de.wikipedia.org/wiki/Brummschleife

. Vom Netzteil aus -> Dicke masse zum Mainboard UND zum AMP
. Analog-Ausgang -> Masse an Analog Eingang

Analoge Verstärker haben normalerweise eine sternförmige Massetopologie.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
|          MoBo                      |
   | Analog-Gnd                 ATX-Gnd |
   |------------------------------------|
        <--Strom durch Komponenten--
         =rhytmischer Spannungsabfall - Störungen

An dem Verstärker hast Du beide Massepunkte verbunden. Da sich der 
Arbeitspunkt des Analog-Ausgangs vom Mobo mitsamt des Analog-Gnd 
gleichmäßig verschiebt, hast Du im Kopfhörer oder Verstärker mit eigener 
Stromversorgung keine Störungen.

Richtig wäre, den Analog-Gnd als einzige Masseverbindung zum Verstärker 
zu nutzen. Bei 2*6 Watt allerdings schon wieder schwierig wegen des 
benötigten Stromes dafür. Helfen kann dann nur noch ein extra 
Vorverstärker mit Differenzeingängen, um die Störungen zu eliminieren.

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, ich habe eine Brummschleife gebaut, weil Signalmasse und 
belasteter GND verbunden sind und die Ströme den selben Weg wählen. Doch 
was ist jetzt die Maßnahme der Wahl?
a) Ich trenne Signalmasse vom restlichen GND-Weg und löse dadurch das 
Problem komplett. Soweit ich mich allerdings erinnern kann, raucht der 
AMP dann. Macht zwar keinen Sinn, aber ich bilde mir ein, das war so. 
Wenn ihr meint, das müsste eigentlich gehen, würd ichs riskieren.
b) Ich lege mit einem zusätzlichen Draht einen Weg vom Signal-GND 
Eingang an der Platine zum Signal-GND Pin des AMPs damit die Störungen 
(Potentialunterschiede --> Wiki) gringer werden. Genügt das vielleicht 
schon?


Was mich nur wundert, dass da selbst beim Mausbewegen Störungen 
entstehen - da sollte sich der Strom (größenordnung 1-2A) ja nicht 
großartig ändern, oder?


btw: die Soundkarte mit 220 Ohm zu belasten hat nichts gebracht. 
Trotzdem danke für die Vorschlag :S


Zusatz: Das war jetzt glaub ich nicht ganz so klug. Ich bild mir ein, 
grad einen speaker durch etwas zu viel Signal beschädigt zu haben - auf 
jeden Fall kratzt der gerade ziemlich fies bei basslastiger musik :(. 
Kann das sein, ohne dass man irgendwas von außen sieht - wie etwa eine 
zerrissene Membran?
Naja die speaker wollte ich eh irgendwann mal wechseln - hoffentlich 
finde ich welche, die passen...

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Armin schrieb:
> Was mich nur wundert, dass da selbst beim Mausbewegen Störungen
> entstehen - da sollte sich der Strom (größenordnung 1-2A) ja nicht
> großartig ändern, oder?

Der Prozessor muss die Mausbewegung ja umsetzen, der macht die 
Zusatzstörung.

Armin schrieb:
> Kann das sein, ohne dass man irgendwas von außen sieht - wie etwa eine
> zerrissene Membran?

Nein, Die Schwingspule hat sich verformt und schleift im Magnetspalt.


Zur Lösung:
Entweder extra Stromversorgung für den Verstärker, oder, wie von mir 
schon geschrieben, Signalzuführung mittels Differenzverstärker für den 
linken und rechten Kanal.

http://www.elektronik-kompendium.de/sites/slt/0210153.htm

Der invertierende Eingang kommt an Analog-Gnd, der nichtinvertierende an 
das Signal. Der Einfachheit halber die Schaltung auf Betrieb mit einer 
Betriebsspannung ändern. Der Verstärker darf nur eine Verbindung zur 
Rechnermasse haben (also keine Verbindung zum Analog-Gnd außer die vom 
Differenzverstärkereingang).

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
meinst du echt, das geht so?
wie du schon gesehen hast, ich habe keine negative Versorgungsspannung.
Trotzdem müsste doch das Audiosignal negative Anteile haben, oder ist 
das vorgespannt? Und diese müsste ich mit dem Differenzverstärker 
rausarbeiten - ohne dass ich ihm die entsprechende Versorgung geben 
kann...

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Armin schrieb:
> meinst du echt, das geht so?

Ja.


Am Beispiel von 
http://www.elektronik-kompendium.de/sites/slt/0210153.htm

R4 kommt nicht an Masse, sondern an Ub/2. Damit funktioniert das auch 
mit einfacher Betriebsspannung. An den Eingängen und dem Ausgang kommt 
jeweils ein Kondensator zur Gleichspannungsabtrennung (und nein, die 
negative Halbwelle Deines Signales wird nicht fehlen^^). Alle 
Widerstände machst Du 10 kOhm. Vom Mittelpunkt des Spannungsteilers für 
Ub/2 schaltest Du noch einen Kondensator 100 oder 220 µF gegen Gnd. Der 
ausgewählte OPV muss für Verstärkung =1 geeignet sein.

Autor: Düsentrieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tja, ich hatte das selbe problem...
habe nen kleinen verstärker in einen 5" einschub fürs PC gehäuse gebaut, 
versorgung von den 12V im PC.
audio von der onboard / rückwand - buchse
-> nettes knistern und grummeln, bes. wenn sich der bild-inhalt (!) 
ändert, also wohl vom stromverbrauch der graphik
-> offenbar (wie hier) ein problem der masseführung, bzw -schleife

1. versuch mit symm. differenz-verstärker : geräusche sehr gering, aber 
noch vorhanden ; vmtl packt der opamp die breibandigen störungen nicht 
ganz, da vor allem ein feines knistern noch blieb

2. versuch mit übertrager , sowas:
http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=IC4...

(hab die 2 mini-übertrager aus der plastikdose rausgenommen, wg 
platzverschwendung) :
geht wunderbar, keine störungen mehr .

Autor: Ronny Schmiedel (ronnysc)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe dazu bereits eine fertige Schaltung entwickelt und mehrfach in 
Betrieb.
http://home.arcor.de/ronny.schmiedel/mypage/elektr...
Vorteil gegenüber den NF-Filter sind keine frequenzbestimmenden Bauteile 
im Signalweg. Damit wird das Audiosignal nicht verfälscht.
siehe auch: http://www.meintomtom.de/forum/index.php?showtopic=36348 
oder
http://www.car-pc.info/phpBB2/viewtopic.php?t=2493...
Gruss
Ronny

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.