www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik externer A/D Wandler


Autor: Jens (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

Ich hab da eine Schaltung die ich nachbauen möchte. Die Schaltung 
besteht aus einem Microcontroller und einem externen A/D Wandler 
TLC2543. Jetzt nun meine Frage muß der A/D Wandler auch intern irgendwie 
programmiert werden, oder wie bekommt der Mikrocontroller die Daten aus 
dem A/D Wandler heraus (in welchem Format). Habe seither nur mit den 
internen A/D Wandler in den Mikrocontrollern experimentiert.

Mit freundlichen Grüßen

Jens

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin Jens,

also, programmiert werden muss der  nicht, aber er braucht natürlich 
Informationen darüber, was er machen soll, welchen Kanal er auswerten 
soll und so weiter. Du kannst den Bruder im 8bit Mode über das SPI des 
AVR´s  betreiben. Die Informationen über die Art des Datentransfers 
kannst du aber alle aus dem Datenblatt rauslesen. Das sieht auf dem 
ersten Blick auch recht einfach aus und errinnert mich an die 
(selbstgemachten) Probleme die ich mit dem "C-Bus" zuerst hatte.

Gruß,
Günter

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Günther,

welche Probleme hattest du denn mit dem C-Bus ?

nur so aus reiner Neugier, man kann ja nur daraus lernen.

Gruß

Jens

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
N 'abend Jens,

eigentlich waren es zwei Probleme: das Erste war ein Verständnissproblem 
des SPI allgemein und das Zweite war, den C-Bus Slave dazu zu bringen, 
Daten zu senden die der Master (im Mastermode) empfängt.
Problem 1 war relativ schnell gelöst und Problem 2 ließ sich nur durch 
Einsatz eines zusätzlichen Gatters beheben. Danach haute alles prima 
hin. Der Haken ist nämlich der, das ein C-Bus Slave selbstständig keine 
Daten sendet sondern nur auf Anforderung und ein Taktsignal hierfür 
benötigt. In den ersten Versuchen hatte ich immer das Problem mit dem 
WCOL bit, welches immer nach 8 bit gesetzt wurde und einen weiteren 
Empfang nicht mehr ermöglichte.

Aber nun klappt ja alles und die Hard - und Software läuft jetzt seit 
gut 3 Wochen störungsfrei.

Glückauf,
Günter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.