www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Brenner5 P Brenner8 P


Autor: Daniel B. (sir_hagbard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich bin neu hier und starte auch gleich mit einem Problem:

Ich habe vor einiger Zeit einen Brenner5 P von Sprut auf Lochraster 
nachgebaut, mit diesem auch schon diverse PICs gebrannt.

Nun dachte ich mir, ich bau mal den Brenner8p.

Dabei ist mir dann aufgefallen, dass mein alter Brenner nicht mehr 
funktioniert. Die Spannungen sind okay und die Transistoren schalten.

Am LPT Port kann ich die Spannungen mit dem Brennprogramm auch auch 
schalten.
Wenn ich einen 100R Widerstand von Pin2 auf Pin10 lege, erkennt das 
Programm dieses und gibt aus, Brenner gefunden.

Wenn ich den Brenner aber anschließe wird dieser nicht gefunden.
Die drei LPT Port Einstellungen im BIOS habe ich auch schon 
durchprobiert.

Weiß noch Einer Rat?

Oder würde mir jemand den Pic(18F2550) für den Brenner8p mit der 
entsprechenden Software bespielen?

Liebe Grüße!

Autor: Stephan S. (uxdx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal auf die Seite 
http://sprut.de/electronic/pic/projekte/brenner5/, da steht bei 
"bekannte Probleme" etwas von einem Kondensator 100nF zwischen Pin 2 und 
3 der ICSP-Buchse. Ich habe den Brenner8P9smd (Variation von Lars) auf 
der Seite http://sprut.de/electronic/pic/projekte/brenner8/ und bin sehr 
zufrieden.

Falls Du einen 18F2550 gebrannt haben willst, schreib mit eine PM

Autor: Ingolf O. (headshotzombie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das fremde Brennen des 2550 beseitigt aber Dein Problem mit dem alten 
Brenner nicht, also wäre zumindest mal abzuklären, welche Bedingungen 
sich zwischen dem Zeitpunkt, wo alles noch i.O. war und heute geändert 
haben. Einen Defekt schließt Du ja so ziemlich aus.

Autor: Stefa N. (exa)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Daniel,
hast du dir folgenden Hinweis angeschaut:
Modifizierung für den PIC18Fxxxx
http://sprut.de/electronic/pic/projekte/brenner5/mod.htm#12V
Der benötigt eine andere Spannung zum Programmieren.
Ich stand vor einiger Zeit vor dem gleichen Problem. Ich habe damals die 
beiden Spannungsregler auf Lochraster verfrachtet und sie via Jumper 
umschaltbar gemacht. Je nach PIC muss man dann hald den Jumper setzen, 
aber wenn du dir eh einen Brenner8 anschaffen willst wird dich das 
weniger kümmern.

Hoffe dir geholfen zu haben.
MfG
EXA

Autor: Peter Zabel (flexopete)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Daniel,

auch ich wollte vor langer Zeit den 18F2550 für den
Brenner 8P auf meinem alten Brenner 5 brennen.
Dafür musste ich den 7406 (ältere Brenner 5 Version)
gegen einen 7407 tauschen, andere Software und die
beiden Dioden in der Masseleitung des 12V Reglers
überbrücken um 12 zu erhalten.

Gruss
Peter

Autor: Stephan S. (uxdx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Dafür musste ich den 7406 (ältere Brenner 5 Version)
> gegen einen 7407 tauschen, andere Software und die

Ich habe mit einem Brenner5 (Rev 7e) schon mehrere 18F2550 problemlos 
gebrannt, wenn der 100nF-Kondensator dabei ist

Das Problem von Daniel ist aber, dass der Brenner nicht erkannt wird. 
Das könnte eher an einem fehlerhaften oder zu langem Druckerkabel 
liegen.

Autor: Sebastian Hepp (sebihepp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich tippe auch auf das Kabel als Ursache. Oder hast du einen neuen 
Rechner? Wenn du ein Multimeter hast, kannst du auch einfach mal alle 
Bauteile durchchecken. Vielleicht irgendwo ein Kurzschluss?

Ich könnte dir auch den PIC18F2550 brennen, wenn du möchtest. Ich wohne 
in Heidelberg. Pass beim Brenner8P rev5 auf die Bauteilbezeichnungen 
auf. Ich spreche da aus Erfahrung. =) Es gibt BC338-25 und BC328-25 
Transistoren. Ich habe beide als BC338-25er gelesen und mich hat es 
einen Monat gekostet, den Fehler zu finden. Zumal ich einen ausgetauscht 
habe und dann ging es immer noch nicht, da noch 2 andere darauf waren. 
=D

Viele Grüße
Sebihepp

Autor: Daniel B. (sir_hagbard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und Danke erstmal für das gute Feedback!

Also wenn ich mich recht entsinne, könnte vielleicht der Andere Rechner 
ein Problem sein.

Damals hatte ich noch einen Anderen.
Gut, der mit dem ich das jetzt wieder versucht hatte, ist aber auf dem 
gleichen alten Hardwarestand, hat aber ein anderes Board.

Die Parallelport Leitung hab ich durchgecheckt (mit einem Testgerät in 
der Firma in der ich arbeite), die ist auch nur 1m kurz.

Multimeter ist vorhanden.

Tja, dumme Sache. Ich werde die Tage erstmal noch bei einem bekannten 
versuchen, den Brenner anzuschließen.
Wenn auch das scheitern sollte, müsste ich auf ein Angebot für das 
Brennen zurückkommen. Danke schonmal.

Autor: Stephan S. (uxdx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Neuere Rechner arbeiten an den Ports oft nicht mehr mit 5V-Pegeln, 
sondern mit 3.3V.

2. Hast Du an Deinem neuen Rechner einen echten Parallel-Port (auf dem 
Board oder auf einer Karte) oder hast du einen Adpater, der über USB 
angebunden ist? Im letzteren Fall geht das sicher nicht mehr mit dem 
Brenner5, der braucht einen echten Parallel-Port. Daher ja auch der 
Wechsel zu Brenner8 bzw. 9. Lies das mal bei sprut.de nach. Dann hast Du 
hier im Forum mindestens 2 Angebote, die Dir einen 18F2550 für einen 
Brenner8 bzw. 9 brennen.

Autor: Daniel B. (sir_hagbard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das ist schon noch nen "echter" Onboard LPT Port.

Es liegen gemessene 4,7V am Ende der Parallelportleitung an.

Autor: stephan_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- evtl. neues Betriebssystem?
- ZLPORTIO.SYS (im gleichen Verzeichnis wie pbrennerng45.exe)
- schreib doch mal ne Mail an sprut

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.