www.mikrocontroller.net

Forum: Platinen Eagle Massefläche - Abstand zu Bauteilen


Autor: EaglePolygon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Wie verändere ich den Abstand von Masseflächen bzw allgemein von 
Polygonen zu Bauteilen?

Im Anhang ist der Teil eines Layouts zu sehen. Der Abstand von den 
Masseflächen zu den krummen Leiterbahnen (rechts im Bild) muss genau 
200µm sein. Das klappt auch soweit nur sieht man, dass dort wo die 
Bauteile auf den Bahnen sind, der Abstand an der gegenüberliegenden 
Seite größer ist. Wie stelle ich ein, dass der Abstand zu den Bauteil 
Pads genauso groß ist wie der zu anderen Leiterbahnen?

: Verschoben durch Moderator
Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du da Sperrflächen im Bauteil?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  EaglePolygon (Gast)

>Wie verändere ich den Abstand von Masseflächen bzw allgemein von
>Polygonen zu Bauteilen?

ISOLATE. Schau auch mal in die Hilfe von Eagle. Bei Polygonen geht auch 
noch die Linienbreite mit ein. Und die Minimalabstände im DRC.

>200µm sein. Das klappt auch soweit nur sieht man, dass dort wo die
>Bauteile auf den Bahnen sind, der Abstand an der gegenüberliegenden
>Seite größer ist.

Blende mal den Layer trestrict ein und staune.

MFG
Falk

Autor: EaglePolygon (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sperrflächen...nicht das ich wüsste, ich habe die Footprints selbst 
erstellt und einfach nur Polygone bzw Pads benutzt ansonsten kein 
Schnick Schnack...

Ich hab nochmal ein Bild mit allen Layern gemacht, da ist zwar ein Rand 
um die Pads, aber obwohl ich den jetzt auch auf die Leitung geschoben 
habe, sind die Polygone immer noch nicht so wie ich sie will.

Mit Isolate habe ich die 200µm eingestellt, bei Spacing den normalen 
Wert gelassen (wenn ich den ändere tut sich eh nichts).

Was könnte man sonst noch verstellen?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  EaglePolygon (Gast)

>Sperrflächen...nicht das ich wüsste, ich habe die Footprints selbst
>erstellt und einfach nur Polygone bzw Pads benutzt ansonsten kein
>Schnick Schnack...

Wahrscheinlich hast du den falschen Layer für die Bauteildarstellung 
genutzt. Die gehört in tplace. Wenn du Dimension erwischt hast, wirkt 
das wie ein Platinenrand. Probier mal im DRC die Einstellung Distance -> 
Copper/Dimensions zu ändern. Wenn sich was zuckt, ist der Fehler 
eindeutig wie beschieben.

>Mit Isolate habe ich die 200µm eingestellt, bei Spacing den normalen
>Wert gelassen (wenn ich den ändere tut sich eh nichts).

Spacing ist egal, das ist ein Parameter für schraffierte Flächen, nutz 
man heute kaum noch.

Aus der Eagle-Hilfe zu POLYGON

"Isolate: Distance between polygon areas and other signals or objects in 
the Dimension layer (default: 0). If a particular polygon is given an 
Isolate value that exceeds that from the design rules and net classes, 
the larger value will be taken. See also Design Rules under Distance and 
Supply, respectively."

MFG
Falk

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was könnte man sonst noch verstellen?

Füll den Rest per Hand.

Autor: Wolfgang R. (portside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie oben schon erwähnt Linienbreite des Polygons erhöhen

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube nicht, dass das was bringt.

Ich würde lieber mal das mit dem Dimension-Layer überprüfen. Die 
Gehäuseabmessungen, wie gesagt, mit tPlace erstellen.

Wenn du das nicht machst, dann hast du spätestens bei der 
Platinenherstellung ein Problem.

Autor: EaglePolygon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner schrieb:
> Wahrscheinlich hast du den falschen Layer für die Bauteildarstellung
> genutzt. Die gehört in tplace. Wenn du Dimension erwischt hast, wirkt
> das wie ein Platinenrand. Probier mal im DRC die Einstellung Distance ->
> Copper/Dimensions zu ändern. Wenn sich was zuckt, ist der Fehler
> eindeutig wie beschieben.

Falk hats erkannt, vielen Dank.

Ich hatte die Bauteile mit einem Kasten im Dimension Layer gezeichnet, 
wusste nicht, dass der für was anderes gedacht war. Habe die Dimension 
Ebene durch tplace ersetzt und jetzt füllen sich die Polygone wie ich es 
will. THX

Autor: Florian W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es hätte auch genauso gut eine Einstellung im DRC sein können.

Da kannst du den Minimalabstand für Wire/Wire, Wire/Pad, Wire/Via, etc. 
jeweils getrennt einstellen. Normalerweise ist der Abstand Wire/Pad 
größer als Wire/Wire was ebenfalls zu genau diesem Symptom führen kann.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.