www.mikrocontroller.net

Forum: Platinen FDN 335 N - Kaputt oder Denkfehler beim Anschließen?


Autor: didadu (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eine kleine Stepper-Driver-Schaltung gebaut, aber sie 
funktioniert nicht. Sie ist eigentlich so einfach, dass kein Problem 
auftreten sollte (und war als einfacher Test meines LED-Belichters 
gedacht), aber dennoch ... und ich stehe gerade auf dem Schlauch und 
vermute ein Brett vor'm Kopf.

Achtung: Die verbauten Transistoren sind FDN 335 N ("N-Channel 2.5V 
Specified PowerTrenchTM MOSFET"), im Schaltbild ist jedoch ein anderes 
Symbol (kenne Eagle noch nicht gut genug, um selbst Symbole 
zusammenzuwurschteln). Zum Vergleich habe ich jedenfalls den 
Datenblattanfang des MOSFETS beigefügt.

Fehler: Bei Anschluss der 12 V zieht das Netzteil so viel Strom wie 
seine Strombegrenzung hergibt (waren ca. 600mA, und irgendwas in der 
Schaltung wird sehr warm (Rauchzeichen). Werden die Eingänge auf Masse 
gelegt, dann jedoch nicht.

Der Stepper selbst zieht bei 12 V nur 170 mA -- und die Schaltung zieht 
selbst dann Strom, wenn der Stepper gar nicht angeschlossen ist...
Dioden getestet: sie sperren/öffnen wie gewünscht.
Kurzschlüsse habe ich beim Durchklingeln nicht gefunden.

Ich vermute, dass ich was mit der Ansteuerung dieser MOSFETS nicht 
richtig begriffen habe.

Autor: didadu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was man auf dem Bild der Platine wegen der Verpixelung nicht sieht, ist 
jeweils der Abstand zwischen G und der gemeinsamen Masseleitung.

Autor: didadu (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch 2 Fotos von dem Teil.

Was habe ich falsch gemacht?

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
teilen sich die ports "input" und "stepper" die selbe masse?
hast du beim anschließen der 12V irgendwas bei "input" angeschlossen? 
wenn nicht, waren deine transistor-gates von dem geladen, was grad durch 
die luft fliegt.
wo ist die ableitung der induktionsspannung gegen masse?

Autor: didadu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Des Rätsels Lösung: Wer misst, misst Mist.

Anscheinend waren doch zwei Dioden kaputt (Gebrauchtdioden...). So zog 
sich beim Durchschalten jener zwei damit verbundenen Transistoren die 
Spannung runter.

Die Reparatur war dann etwas schwierig, weil ich beim Umbau zwischen 
denselben Dioden einen Kurzen produzierte, der nicht offensichtlich war 
(ein Tag mit erhöhtem Murphy): durch das Gewürge beim Ausbau (oder eine 
schlechte Leiterbahn?) hatte sich eine Leiterbahn gelöst und -- unter 
Dreck vom Flussmittel -- wieder diese beiden betroffenen Transistoren 
verkoppelt.

Nun ja, nach einigem Hin-und-Her-Gemesse und Nachdenken, was die 
verschiedenen gemessenen Spannungen bedeuten, geht's jetzt.
Das Schaltungsprinzip ist also soweit i.O.

Die Transistoren haben das Geteste zum Glück überlebt.

@Michael M. (ad-rem)
Ich habe den Gates jetzt Pull-downs spendiert. Sie werden zwar 
irgendwann im Gegentakt von einem AVR angesteuert, aber es ist besser, 
wenn man händisch damit testen will, und man hat so auch beim Reset des 
AVRs definierte Zustände.
Der gemeinsame Anschluss des Steppers ist bei der Schaltung an +12V, die 
Transistoren schalten die Spulen dann gegen 0V.
Was für eine Induktionsspannung muss ich nach Masse ableiten? Ich 
dachte, ich habe den Abschaltfunken mit meinen Dioden schon erschlagen. 
(Es ist ja ein unipolarer Stepper. Oder ist das ein Denkfehler? Oder 
spielt das eine Rolle für den Fall, wenn der Motor mal von extern 
angetrieben wird?)

Autor: didadu (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der Schrittmotor ist übrigens ein älteres Teil, auf welchem steht:

Logo: S in einem C, dann:
77673175
STH-39D138
1.8DEG/STEP 12V 0.171A
NO. 09252
SHIMANO KENSHI CO., Ltd. Japan

Ein Datenblatt habe ich im Netz nicht gefunden (wie auch schon andere 
vor mir nicht). Ich habe den als Foto angehängt, damit auch andere Leute 
ihre alten Stepper hier wiedererkennen können.

Autor: didadu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> SHIMANO KENSHI CO., Ltd. Japan
Korrektur:

SHINANO KENSHI CO., Ltd. Japan

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
didadu schrieb:
> (Es ist ja ein unipolarer Stepper. Oder ist das ein Denkfehler? Oder
> spielt das eine Rolle für den Fall, wenn der Motor mal von extern
> angetrieben wird?)
genau für den fall meinte ich.
da müssen momentan die dioden im mosfet herhalten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.