www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik MC34063 surrt bei 24V Eingang


Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe von Reichelt das "SNT 3122" Steckernetzteil, Eingang 12..24V 
Ausgang 1,5..12V.

Wenn ich das bei 12V betreibe ist es leise. Bei 24V allerdings macht es 
krach, ist laut, surrt, pfeift. Zumindest ist es sehr störend.

Ich habe schon mehrere probiert, immer das gleiche. Also ist es nicht 
kaputt.

Ich habe es mal aufgeschraubt und dort ist ein RT34063A drin. 
Datenblatt:
http://pdf1.alldatasheet.com/datasheet-pdf/view/20...

Vom Aufbau her ist es ein typischer Step-Down Regler.
Die Spule ist ein Ringkern (gemessen) 134uH.
Der Kondensator am Tc Pin hat 1nF.
Die Last etwa 300-500mA.

Was muss ich ändern damit das leiser wird?

Vielen Dank für eure Tipps.

: Verschoben durch Admin
Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Markus Müller (mmvisual)

>Was muss ich ändern damit das leiser wird?

Wahrscheinlich ist die Drossel zu lasch gewickelt und summt auf Grund 
der etwas komischen, pulsartiegen Regelung des ICs. Man kann die Spule 
DÜNN mit Epoxidharz tränken, das sollte das Geräusch deutlich dämpfen.

MFG
Falk

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner schrieb:
> Man kann die Spule
> DÜNN mit Epoxidharz tränken, das sollte das Geräusch deutlich dämpfen.
warum is denn die schichtdicke so wichtig?

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Giesharz hab ich leider nicht, nur Kleber oder Wachs.

Ich habe mal ein paar andere Spulen rein gemacht. Reichelt L-PISR100, 
150 und 220. Immer laut.
Diese Spulen sind gut gewickelt.

PS: Ich habe den Ausgang auf 7,5V eingestellt und einen 18R 
Lastwiderstand dran. Also kein Gerät, das stören könnte.

Autor: Gebhard Raich (geb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier gibt es 2 mögliche Probleme:

1. Die Drossel könnte bei 24V zu klein sein,Ströme werden 
hoch,Strombegrenzung und/oder übermäßiger ripple stört das 
Regelverhalten.

2.Die Phasenkompensation der Regelschleife passt nicht für 24V.

Ohne Oszilloskop tappt man da weitestgehend im Dunklen.

Grüße

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Datasheet sagt zu diesem SNT: 1,5Amax. Wenn da nicht noch ein 
Leistungstransistor drin sitzt, dann ist dieser Teil schon mal gelogen. 
Denn diese 1,5A sind das Limit des Transistors im IC, sind folglich am 
Ausgang nicht erreichbar - nach landläufiger Berechnungsmethode die 
Hälfte.

Mit dem 34063A ist es nicht wirklich angenehm, ein Weitbereichsnetzteil 
zu bauen, da die Schaltfrequenz in ebenso weitem Bereich variiert. 
Entweder ist sie irgenwann zu hoch oder zu niedrig. Da dürfte sich ein 
Frequenzmix einstellen, der hohe Anteile im hörbaren Bereich hat. Wenn 
dann Spule, Kondensatoren, ... Laut geben, dann eben hörbar.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist da ein Leistungstransistor drin? Wie gross ist Rsc? Der sitzt 
zwischen den Pins 6 und 7.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gebhard Raich schrieb:

> 2.Die Phasenkompensation der Regelschleife passt nicht für 24V.

Wie der Name des IC schon suggeriert ist das ein Klon des üblichen 
MC34063A. Bei dem muss man sich um solche Feinheiten normalerweise nicht 
kümmern.

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Du hast recht, da ist ein Leistungstransistor drin. Es müsste ein 
PNP Typ sein, denn der hängt an +24V. Der RT34063A schaltet nach GND 
(Pin 3 ist an GND, Pin 1+8 sind über R's an Basis des Transistors)

Anbei ein Foto der geschaltenen Spule.

Ich habe mal den C von Tc auf 470nF verkleinert, aber es macht kein 
unterschid ob da nun der 1nF drin ist oder auch einer mit 1,5nF.

Der Schaltregler schaltet durch, dann wieder ab und eine Pause. ABer 
immer wieder schaltet der dazwischen auch mal "kurz" ab. Siehe Bild.

Der Rsc müsste 1Ohm haben (Bn/Sw/Silber) Messen tue ich 0,35 Ohm.

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Schema ist im Datenblatt Seite 5 "(b) External PNP Saturated Switch"

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Markus Müller schrieb:

> Anbei ein Foto der geschaltenen Spule.

Deine Spule sieht mehr nach einem Oszi aus ;-). Aber was zeigt der an?

Ich kann das Raster zwar kaum erkennen, aber das sieht nach 6-10KHz aus, 
variierend wie bei diesem Regler üblich. Wenn du nicht schon der Rente 
nahe bist, dann ist das locker im Hörbereich.

> Ich habe mal den C von Tc auf 470nF verkleinert,

Nanofarad?

> Der Rsc müsste 1Ohm haben (Bn/Sw/Silber) Messen tue ich 0,35 Ohm.

0,35 Ohm ergäbe knapp 1A Spitzenstrom. Das wiederum ginge auch ohne 
externem Schalttransistor, ergäbe aber niemals 1,5A am Ausgang.

1 Ohm erscheint irgendwie sinnlos. 330mA Stromlimit für wen?

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, 470pF.

Auf der Packung des Teils steht 1500mA Max.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wäre nützlich, zu sehen in welcher Betriebsart er arbeitet. Dafür ist 
der Strom durch die Spule der interessante Wert. Normalerweise kann man 
das über Rsc messen, vorausgesetzt der sitzt wirklich da wo er hin 
gehört, was bei 0,35/1 Ohm nicht zu sein scheint. Ist ausserdem bei 
gemeinsamem Massebezug nicht so ganz leicht zu messen.

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mal einen 1,5 Ohm Widerstand in die Spule mit rein gebaut und 
gemessen.
Das Oszi habe ich an einen 12V Akku angeschlossen und ist potentialfrei.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was immer du da misst, der Stromverlauf durch eine Schaltreglerdrossel 
ist es nicht. Schon vom Kurvenverlauf her. Aber auch von den Werten her, 
50mVss bei 1,5 Ohm entprechen 33mAss.

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Doch, garantiert.
Hier in dieser  Spule hab ich den extra Mess-R rein mit 1,5 Ohm. 
Parallel zu dem gemessen.

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab noch mal gemessen, diesmal an dem R wie Du geschrieben hast.

Und das Kabel war unterbrochen zum 18R Last. (vermutlich schon bei der 
anderen Messung) Ist nur ein fliegender Aufbau.

PS: Die Messung ist invertiert. +24V = Oszi GND / Messspitze = Pin7

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ergibt immer noch keinen Sinn. Wenn man an eine Spule eine Spannung 
anlegt, dann steigt der Strom an. Das haben Spulen so an sich. Sowas 
muss bei einem Step-Down in der Einschaltphase zu sehen sein.

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab nochmal gemessen an dem Mess-R den ich eingelötet habe. Jetzt 
sieht die Grafik besser aus.

Steigender Strom, dann abfallender Strom.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ich das Raster kaum erkennen kann: sind das ca. 3,5V Amplitude? Das 
wären bei 1,5 Ohm um die 5A?!

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
7 Raster, 3,5V, 1,5 Ohm  2,33A

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yep, hatte falschrum gerechnet.

Passt einigermassen. Sieht nach lückendem Betrieb ohne Sättigung aus. 
Und halber Ct ändert nichts am Bild? Welcher L war das eigentlich?

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe Ct auf 470pF geändert.
L ist Original mit 135uH. (wie oben das Foto)

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Michael M. (ad-rem)

>> Man kann die Spule
>> DÜNN mit Epoxidharz tränken, das sollte das Geräusch deutlich dämpfen.

>warum is denn die schichtdicke so wichtig?

Wegen der Kühlung. Je nach dem wie die Drossel dimensioniert ist, wird 
die mehr oder weniger warm. Eine dicke Epixidharzschicht verchlechtert 
die Kühlung. Auch wenn Kupferdraht sehr robust ist, sollte man das nicht 
übertreiben.

MfG
Falk

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als nächstes hätte ich mal an Rsc gespielt um die Spule dezenter zu 
laden. Und hätte den testhalber mal auf 0,22-0,33 Ohm vergrössert. 
Müsste die Amplitude der Stromkurve niedriger werden, dafür häufiger. 
Der maximal mögliche Laststrom könnte allerdings darunter leiden.

Bn/Sw/Silber entspricht übrigens 0,1 Ohm. Und damit passt auch der 
endlich ins Bild, mit 3,3Amax.

Apropos Widerstandswert messen: Wenn man Widerstände < 1 Ohm misst, hat 
man Kontaktwiderstände und Messkabel mit drin.

Alternativ kannst du auch versuchsweise die Induktivität halbieren, aber 
denk dabei an den erwähnten Spitzenstom.

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Grad sind ein paar Handwerker gekommen, teste das nachher, melde mich 
dann wieder...

Autor: Gebhard Raich (geb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Induktivität deiner Drossel ist jedenfalls zu klein(Strom durch die 
Drossel sollte nicht 0 werden). je nach Stromripple komm ich bei 30kHz 
auf 220-330uH (5V/0,5A out).Es wird generell ein Problem darstellen, in 
weiten Bereichen eine saubere Taktung zu erreichen. Du kannst mal 
probieren zwischen Ausgang und "Comp" Anschluß einen Kerko mit ca. 100pF 
zu geben. Das könnte die Sache auch beruhigen.

Grüße

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gebhard Raich schrieb:

> Die Induktivität deiner Drossel ist jedenfalls zu klein(Strom durch die
> Drossel sollte nicht 0 werden).

Obacht. Der lückende Betrieb ist für den MC34063A geradezu typisch. Im 
Unterschied zu Reglern wie den LM257x.

> Es wird generell ein Problem darstellen, in
> weiten Bereichen eine saubere Taktung zu erreichen

Eine saubere weitgehend gleichmässige Taktung sollte man bei diesem 
Regler ohnehin nicht erwarten. Ist nicht seine Arbeitsweise.

Autor: Markus Müller (mmvisual)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt 0,3R drin. Hatte nur 0,1R in der Schublade.

Anbei Bilder für C 470pF und 1nF.

der 1nF macht vom Oszi-Bild her einen besseren Eindruck. Da fließt auch 
nicht so viel Strom als wie bei 470pF.

Und das aller wichtigste: das ist Leise, kein surren mehr. Egal welcher 
C drin ist.

0,2R sind zu wenig, da hört man wieder etwas. Ich denke 0,33R sind dann 
schon gut. Ich muss gleich mal meine Kisten druchforsten ob ich welche 
auftreiben kann.

Eigentlich ist das mit den Farbringen einfach zu merken, Gold ist mehr 
Wert als Silber, daher Bn/Sw/Silber = 0,1R und nicht 1R...

>Du kannst mal probieren zwischen Ausgang und "Comp" Anschluß einen Kerko >mit ca. 
100pF zu geben.
Den Test habe ich nicht gemacht. Es geht ja jetzt.

Vielen Dank für die Tipps und Hilfe! Alleine wäre ich sicher nicht so 
schnell auf die Idee mit dem größeren R gekommen.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Prima. Aber achte auch auf die Ausgangsspannung, insbesondere bei 
steigender Last.

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Grmbl.

Jetzt habe ich das Teil dort eingebaut wo es hin sollte, als 
Steckernetzteil für den Router. Der möchte anspringen, dann aber 
schaltet der ab und macht einen Reset. Also der Strom reicht doch nicht.
Wenn ich eines einstecke ohne diesen Umbau, dann tut es.

Hmmm. Ich mache morgen weiter. Mal eine Nacht drüber schlafen vieleicht 
träume ich davon.

Nur der Frage vorweg, meine Hausstromversorgung ist 24V für alle Lampen 
(LED) und Kleingeräte mit Akku und Solar...

Wenn das mit dem 34063 nicht klappt würde ich einen anderen nehmen. z.B. 
LT1074 von Linear. Der ist aber leider nicht Kurzschlussfest.

Autor: Mike J. (emjey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Markus Müller
Der Widerstand von 0.33 Ohm ist zu groß wenn die Spannung am Ausgang 
nicht gehalten werden kann.

Beitrag "Re: MC34063 surrt bei 24V Eingang"
Die Spule scheint zu klein zu sein.

Hast du eine 300µH Spule oder größer?

Autor: Markus Müller (mmvisual)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt gehts, ich bin zwar noch nicht ganz zufriden, aber es geht.

Den R habe ich auf 0,25R verkleinert. Ich habe nur 1R in der Kiste, 
davon 4 Parallel.
Den C von Tc auf 470pF verkleinert.

Die Spule wird schon gut warm. Ich hoffe die hält es aus. Mit dem 0,25R 
hört man ein gaaanz leichtes Pfeifen, ist noch im vernachlässigbaren 
Bereich.

Mehr wie diese beiden Bauteile habe ich nicht umgebaut.

Danke euch allen!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.