www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Pull-Up-Widerstände an IRF9510


Autor: Carsten Born (corvulus)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen!

Ich würde gerne, wissen, ob ich die Widerstände bei 10kΩ belassen kann, 
oder ob z.B. ein 1MΩ Widerstand besser wäre.
Die Schaltung ist erprobt und funktioniert, solange die externe 
Logikschaltung an dem Stecker (P8 ist +5V und die anderen Ports 
verhalten sich wie GND) angeschlossen ist.
Wenn nicht, kann es passieren, dass die LEDs nach einer Weile leuchten. 
Ich denke das ist der Latch-Up Effekt, oder? Dies möchte ich nun mit den 
Widerständen unterbinden. Die LEDs haben etwas mehr als 2W.

Gruß Carsten

: Verschoben durch Admin
Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe, irgendwo nach dem Gleichrichter versteckt sich noch ein 
ELKO...?!

Autor: David Madl (md2k7)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke nicht, dass das was mit Latch-up zu tun hat. Die Gates (bzw. 
die Leitungen/Leiterbahnen dran) fangen einfach als "Antenne" kapazitiv 
oder induktiv eine Ladung ein...

Wenn man ranfasst, leitet man den schönen 50 Hz Umgebungsbrumm hinein, 
je nach Zeitpunkt des Loslassens bleibt dann eine gewisse Ladung übrig. 
Sollte man an einem offenen Gate allerdings nicht machen, da die FETs 
sehr überspannungs- und damit ESD-empfindlich sind.

10 k passt, da er mehr Störungen ableiten kann als 1 M.

Gruß
David

Autor: 445 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Born schrieb:
> solange die externe
> Logikschaltung an dem Stecker (P8 ist +5V und die anderen Ports
> verhalten sich wie GND) angeschlossen ist

Und wenn die floaten, dann fangen deine LEDs an zu leuchten?

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnellen Antworten! :-)

445 schrieb:
> Und wenn die floaten, dann fangen deine LEDs an zu leuchten?

Ja, die LEDs leuchten, wenn die Logik schaltet. Nur, wenn ich die nicht 
eingesteckt habe, kann es halt zu den Fehlern führen, dass die LEDs 
trotzdem leuchten.
Die flackern dann Teilweise, bis sie die normale helligkeit erreicht 
haben.
Bei der schon bestehenden Platine habe ich einfach mal so einen 
Widerstand eingelötet, das hat zumindest das Problem behoben.
War mir nur nicht sicher, ob 10k vielleicht nicht zu viel durchlassen 
und das sich dann irgendwie negativ auswirken kann.

skepsiS schrieb:
> Ich hoffe, irgendwo nach dem Gleichrichter versteckt sich noch ein
> ELKO...?!

Nein, ich habe keinen ELKO daran. Ist dieser zwingend notwendig?
Ich benutze standart LEDs mit GX5,3 Stecker. Die müssten intern auch 
noch einen gleichrichter haben.
Die Schaltung habe ich schon über mehrere Stunden am Stück laufen 
lassen. Im Dauerbetrieb und auch im Wechselbetrieb der LEDs. Es ist 
weder etwas zu warm geworden, noch ist (bisher) ein Defekt an den 
Leuchten aufgetreten.

Gruß Carsten

EDIT: Kann ich die MOSFETs mit der Kühlfläche auf die Platine löten, 
oder werden diese geschraubt?

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Born schrieb:
> Nein, ich habe keinen ELKO daran. Ist dieser zwingend notwendig?


Ja! Du bekommst ja sonst keine ordentliche Gleichspannung.

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Born schrieb:
> Kann ich die MOSFETs mit der Kühlfläche auf die Platine löten,
> oder werden diese geschraubt?

Das kannst du schon machen, nur erfordert es viel Wärme, bis das Gehäuse 
des FETs auf Temperatur ist...zuviel und er scheidet dahin.

Und bedenke: Die Fläche muss isoliert vom Rest sein - Ein Pin des 
Packages ist auf die Montagefläche geführt.

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist eine geglättete Gleichspannung für die LEDs oder die MOSFETs denn 
wichtig?
Wenn ja, welche Kapazität müsste ich einbauen?

Gruß Carsten

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Born schrieb:
> P8 ist +5V

Warte mal...Dann sind ja die 5V mit den 12V verbunden?

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daumenregel: 1000uF/A

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
skepsiS schrieb:
> Das kannst du schon machen, nur erfordert es viel Wärme, bis das Gehäuse
> des FETs auf Temperatur ist...zuviel und er scheidet dahin.
>
> Und bedenke: Die Fläche muss isoliert vom Rest sein - Ein Pin des
> Packages ist auf die Montagefläche geführt.

Ich werde es Versuchen.
Habe das liegende TO220 Gehäuse in EAGLE verwendet. Da reserviert der 
automatisch die Isolierte Fläche. Dann muss das nur mit dem Löten 
funktionieren. ;-)

skepsiS schrieb:
> Daumenregel: 1000uF/A

Hmmm, dann würde ich 6000µF benötigen. Das höchste was ich hier gerade 
gefunden habe ist ein 470µF Kondensator aus einem Computernetzteil.
Dachte der hätte eine größere Kapazität, weil der so groß (Baby 
Batterie) ist.

Gruß Carsten

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Born schrieb:
> Da reserviert der
> automatisch die Isolierte Fläche.

Ja nur irgednwo musst du das ja noch drauflöten - ich meine damit nur, 
nicht jetzt auf ne Massefläche oder so anklemmen mit der Montagefläche.

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja der ist bestimmt 350/400V oder so.

Mach ihn mal dran, geglättet ist schon sinnvoller.

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
skepsiS schrieb:
> Ja nur irgednwo musst du das ja noch drauflöten - ich meine damit nur,
> nicht jetzt auf ne Massefläche oder so anklemmen mit der Montagefläche.

Ich lass den komplett isoleirt vom rest. Mir ging es nur darum, dass die 
nicht in der Luft stehen. So hatte ich das vorher. Möchte die nur 
mechanisch Stabiler befestigen.

skepsiS schrieb:
> Mach ihn mal dran, geglättet ist schon sinnvoller.

Okay. Ich werde es mal testen.
Jetzt muss ich aber nocheinmal dumm fragen: Wie ist der Aufbau von 
diesen LEDs intern? Ich denke mal ein Gleichrichter muss eingebaut sein, 
da die Polung schließlich egal ist/sein muss.
Liefern die LED Trafos denn eine geglättete Gleichspannung oder nicht?
Einen normalen Halogentrafo darf man für die nicht benutzen, da dieser 
wohl 10k bis 100kHz Wechselstrom erzeugt (Digitaltrafos).

Gruß Carsten

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmal die Frage, sind deine 5V mit den 12V verbunden, oder ist das ein 
Zeichenfehler?

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
skepsiS schrieb:
> Nochmal die Frage, sind deine 5V mit den 12V verbunden, oder ist das ein
> Zeichenfehler?

Öhm, ich denke einmal da ist die Beschriftung ein wenig merkwürdig. Das, 
was Verbunden ist, soll von der Idee her GND entsprechen. :-) Habe eben 
einfach nur ein paar Werte daran geschrieben, damit man in etwa weiß, 
was an den Pins angeschlossen werden soll (der 230V->12V Trafo und die 3 
LEDs).

Gruß Carsten

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Carsten Born schrieb:
> P8 ist +5V und die anderen Ports
> verhalten sich wie GND

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, wie benenne ich das denn alles richtig?
In den Beispielschaltungen für meine Logik steht überall +5V dran. Die 
habe ich mit der einen Leitung (P8) verbunden.
Dann habe ich auch noch GND, welches ich in dem Falle aber nicht 
benutze.
Beitrag "FTDI FT232RL - Probleme mit Platine/Verbinden mit PC" <- Da steh fast alles zu 
der Logig. ;-)
Beitrag "Re: FTDI FT232RL - Probleme mit Platine/Verbinden mit PC" und hierbei notfalls 
noch die PDF zum Chip.
Der Rest müsste ja demnach aus dem Schaltplan hervorgehen. 12V+/- liegen 
hinter dem Brückengleichrichter an, der direkt an einem 12V Trafo 
angeschlossen ist.

Gruß Carsten

Autor: skepsiS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja aber dann hast du doch 5V mit 12V verbunden

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm... irgendwie schon. Was heißt das jetzt? Funktionieren tuts ja. :-)
Aber es klingt nicht richtig.

Gruß Carsten

Autor: Carsten Born (corvulus)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Netze nun (um-)benannt.
Dürfte man das so machen? An GND schließt man ja oft mehrere Spannungen 
an.

Bin seit einer Woche am rätseln, wie dieses Problem zu lösen ist.
Ich darf GND nun halt nicht auf Erde legen, da es ein anderes potential 
hat, aber ob das nun zulässig ist, oder ob es dadurch (immer) noch 
Fehler gibt, weiß ich nicht.
Lasse mich gerne korrigieren! :-)

Gruß Carsten

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Carsten Born (corvulus)

>Logikschaltung an dem Stecker (P8 ist +5V und die anderen Ports
>verhalten sich wie GND) angeschlossen ist.
>Wenn nicht, kann es passieren, dass die LEDs nach einer Weile leuchten.
>Ich denke das ist der Latch-Up Effekt, oder? Dies möchte ich nun mit den
>Widerständen unterbinden. Die LEDs haben etwas mehr als 2W.

Du sprichst wirr. Lies etwas über Netiquette und beschreibe deine 
Aufgabe, nicht deine vermeintliche Lösung.

>Lasse mich gerne korrigieren! :-)

Siehe oben.

MFg
Falk

Autor: Carsten Born (corvulus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
skepsiS schrieb:
> Ja aber dann hast du doch 5V mit 12V verbunden

Darum ging es. Dafür habe ich versucht eine Lösung zu finden und diesen 
Lösungsansatz bestmöglich zu beschreiben.

Carsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.