www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Verflixte Inverse Schreibweise.


Autor: Thomas O. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe ein kleines Problem mit Chipblaster. Irgendwie hab ich die
Resetleitung meines ATtiny26 deaktiviert. Letztes Kästchen. Nun habe
ich mal nen neuen reingemacht und die Fuses ausgelesen. Muss ich wenn
=1 dortsteht das Kästchen rechts im Bild mit einem Hacken versehen oder
ist es genau umgekehrt? Kann mich nicht mehr genau erinnern ob das bei
Chipblaster genau umgekehrt ist.

Den RSTDSBL=1 sollte doch heißen das die Resetleitung deaktiviert wird,
ich glaube aber das dort immer ein Häckchen drin war. Wäre dankbar für
eine schnelle Antwort da ich mein Prog draufspielen will ohne den AVR
gegen weiteres überschreiben zu sichern.

Autor: Christof Krüger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kenne zwar das Programm nicht, aber da steht bei den Kästchen Immer
[ ]FUSE=0
Also denke ich mal, wenn das Kästchen markiert ist, dass dann das
FUSE=0 gestellt wird, also das Fuse PROGRAMMED ist. Alles andere wäre
unlogisch... ich übernehme aber trotzdem keine Gewähr!

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

trotzdem Danke warte dann doch noch mal bis jemand antwortet der das
100% weiß. Am Anfang brachte mir das Programm mal eine Meldung die
ungefähr so lautete "wollen sie wirklich die Resetleitung
deaktivieren?" Aber bei dem einem Mal wos schiefging kam die Meldung
nicht.

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

na arbeitet keiner mit dem Programm? Ich kann zwar ganz normal flashen
wenn ich jetzt aber den internen Takt ändern will dann komme ich wieder
zu den Fuses.

Autor: emil (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
RSTDSBL=1 heisst "unprogrammiert", also eben bit.RSTDSBL=1;
wenn du den reset-pin "disablen" willst (aber das willst du bestimmt
nicht), DANN musst du ein häcken im kästchen beim "RSTDSBL=0" setzen,
dann hast du nach dem fuse-programming eben bit.RSTDSBL=0, also
"programmed", also kein reset mehr möglich; alle fuses bei atmel sind
eben mit 0 programmiert und mit 1 unprogrammiert.
ganz unlogisch, ich weiss, ich hatte auch meine fehlversuche damit...

Autor: Thomas O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ok danke Emil, wenn ichs probiert habe werde ich berichten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.