www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fragen zu einer Ladungspumpe


Autor: Sebastian Knödler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Ich hab mir zu Hause versucht mit ein paar einfachen Mitteln ne kleine
Ladungspumpe auf zu bauen (schreibt man das zusammen?). Die sollte
eigentlich die Spannung verdoppeln und dann invertieren.
Den Schaltplan hab ich einmal von Sprut und einen anderen Seite (keine
Ahnung mehr woher).
Mit dem ersten Schaltplan hab nur +1,5 Volt hinbekommen...ich denke
aber, dass es ein fehler im Schaltplan war.
Mit dem Plan von Sprut hab ich immerhin -3 Volt bekommen, aber die ist
beim Anschluss eines 47k Widerstands schon auf -0,8 Volt eingebrochen.
Kann das ganze daran liegen dass ich 1N4003 Dioden und nur 10µF
Kondensatoren verwende und was ist die optimale Frequenz dafür (reichen
die 20mA meines Mega8 überhaupt)?
Kann man die einzelnen Parameter der Ladungs Pumpe irgendwie
berechnen?

Wäre für jede hilfe dankbar!

MfG
Basti

Autor: Philipp Sªsse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aufzubauen schreibst man hoffentlich auch trotz Schreibreform zusammen.
(-: Und "Ladungs Pumpe" auch! (-;

Ich kenne Deine Schaltung nicht, noch nicht einmal die
Eingangsspannung, von der aus Du "hochpumpen" willst.

Aber rechne mal: 3 V über 47 k sind 64 µA; wenn Du vor der Pumpe nur
1,5 V hattest, brauchst Du da 128 µA plus Verluste -- das reicht auf
jeden Fall dick.

Wenn Du 10 µF über eine Zeit T mit 20 mA lädst, hast Du mit Q=CU eine
Spannung U=20mA * T/10µA; wenn Laden und Entladen gleich lang sein
sollen, muß Du mit rund 650 Hz pumpen, um 1,5 V zusammenzubekommen.

Hat denn die Ladungspumpe eine Regelung?

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit "Schaltplan von Sprut" und "Schaltplan von einer anderen Seite",
kann keiner was anfangen.

Du kannst ruhig davon ausgehen, daß Dir keiner in den Kopf schauen
kann.

Das mindeste ist also bei Schaltungsfragen den Schaltplan dazu bzw.
einen Link darauf.


Peter

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist es nicht unglücklich das DIng aus nem ATmega Port zu versorgen?

Autor: Sebastian Knödler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Peter Dannegger: Also hier der Link von Sprut:
http://www.sprut.de/electronic/switch/minus.html

Bei der anderen Site ist die Diode D1 in die andere Richtung gepolt
(was ja eigentlich falsch ist).

Ich wollte die Ladungspumpe erstmal zum test an den AVR anschließen.
Ich hab's jetzt auch mal mit nem PNP Leistungstransistor probiert (BD
244B), was aber nicht ganz funktioniert (Basis über 4,7k an
schaltquelle, Collector an +5V und an den Emitter die Last). Was den
Transistor angeht: Ich hatte nur den zur Hand.
Ich denke mit nem Kleinsignal NPN geht's besser (a la BC 547C o.ä.).

Wäre nett wenn ihr mir weiterhelfen könnt!

MfG
Basti

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.