www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bascom Programmer funzt nur "gelegentlich"?


Autor: Rene (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallöchen! Ich hab folgendes problem:
Hab schon mehrere µC Schaltungen gebaut und Programmiert. Jedoch tritt
immer wieder auf, daß Bascom meldet: "...identify chip with
id:FFFFFF"
Das lustige ist: Manchmal hilft es in den bascom einstellungen zu
spielen (Programmer von SP12 auf FUTURELEC und zurück). Und dann läuft
es den halben Tag wunderbar, bis ich bascom beende. Irgendwie tritt es
zufällig auf. Könnte es an XP liegen, daß es den LPT1 irgendwie komisch
verwaltet und bascom dann keinen zugriff hat?
Am LPT ausgang tut sich dann übrigens auch nix, hab ich gemessen
(Oszi).

Meine Systemkonfiguration:
WinXP
Programmer von www.rowalt.de an 1m Kabel.
Zur Zeit zu Programmieren: Ein ATMEGA8 auf komplett aufgebauter
Platine. (Habe ich darauf auch schon mehrmals programmiert, bis das
Problem wieder auftrat.)

Habe die Suchen funktion des Forums genutzt bin aber auf keinen
gilfreichen Beitrag gestoßen, weil es ja normalerweise gut
funktioniert.

Autor: Rufus T. Firefly (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wird eher am "Rowalt"-Programmer denn an Bascom oder XP liegen.
Der SP12-"Programmer" besteht ja nur aus einigen Widerständen, und
wenn da noch 1 m Kabel dazwischenhängt ...
(ich nehme jedenfalls an, daß Du
http://www.rowalt.de/mc/avr/twinavrh.png meinst).

Andererseits lässt der Druckerport, an dem sich nichts tut, auch nichts
gutes vermuten; vielleicht aber ist das auch normal, weil möglicherweise
vor dem Entwickeln von Aktivität erstmal der Status einiger Eingangspins
geprüft wird? Wer weiß.

Wie dem auch sei, die besser funktionierenden Parallelportprogrammer
verwenden noch ein Treiber-IC ('244); in der Online-Hilfe von Bascom
ist ein entsprechender Schaltplan abgedruckt.
Sogar Rowalt bietet etwas vermutlich vergleichbares an
(http://www.rowalt.de/mc/avr/dongle.png).

Damit habe ich noch nie Probleme gehabt, ist wie ein (alter) Käfer ...

Autor: Rene (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja genau den Programmer mein ich...

Ok, dann werd ich morgen ma den anderen bauen und schauen wies dann
läuft.
Danke schon ma für die Hilfe!

Autor: Messfux (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sind die PIN`s des ISP mit einer Beschaltung belegt? Dadurch können die
Pegel nicht erreicht werden, z.B Dauerpulldown.

Gruß

Messfux

Autor: Rene (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm das wäre aber keine Erklärung dafür, daß es manchmal ohne probleme
läuft.

Habe jetzt mal die Adresse vom LPT geändert und seitdem funzt es
wunderbar...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.