www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Stereokamera CY7C68013A + 2 mal MT9D131


Autor: Florian S. (smartcam)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich arbeite zur Zeit an einem Konzept um eine Stereo-USB-Kamera zu 
Entwickeln.

Als Bildsensoren habe ich mir die MT9D131 von Aptina/Micron 
herausgesucht.
Es sollen lediglich die Kamerabilder an den PC gesendet werden. Es 
findet also keine Verarbeitung der Kameradaten auf dem System statt.

Um die Bildsensoren auszulesen möchte ich gerne den CY7C68013A 
verwenden.
Dieser hat ein 16 Bit Interface, das ich verwende um die 2 x 8 
Datenleitungen der Bildsensoren anzubinden.

Meine größte Frage ist jedoch wie ich die Leitungen Line_valid, 
Frame_Valid, PixCLK und EXTCLK anschließe.

Das Problem vor dem ich stehe ist, dass ich nicht weiß, ob die Sensoren 
synchron laufen oder nicht, bzw. wie ich sie Synchronisieren kann.

Ich habe einen Schaltplan in den Anhang gehängt. (Leider muss ich die 
Chips außerhalb der Spezifikation betreiben, da ich keinen Pegelwandler 
verwenden möchte -> Bildsensor max 3,1V, Cy7C680 min 2,8V -> 3,1V)

Ich würde mich sehr über eure Unterstützung freuen, da ich selber erst 
ab nächstem Semester mit meinem E-Technik Studium anfange und daher 
leider noch einige Wissenslücken habe.

Vielen Dank im Voraus!

Autor: Florian S. (smartcam)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe noch kurz die Datenblätter hochgeladen. Vlt kann jemand mehr 
aus den Datenblättern herauslesen, als ich :)

Vielen Dank!

Autor: Florian S. (smartcam)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eben noch eine Skizze gefunden. Bei dieser Skizze wurde ein 
Sensor von Omnivision verwendet, aber ich glaube das Image Sensor 
Interface ist sehr ähnlich.

Mein Problem ist nun das folgende:
Der Bildsensor erzeugt selbstständig die Signale VSYNC und HREF bzw. 
Line_Valid Frame_Valid.

Solange man nur einen Bildsensor verwendet kann man auf diese Art das 
FIFO mit Daten füttern. Aber ich habe leider 2 Sensoren und ich 
befürchte, dass die beiden Sensoren die entsprechenden Signale nicht 
gleichzeitig ausgeben.

Hat jemand eine Idee, wie man dieses Problem lösen könnte? Bzw. hat 
eventuell schon einmal jemand mit den Sensoren von Aptina gearbeitet?

Ciao

FLO

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.