www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik DAC Referenz spinnt


Autor: Ruslan K. (idrisk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Problem:

Ich habe mir einen DAC AD5344 besorgt, der auch sehr gut 
funktioniert(e).

Ich betreibe den DAC mit 5v Versorgung. Da die Referenzspannung je nach 
anschloßenem System 3,3 oder 5 ist, habe ich den Referenzeingang des 
Dacs rausgeführt. Wenn ich den DAC mit 3,3 Volt Referenz betreibe habe 
ich keine Probleme. Aber wenn ich die die Referenz auf 5 V stelle, tritt 
folgendes auf. Schaltet man die Referenzspannung ab und an z.b. passiert 
es wenn ein steuergerät sich resetet saugt aufeinmal der DAC über den 
Referenz super viel strom. Dank strombegrenzung im Netzteil geht er 
dabei gottseidank nicht kaputt.

Zustand.
DAc wird immer versorgt und läuft vorsich hin. Aber die Referenzspg. 
kann ausgeschaltet werden, z.b. steuergerät wird ausgemacht. Nicht 
immer, aber leider auch nicht reproduzierbar zieht der DAC durch die 
Referenz zu viel Strom.

Kann mir einer vieleicht helfen?

Gruß

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hört sich nach Latch-Up an...

> Ich betreibe den DAC mit 5v Versorgung.
Wie genau sind diese 5V?
> wenn ich die die Referenz auf 5 V stelle
Wie genau sind diese 5V?

Die Spannung am Referenzeingang darf niemals (auch nicht 100mV) größer 
sein als Vdd. Bereits bei Verf=Vdd-100mV steigt der Eingangsstrom laut 
DB schon an...

Autor: Ruslan K. (idrisk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
>> Ich betreibe den DAC mit 5v Versorgung.
>
> Wie genau sind diese 5V Versorgung?
> Kommt aus einem Spannungregler, schon sehr genau
>
> Wie genau sind diese 5V?
  Das selbe, nur das der Spannungregler sich auf dem Steuergeät 
befindet!

habe aber zum probieren mal die Referenz aus einem Tölner Netzteil 
geholt, auf dem Oszi sieht es sehr genau aus.
Habe auch zwischen Referenz und Masse einen Puldown von 10k und schon 
zwei kondensatoren eingelötet. 100 nF und 1uF, über vermeintliche 
Überschwinger zu unterbinden.

Ich mache es Testweise so, dass der DAC läuft und ich während dessen die 
Refenz aus dem Netzteil rausziehe und reinstecke und das schlatet zu 
simulieren. Bis 4,5 V läuft es auch, aber ab ca. 4,8 fangen die 
beschrieben Probleme auf.

Kann ich den Referenz eingang irgendwie anderes schützen?

Autor: Georg A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Kann ich den Referenzeingang irgendwie anderes schützen?

Es soll Widerstände geben...

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ruslan K. schrieb:
> abe aber zum probieren mal die Referenz aus einem Tölner Netzteil
> geholt, auf dem Oszi sieht es sehr genau aus.

Es soll Digitalmultimeter geben...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.