www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Temperatur des 90S4433


Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe mal gestern meine Schaltung für den AT90S4433 ausprobiert, die ich 
nach dem Schaltplan dieser Seite aufgebaut habe. Hab noch paar LEDs und 
so rein, um z.B. zu sehn ob das Board an ist und ob programmiert wird 
etc.
Es funktioniert auch alles, und die LEDs leuchten richtig (ob der 
Controller wirklich funktioniert kann ich nicht sagen, weil ich noch 
keinen ISP-Adapter habe), aber die Temperatur des Atmel steigt sehr 
schnell sehr hoch, so dass man ihn nach kurzer Zeit nicht mehr anfassen 
kann.
Ist das normal?

Danke

Gruss
   Benjamin

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, das ist NICHT normal. Hast du Widerstände vor die LEDs geschaltet? 
Ist die Spannung unterhalb von 6V?

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab die LED mit der gleichen Spannung verbunden wie den µc und nen 
1k davor geschaltet. Leider is sie abgefackelt ;). Die Spannung die ich 
für den MC benutze liegt konstant auf 5 V.

Könnte es daran liegen, dass der MC kaputt ist? Ist mir mal aufn Boden 
gefallen. Hab hier noch einen liegen aber kein Bock den zu testen, bevor 
mir der auch noch futsch geht.

Benjamin

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Benjamin,

wenn ein solcher Prozessor/Mikrocontroller so heiß wird, ist er sehr 
wahrscheinlich defekt, und reif für den Mülleimer!

Hast du die Schaltung richtig aufgebaut?


Gruß Matthias

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich glaube ich habe den Fehler gefunden. Ich habe den Pin 1 des Atmel 
mit Pin 3 der Stift-Leiste verbunden. Auf dem Schaltplan ist bei dem 
"Übergang" der beiden Leitungen ein Kreis. Bedeutet das, dass man die 2 
Leitungen verbinden muss oder nicht?

Benjamin

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ansonsten ist alles richtig aufgebaut

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der kreis heißt nur, dass der pin 1 negiert angesprochen wird. es 
handelt sich um den RESET pin. wenn High ist, ist kein reset, deshalb 
der kreis...

der fehler liegt wahrscheinlich woanders. miss nochmal alles sorgfältig 
durch!

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heisst das nun, dass die Leitungen verbunden werden oder nicht? Bei mir 
sind die beiden Leitungen verbunden. Bei mir sieht es so aus :

+ Pol
|
| Widerstand        Pin 1 des Atmel
|          |
-------------------------------------------------------
|            |
| Kondensator          Pin 3 der Stiftleiste
|
- Pol

| und - sollen die Leiterbahnen darstellen.

Ist es so richtig oder so? :

+ Pol      - Pol
|      |
| Widerstand    | Kondensator
|      |
 Pin 1 des Atmel                  Pin 3 der Stiftleiste


Falls aus den "Zeichnungen" nichts zu erkennen ist kann ich auch nen 
Bild machen.

Gruss
 Benjamin

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
komm mit den zeignungen nicht ganz klar. du musst verbinden.

der pin1 geht an einen kondensator und dieser dann nach masse. über 
einen widerstand wird pin 1 noch auf vcc gezogen. zusätzlich ist pin1 
mit pin3 der stiftleiste verbunden.

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay. Dann hab ich alles richtig (<ftp://wots.dyndns.info/> Stimmt das 
Bild?). Wenn ich die Spannung von Pin 1 des Atmel gegen GND messe müsste 
ich doch die Versorgungsspannung (also 5 V) haben wenn er nicht 
programmiert wird oder?

Mir fällt übrigens grad auf dass der Spannungswandler auch schnell 
relativ heiss wird obwohl ich ihn mit 7.5 V betreibe. Bei einem anderen 
Gerät wo ich den gleichen habe wird er nicht so heiss obwohl ich 12 V 
anliegen hab.
Könnte das etwas damit zu tun haben?

Benjamin

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe den Fehler gefunden. VCC war ausversehen mit Pin 28 (PC5) des MC 
verbunden. Dadurch kam die hohe Temperatur.

Danke für eure Tips

Gruss
 Benjamin

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh.. dann haste den port evtl. gegrillt... klappts denn nun mitm 
programmieren?

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab den Programmer net. Bring den 25 Sub-D Buchse nich auf nen 
Steckbrett.

Benjamin

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein AVR ist hin, da bin ich mir sicher.

Autor: Benjamin Hepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo, ich glaub auch. Aber ich hab ja noch nen dritten ^^. Und im Notfall 
bleibt mir noch mein vierter.

Benjamin

Autor: H.Howey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab ein Steckbrett bei dem eine Metallplatte darunter ist, wo auch 
zwei Klemmen für die Versorgungsspannung sind. Daneben hab ich zwei 
Löcher gebohrt und eine 9 Sub-D Buchse (90 Grad) für die Serielle 
Montiert. Für die 25 Sub-D Buchse hab ich ein Druckerverlängerungskabel 
genommen, wobei ich eine Seite abgelötet habe. Die Zugentlastung, von 
dem abmontierten Stecker, ist mit einem Kabelbinder, der durch zwei 
weitere Löcher gezogen wird, fest direkt neben dem Steckbrett dran.
Gruß
H.Howey

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.