www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Flip 2.4.0


Autor: Zelfir Hot (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich habe mir ein Entwicklungbord mit AT89C51RD2 und dem Max 202
mit dem entsprefchendem Schaltpaln gekauft. Nun benutze ich den Flip
2.4.0. Das Problem ist, dass ich keine Verbindung zu dem Bord bekomme
obwohl ich meine, dass ich alles richt auf einem Experimentierbord
angeschlossen habe. Am Anfang habe ich die Kondensatoren an den Max 202

fälschlicherweise falschrum eingebaut. Jetzt weiss ich nicht ob der Max
202 dadurch kaputt geganen ist.
Was soll ich jetzt machen??

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

am MAX202 kommen normalerweise doch 100nF, keramisch. Die kannst du
nicht verpolen. Am Max232 hatte ich auch mal die Elko`s verpolt. Der
Max und die Elko`s haben es aber überlebt. Eventuell TXD und RXD
vertauscht?

Mfg Sascha

Autor: Andreas W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
poste doch mal den Schaltplan.
Um den MC zu programmieren, musst du noch den Bootloader aktivieren.
Dazu muss der PSEN-Pin auf Masse gezogen und ein Reset ausgelöst
werden. (Steht auch im Datenblatt.)

Gruß
Andreas

Autor: Matthias Friedrich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist die Baudrate richtig eingestellt? Der Atmel kann in Abhängigkeit des
Quarzes nicht alle Baudraten richtig erkennen und verarbeiten.

Autor: Zelfir Hot (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Sascher:
Auf dem Schaltplan den ich von Microcontroller.net gezogen habe steh
dass man 1µ condensatoren verwenden muss.
Die TxD und RxD habe ich auch schon nachgeschaut es stimmer meiner
Ansicht alles. Übrigens haben mein freund und ich das
schon mal bei ihm ausprobiert und es "ging" ja mit den selben
Bauteilen, jetzt hatte ich ja den Max202 auf einen
Experimentierboard aufgebaut und alle Pins um eins verückt ( der 8 an
7, der 7 an 6, usw.) da kann was schief gegangen sein.

@Andreas:
ja ganau den PSEN-Pin habe ich auf Masse gezogen und den Reeset vor dem
programieren ausgelöst. Genaus so wie es auch
im Datemnlatt steht. Den Schaltplan lade ich jetzt auch hoch.

@ Matthias:
Die Baundrate habe ich auf 9600 und dann alle duch ausprobiert, das hat
leider nichts gehollfen. der Quar taktet mit 12 MHz.

nochmal dankeschön. wenn euch noch was einfällt dann schreibt das und
wenn ich es geschaft habe dann melde ich mich.

Autor: Andreas W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Benutzt du auch das selbe serielle Kabel (muss gekreuzt sein) ?

Autor: Zelfir Hot (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne das nicht ich habe mir ein von Reichelt bestellt. Es ist ein D Sub
Kabel und ich habe schon probiert die Anschlüsse zu vertauschen. Aber
das ist ne gute Idee ich werd mal das Kabel von meinem Freund mal
ausprobieren. Danke
Zelfir

Autor: Zelfir (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus,
Das Problem hat mein Freund gelöst. Ich hatte den Schaltplan auf einem
Experimentierboard aufgabaut, und hatte die zwei Condensatoren am Quarz
einfach kurzgeschlossen. Der Maxx so wie alle andere Bauteile haben mein
Missgeschick überlebt und es funtioniert alles.
Nochmal danke an alle.
Zelfir

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.