www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR DRAGON defekt?


Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebe Board-Gemeinde,

gestern hat mein Dragon seine Dienste bei mir quittiert. Ich hatte mich 
nun endlich mal dazu entschlossen, die fehlenden Pinleisten und einen 
DIP40-Sockel nachzulöten, um ein paar verfuste AVR zu retten. Habe 
danach nach Plan verdrahtet und nen ATMEGA32 in den Sockel gesteckt. 
HV-PROG über AVR-Studio hat nicht funktioniert. Nun funktioniert leider 
auch nichts anderes mehr. Weder JTAG noch ISP. Der Dragon findet einfach 
keine AVR-Hardware mehr. Mit einem AVRISP MKII anstelle des Dragon 
funktioniert alles einwandfrei.

Die USB-Seite funktionioert noch super. Ich kann sogar noch upgraden. 
Aber irgend Etwas auf der Platine scheint gestorben zu sein. Ich weiß 
nur nicht was.


Kann mir jemand helfen?

Gruß Olli

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liegt denn die Target-Spannung noch an?

Hast du vielleicht irgendwo eine Zinnbrücke gebastelt?

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wärs mit Fotos mit zahlreichen Details? Sonst kann man hier nur 
rumraten.. Schlurzkuss, ESD, Beschaltungsfehler, Sonnenwinde, ..

HTH

Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Hast du vielleicht irgendwo eine Zinnbrücke gebastelt?

Zinnbrücken sind so weit ich das beurteilen kann keine vorhanden.

> Liegt denn die Target-Spannung noch an?

Wenn ein Target angeschlossen ist, dann kann ich mir die Targetspannung 
nicht anzeigen lassen. Da zeigt AVR-Studio blos "Setting device 
parameters.." an und tut garnichts mehr. Hab ich aber nix dranhängen, 
dann zeigt er mit 5V an. Ist das normal?


Außerdem Powert der Dragon immer das Target. Jetzt leuchten nämlich LEDs 
und die Hintergrundbeleuchtung meines LCD, habe aber keine 
Versorgungsspannung angeschlossen. Habe das nich so in Erinnerung oder 
täusche ich mich da jetzt?

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli schrieb:
> Außerdem Powert der Dragon immer das Target.

Wenn du von Vtarget eine Leitung ziehst, dann ist das normal.  Dafür
gibt's ja eigens 3 Pins neben den 3 Massepins in einem 6-poligen
Header.

Lass mal ein

avrdude -p <youravrname> -c dragon_isp -P usb -vvvv

laufen und schau an, was die letzten Kommandos und deren Ergebnis
waren.  Kannst du mit

avrdude -p <youravrname> -c dragon_isp -P usb -vvvv 2> log.txt

auch in eine Datei umlenken und diese ggf. hier als Anhang posten.

Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörg Wunsch schrieb:
> Wenn du von Vtarget eine Leitung ziehst, dann ist das normal.  Dafür
> gibt's ja eigens 3 Pins neben den 3 Massepins in einem 6-poligen
> Header.

Ich habe keine Leitung gezogen. Der 6-Pin-Header wird nicht benutzt.


> Lass mal ein
>
> avrdude -p <youravrname> -c dragon_isp -P usb -vvvv
>
> laufen und schau an, was die letzten Kommandos und deren Ergebnis
> waren.  Kannst du mit
>
> avrdude -p <youravrname> -c dragon_isp -P usb -vvvv 2> log.txt
>
> auch in eine Datei umlenken und diese ggf. hier als Anhang posten.

avrdude werde ich gleich mal anwerfen. Muss dazu noch den Treiber 
installieren. Das dauert unter Windows 7 X64 ein wenig. Melde mich dann 
wieder.

Danke für deine Hilfe Jörg.

Autor: Olli (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ist der log vom avrdude.

Autor: Olli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab vorhin mit dem Distributor telefoniert und werde einen neuen 
bekommen.

Danke an Jörg für seine Bemühungen.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Olli schrieb:
> Hier ist der log vom avrdude.

Das "set parameter", das er versucht ist, den ISP-Modus zu aktivieren.
Das klappt nicht.  Vermutlich einer der Treiber kaputt oder sowas.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.