www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Tachosignal von Kühlern


Autor: MC_AVR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alle,

ich beschäftige mich gerade mit 4-Wire Kühlern (Tachosignal + PWM) und 
habe das Tachosignal etwas genauer untersucht.

Ich habe das Tachosignal einmal direkt mit meinem Multimeter 
(Frequenzzähler und RPM Anzeige integriert) gemessen und hatte bei 15V 
eine Drehzahl von 36000 U/min, was ja nicht sein kann. Um halbwegs an 
das richtige Ergebnis zu kommen, habe ich an dem Umfang des Rotors einen 
kleinen Magneten angebracht und an dem Gehäuse des Kühlers ein 
Hallsensor und habe einmal die Impulse des Hallsensors gemessen und kam 
da auf c.a. 3300 U/min, was ja realistischer klingt.

Das Tachosignal gibt ja 2 Impulse pro Umdrehung oder täusche ich mich da 
? Wie muss ich das denn auswerten ? Irgendwie scheint mir zwischen 
Tachosignal und Hallsensormethode immer ein Unterschied von Faktor 10 zu 
sein.

Bin für jeden Tipp dankbar !

MfG,
MC_AVR

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MC_AVR schrieb:
> Das Tachosignal gibt ja 2 Impulse pro Umdrehung

2 und 4 sind üblich. Du hast sicher den PullUp Widerstand gegen +5V 
vorgesehen bei der Messung mit dem Multimeter...

Autor: MC_AVR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ups...

Also ein Pullupwiderstand von 10kOhm zwischen 5V und Tachosignal ?

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genauer Wert ist unkritisch, mit 10 kOhm sollte passen.

Autor: MC_AVR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
5V ? Du meinst gegen die Versorgungsspannung also VCC des Kühler's oder 
?

Autor: MC_AVR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok habe nun mit 10kOhm die Messung nochmal durchgeführt.

Ich bekomme eine Signalfrequenz von f= 160 Hz. Mit zwei Impulsen pro 
Umdrehung wäre das ja eine Drehzahl von  n = ( 60Hz*f ) / 2 = 4800 U/min 
(ungefähr eben). Da ist aber immer noch eine Abweichung zu der Drehzahl 
die mit dem Hallsensor ermittelt wurde (3600).  Der Hallsensor ist mit 
Kondensatoren und Pullupwiderständen ausgerüstet.

Warum ist so eine erhebliche Abweichung vorhanden ? Was wären die 
üblichen Probleme ?  Pullup Widerstand zu ungenau ?

Danke.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MC_AVR schrieb:
> 5V ?

Ja, 5V. Nicht die Betriebsspannung des Lüfters. Das wird so in den 
Datenblättern angegeben, ohne sich über die Spannungsfestigkeit des 
Ausgangs auszulassen.

Die Abweichung ist aus der Ferne schlecht nachzuvollziehen.

Autor: MC_AVR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend nochmal,

ich habe diesmal eine andere Spannungsquelle genommen, die im Leerlauf 
12.26V liefert. Ich habe sowohl 5V als auch Betriebsspannung des Kühlers 
für den Pull-UP benutzt und bei beiden Spannungen kommen identische 
Tacho-Signale (Frequenzen). Die Abweichung mit der Hall-Sensor Methode 
ist jetzt nur noch minimal im Vergleich zu den vorherigen Werten. Meine 
erste Spannungsquelle war ein kleiner Trafo (Fleischmann-Trafo für die 
Modellzüge). Der Kühler lief dort aber mit einer kleinen Überspannung 
(15-16V). Es muss wohl an der Spannungsquelle gewesen sein; vor allem 
muss gesagt werden, das die Spannung beim Trafo immer sehr stark 
schwankte...

Danke nochmals.

MfG,
MC_AVR

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.