www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Schaltnetzteil Selbstgebaut - Praktische Theorie


Autor: DerAlbi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe mir ein Schaltnetzteil selbst gebaut. Es ist zum Laden vn 
großen Kondensatoren da. Dabei werden aus einem Li-Akku mit 15V bis zu 
350V erreicht.

Realisierung:
4 PC-Schaltnetzteiltrafos parallel (jeweils 2 Stück an einer Vollbrücke) 
und jeweils 2 Primärseiten in Reihe, damit die hohe Spannung erreicht 
wird. Jeder der Reihenschaltungen wird separat gleichgerichtet und dann 
wieder parallel geschlossen.

Da es ein Kondensatorladegerät ist, läuft das Teil ja quasi immer im 
Kurzschlussbetrieb. Bei leerem Kondensator fließen bis zu 4A in den 
Kondensator und rund 90A aus dem Akku. Wobei der Kondensator ratzfatz 
auf 200V aufgeladen ist. Dann wirds langsam. Die Spannung steigt nur 
noch mäßig an. Grund ist natürlich der geringere Stromfluss da nicht 
mehr alle Spannung direkt in den Kondensator fließt sondern nur noch die 
oberen spitzen. -> Weniger Energie. (wobei die Spitzen ohne 
Kondensatoren prinzipiell das Potential haben auf 450V zu kommen - das 
nix passiert übernimmt eine Herde von Schutzschaltung und natürlich eine 
Spannungsüberwachung, die bei einer variablen Sollspannung die 
Vollbrücken aus macht)

Die Vollbrücken, die die Trafos versoren speißen jeweils ihr Rechteck 
über 5x2.2uF (~10uF also) in die Trafos.
Nun hat diese Anordnung (C-L in Reihe) eine Resonanzfrequenz -> die darf 
ich nie und nimmer treffen, da sonst.. naja es fließen halt nicht mehr 
nur 90A aus dem akku ;-)

Mir geht es jetzt da drum, zu verstehen was in dem Netzteil konkret 
passiert. Ziel ist es die Leistungsausbeute bei jeder Ausgangsspannung 
so optimal wie möglich zu machen.

Ich habe bisher ein wenig rumprobiert und an der Frequenz gedreht:
-> Normal sind bei mir jetzt 60KHz eingestellt -> 3.3kJ werden in 12.5 
Sekunden geleifert.
->Verringere ich die Frequenz z.B. auf 20kHz, dauert es wesentlich 
länger bis die Kondis geladen sind. ABER: die Stromausbeute bei höheren 
Spannungen ist fast doppelt so groß. Dafür ist am Anfang der leere 
Kondensator nur sehr schwer zu füllen. Insgesamt dauert es länger.
-> Höhere Frequenzen hab ich nicht lange genug probiert, um was darüber 
aussagen zu können, bei rund 100kHz wurden mir die Mosfets zu warm. Der 
eine Ladevorgang den ich durchgeführt habe dauert aber nicht wesentlich 
kürzer als mit 60KHz, jedoch wurden die Kerne der Schalttrfos merklich 
warm.


Um was es geht:
Die Frequenz scheint ja einen Merklichen Einfluss zu haben,wenn es darum 
geht, den StromOutput in Abhängigkeit von der Ausgangsspannung zu 
optimieren.

--> Als allererstes suche ich eine Erklärung dafür, dass bei hohen 
Spannungen tiefe Frequenzen besser sind. Wobei sie doch schon bei 
niedrigen Spannungen nicht genug Energie übertragen können (ist ja klar, 
die 10uF entladen sich in die Spule und dann is die energie weg bis zur 
nächsten Flanke - aber warum funktionierts bei hohen Ausgangsspannungen 
dann besser??)

Eine Möglichkeit ist, dass sich der Komplexe Widerstand der Cs und Ls so 
verändern, dass die Spannung über die Ls sehr hoch wird und damit die 
Energie der Spitzen wesentlich höher wird. Ist das so?

Ich wäre über fachliche Diskussion erfreut.. Sicherheitshinweise.. naja 
irgendjemand wird sich eh dazu berufen fühlen mich zu retten. 
prinzipiell störts aber. Danke.

MFG
Albi

: Verschoben durch Admin
Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Als allererstes suche ich eine Erklärung dafür, dass bei hohen
> Spannungen tiefe Frequenzen besser sind

Das hängt vermutlich mit der Steuinduktivität in deinem Übertrager 
zusammen. Wenn Du an die Trafo-Primärseite eine rechteckförmige Spannung 
anlegst, ist der Strom nicht rechteckig, sondern hat eher eine 
Trapezform. Dadurch fällt direkt nach der Schaltflanke zuerst mal die 
ganze Spannug an der Struinduktivität ab und erst nach einer gewissen 
Verzögerungszeit kommt sekundär eine Spannung raus.

Wenn Du einfach nur die Schaltfrequenz größer machst, bleibt diese 
"Verzögerungszeit" konstant, so dass die Zeit, an der Sekundärseitig 
eine Spannung anliegt, kleiner wird. Du solltest also auch den 
Übertrager anderst bewickeln für die höhere Frequenz.

Um das besser zu verstehen, könntest Du mal versuchen, so eine Schaltung 
zu simulieren (z.B. in LTSpice), da sieht man diese Effekte sehr schön 
und man kann auch einfach mit verschiedenen Parametern spielen.

Autor: Frank Schlank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DerAlbi schrieb:
> prinzipiell störts aber

LOL! Sehe ich auf jedenfall jedesmal genauso! Wenn einer fragt, dann hat 
er Interesse an der Sache und wird es eh versuchen - ob mit Hilfe, oder 
halt nicht. Und die Hilfe kann dann ja nur alles sicherer machen :-)

Autor: DerAlbi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Johannes, erklärt denn deine Theorie, dass tiefe Frequenzen weniger 
effizient sind, wenn die Spannung am Kondensator noch tief sind?
Die Übertrager sind wie gesagt aus vielen Schaltnetzteilen 
zusammengesucht. Ich kann nur wählen welche wicklung ich ansteuere.
Was simulation der schaltung angeht: kompliziert. Zu viele Parameter 
sind mir unbekannt. Ich kenne die Induktivität des Trafos nicht und auch 
sein Koppelfaktor und Frequenzverhalten sind unbekannt.
Ich kann auch mal rale Spnnungs und Stromkennlinen oszillografieren und 
mal guggn was da passiert. vielleicht ist das erstmal besser :-)

Autor: Johannes (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Johannes, erklärt denn deine Theorie, dass tiefe Frequenzen weniger
> effizient sind, wenn die Spannung am Kondensator noch tief sind?

Das ist jetzt nicht so einfach zu beantworten, ohne die Daten zu den 
Übertragern oder einen Schaltplan zu haben.

Vielleicht ist der 10µF-Kondensator zu klein, vielleicht geht der Trafo 
in die Sättigung, ...

Die Induktivität des Übertragers könntest Du zumindest grob bestimmen, 
indem du die Sekundärsteite öffen lässt und primärseitig mit deiner 
Vollbrücke eine Recheckspannung drauf gibst. Dann mit dem Oszi Strom und 
Spannung aufzeichnen, die Induktivität kann man berechnen: L = U / 
(di/dt).

> Was simulation der schaltung angeht: kompliziert

Das ist gar nicht so schlimm, wenn man sich mal etwas damit beschäftigt 
hat. Du musst ja auch nicht das komplette Gerät auf einmal simulieren, 
die Kunst ist, die Schaltung so weit zu reduzieren, dass man genau den 
Effekt beobachten kann, der einen interessiert.

Ich hab das mal für Dich gemacht (s. Screenshot), ich denke, das müsste 
ungefähr Deiner Schaltung entsprechen (abgesehen von den 
Bauteilwerten...).

Das ist wirklich ganz einfach und man kann so irgendwelche Theorien 
schnell mal nachprüfen, ohne große Hardware-Änderungen zu machen.

Autor: DerAlbi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke erstmal, ich hätte vielleicht sagen sollen, dass ich durchaus mit 
LTSpice umgehen kann und mir diese schalung auch schon angesehen habe. 
Ich hab nur nie das, was wirklich rauskommt irgendwie mal simulieren 
können. Das ist halt parameterfummelei. Rätselraten.

Ich werde mal messungen durchführen. Bis Montag bin ich leider nicht da, 
da kann ich ja mal Oszibilder reinstellen, falles es interessiert.

Was mich auch interessiert: ist es nicht eventuell sogar sinnvol ein 
wenig an die Resonanz ranzugehen, wenn die Spannung hoch wird? 
Hintergedanke ist, dass durch Resonanzfrequenz ja immenser Strom fließt. 
Immenser Strom bei endlichen Wechselstromwiderstand bedeutet hohe 
Spannung an der Spule. Wenn man es nicht übertreibt, sollte das doch die 
Energie der Spitzen nach dem Übertrager um ein einiges erhöhen.
Aber rumspielen in der nähe der Resonanzfrequenz ist sooo furchtbar 
gefährlich für die schaltung :-(

Andererseits werden meine Kondensatoren in 11-13 Sekunden Gelanden. Wenn 
man daran denkt, dass es 4 450W-Übertrager sind, von denen ich jeweil 
nur 1 von 6 Sekundärspulen ansteuere, dann ist die Leistungsausbeute 
(3.3KJ in 12Sek = 270W) ja gar nicht sooo schlecht eigentlich. Aber 
optimieren macht Spaß.

MFG

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> PC-Schaltnetzteiltrafos

sind für das Vorhaben vollkommen ungeeignet.

Man verwendet zum Laden von Kondensatoren keinen Flusswandler, sondern 
das Flyback-Prinzip, weil sich bei dem die stark ändernde sekundäre 
Spannung dabei nur in einem auswirkt: Bei niedrigeren Spannungen dauert 
das Entladen der Spule länger, also ist die Frequenz tiefer. Kennt jeder 
vom alten "Elektronenblitz" der Kamera.

Da du nur 350V erreichen willst (was zur ehemaligen Primärspannung 
passt), und mit 15V ausreichend hoch liegst für die ehemalige 
Sekundärspannung des 5V Kreises, funktioniert zwar der Trafo auch, aber 
der Flusswandler bringt eigentlich viele Probleme: Er produziert ja eine 
(hohe) Rechteckspannung am Ausgang, und wenn du dort überlastest, 
fliesst auch primär viel (zu viel) Strom. Du musst also sekundär die 
erzeugte Spannung an die vorhandene Spannung des Kondensators anpassen 
was auch das PC-Schaltnetzteil mit der nachfolgenden Buck-Drosselspule 
getan hat, und dann musst du noch regeln damit nicht zu viel Strom 
fliesst.
Regelst du nicht, sondern fährst du in den Sättigungsbereich von Spulen 
und Transistoren, verballserst du viel Leistung und die Teile rauchen ab 
(bzw. können nur zu einem Bruchteil genutzt werden, wie bei dir, wo wohl 
Trafos für 2000 Watt nur 250W liefern).

Im Prinzip ist dein PC-Schaltnetzteiltrafo so ausgelegt, daß seine 
Induktivität zur Schaltfreqeunz vernachlässigbar ist. Bei den angelegten 
350V soll sich die transformierte Spannung quasi sofort ändern, und 
nicht erst langsam rauffahren.
Die mit ca. 100kHz schnell ändernde (sekundäre) Spannung wird im 
PC-Schaltnetzteil an die Ausgangsdrossel angelegt, die sie in langsam 
steigenden und sinkenden Strom umwandelt um die Ausgangselkos zu laden 
und den Ausgangsstrom zu liefern.
Der zweite Spule, die Drossel, im PC-Schaltnetzteil ist also das, wozu 
die Schaltfrequenz passen muss.

Wenn du deinen Trafo mit denselben Spannungen, nur halt primär/sekundär 
umgekehrt, betreibst, sollte er auch für 100kHz oder was auch immer das 
PC-Schaltnetzteil hatte geeignet sein. Ich vermute aber, du fährst ihn 
mit der halben Spannung, was die Frequenz reduziert.

Mach also erst mal folgendes: Trafo nur mit mässiger ohm'scher Last 
belasten. Ausgangsspannung oszillokopieren. Es sollte ein sauberer 
Rechteck sein, kein wesentliches Trapez erkennbar, weniger als 10% der 
Periodenzeit sollte für die Ansteigszeit draufgehen, kaum Dachschrägen 
und primär keine zerstörerischen Spannungsspitzen (sonst brauchst du 
einen Snubber) und kein übermässiges Klingeln (also höherfrequente 
abklingende Sinuswellen nach jeder Flanke).

Wenn das so funktioniert, miss auch die Ausgangsspannung, das ist das 
Übersetzungsverhältnis des Trafos, das bei 230V~ (also 325V=) zu 5V 
NICHT 1:65 betrug, sondern eher 1:32, muss ja schliesslich auch bei 
niedriger Eingangsspannung noch Reserven haben).

Nun hast du eine hochfrequente Rechteckspannung, richte sie doch gleich 
wie auch im PC-Netzteil. Schliess die Drossel an, durch die im 
PC-Netzteil per Draht alle Spannungen geführt wurden, wobei du auf sie 
so viele Windungen aufbringen kannst, wie der maximale Strom erlaubt 
(PC-Netzteil hatte vielleicht 50A gesamt bei pro Spannnng 5 Windungen, 
du willst 10A kannst also bis zu 25 Windungen machen). Nun hast du eine 
Spule, die den Ausgangsstrom langsam (na ja, 1/100000 Sekunde) steigen 
und fallen lässt, egal wie die Spannungen an den Enden sind, ob also der 
Kondensator noch geladen oder entladen ist. Dahinter kommt der zu 
ladende Kondensator. Wenn du das nun oszilloskopierst, siehst du, wie 
bei engeschalteten prmären Transistoren der Strom in der Drossel ständig 
steigt, auch wenn umgepolt wird (das ist sekundär ja gleichgerichtet). 
Damitr der Strom nicht zu weit stiegt und damit auch primär in deinen 
Transistoren zu weit steigt, ist es nötig, nicht mit 100% Einschaltzeit, 
sondern mit wneiger, PWM, zu fahren. Du könntest z.B. in jedem Zyklus 
von 1/100000 Sekunde immer abschalten, wenn primär 100A erreicht werden, 
das scheinen deine Transistoren ja auszuhalten, und dann nicht mit dem 
nächsten Zyklus vorzeitig beginnen, sondern den Rest der zeit warten.

Dann sollte auch 1 Trafo locker in weniger als 3 Sekunden deinen Elko 
aufgeladen haben.

Autor: DerAlbi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Interessanter Beitrag!
Ich möchte noch ein paar Sachen richtigstellen: un zwar: 200W-Trafos: 
jein, denn ich nutzte ja nur einen Bruchteil der verfügbaren Windungen. 
Jeder Trafo hatte mal 450W insgesamt. ich nutze jedoch NUR die 
5V-Windung, die weit weniger als die hälfte des Gesamtstroms ausmacht. 
4*450W zu rechen ist also unfug :-)
Außerdem: Vollbrücke. Ich haue da quasi 30V rein, um sekundärseitig auf 
400-500V zu kommen. Dass nur 350V aufm Kondensator landen, macht eine 
Schaltung die immer sagt "brauch Trafos, brauch de nich mehr, brauch die 
Trafos, brauch se nich mehr".
Ein weiteres problem ist: ich kann jetzt an der schaltung nur noch wenig 
ändern. Das einzige worauf ich Einfluss habe ist wirklich nur die 
Schaltfrequenz.
Sekundärseitig habe ich eine Kleine Spule drinne, die die 
Gleichrichterdioden vor Spitzenströmen schützt.  Eine Größere Drossel 
war kontrapoduktiv, da sie den Stromfluss verhindert hat. Ohne Spule 
rauchen mir die Dioden aber weg :-)

Ich hab mal meinen Aufbau in den Anhang fotografiert ;-) Bitte um 
Verständnis, ist noch nicht fest montiert und die kabel fliegen halt so 
rum, da ich verlängerungen brauche, um die einzelnen signale abzutasten. 
Doppelstock ist messtechnisch blöde.

Das PNG zeigt die Ladekurve des Kondesators. Also alle 3. 54mF 
insgesamt. schluss is bei rund 355V.

MFG

Nu bin ich bis Montag weg.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ein weiteres problem ist: ich kann jetzt an der schaltung nur noch
> wenig ändern.

Dann können wir an deinem Problem nur noch wenig ändern.

> Sekundärseitig habe ich eine Kleine Spule drinne, die die
> Gleichrichterdioden vor Spitzenströmen schützt.  Eine Größere Drossel
> war kontrapoduktiv, da sie den Stromfluss verhindert hat.

Sie muss natürlich hinter den Dioden im Gleichstrompfad sein,
und es muss einen Strompfad geben (über eine zweite Diode)
wenn der Trafo "abgeschaltet" ist.

Schau halt mal, wie das PC-Netzteil gleichgerichtet hatte.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.