www.mikrocontroller.net

Forum: HF, Funk und Felder PLL LMX 2330 keine Regelspannung?


Autor: alex (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

bin seit Stunden am testen der Schaltung und komme nicht weiter.
An der Varicap sollte eine Spannung von 2-4V zu messen sein, dies ist 
bei mir aber nicht der Fall.

Getestet habe ich schon folgendes:
Am Oszillator QG1 habe ich 12,8Mhz wie gewünscht.
Die Spannungsversorgung der PLL (LMX2330) scheint ebenfalls ok zu sein.
Die Varicap ist in Sperrrichtung in der Schaltung (hatte ich am Anfang 
übersehen und falsch eingelötet)
Der VCO selbst lässt sich durch verschiedene Luftspulen relativ gut 
"abstimmen"
Die Leitung vom LMX mit der Abstimmspannung hat keinen Schluß zu GND wie 
ich am Anfang annahm.

Wo könnte nun der Fehler sein bzw. warum habe ich keine Regelspannung an 
der Varicap? Ich bin für jeden Tip dankbar.

Der Schaltplan selbst ist nicht von mir, wurde aber schon erfolgreich 
aufgebaut. Das Bauteil am rechten Rand ist ein DDS AD9895BSV...Die 
Steuerleitungen SC SD SE gehen zu einem PIC, dieser funktioniert 
schonmal und dessen Firmware ist drauf.

Alex

Autor: Georg A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn sonst anscheinend alles passt, könnte es eine fehlerhafte 
Initialisierung sein, falsches Timing, schlechte Signale, etc.

Ein Oszi wäre aber sehr hilfreich, alles andere ist ziemliches Stochern 
im Nebel. Dann könnte man in der Initialisierung zB. die 
RF/IF-Teiler-Ausgänge auf Pin 10 geben und schauen, ob sich überhaupt 
was rührt und dann vergleichen. Man könnte auch überprüfen, ob am 
Chargepump-Ausgang (3) kleine Pulse sichtbar sind. Aber so...

Autor: alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Georg,

stimmt, im Moment ist es eher ein fischen im Trüben. Werde heute mal den 
Chargepump Ausgang mit dem Oszi überprüfen...Ein Pulsen auf der 3 könnte 
aber wirklich vorhanden sein, man sieht mit einem einfachen Multimeter 
ein leichtes Pulsen...Allerdings beträgt die Spannung an (3) weniger als 
10uV...sollte da nicht etwas mehr sein?

Alex

Autor: alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Problem gelöst! Der VCO schwingt sofort an und lässt sich pi mal Daumen 
auf 1,2 Ghz ziehen...nur dann wandert es...das sollte die PLL LMX ja 
wieder über die Varicap "nachtrimmen"...Tut sie aber nicht. Die PLL wird 
wiederum über den PIC gesteuert und der hat dafür die entsprechende 
Firmware...In meinem Fall die falsche. Nach einem Update der Firmware 
arbeitet die PLL und die Steuerspannung an der Varicap ist vorhanden. 
Der VCO schwingt sauber und stabil auf 1,2Ghz.

Alex

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo alex,

hättest du einen Link auf die Quelle/Beschreibung deiner Schaltung, oder 
köntest du zumindestens die Geometrieparameter deines 1.2GHz Microstrip 
Filters nach dem Oszi angeben ?

Danke.

Autor: user (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>sieht aus  wie  hier -> ...

ja, danke,
aber leider gibt der Knabe auf seiner Webseite auch keine nähere Angaben 
über die Dimensionierung des Strip Filters.
Aber ich vermute der hat das bei seinem Mehrlagenaufbau sowieso einfach 
über einen HF-Fieldsolver Programm durchsimmuliert.
Mir ging es nur um die genaue Festlegung der Feedtaps.

Autor: alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michi,

nähere Angaben zu den Microstrips kann ich Dir leider nicht 
geben...lediglich ein Layout der einseitigen Platine ist vorhanden. Die 
Quelle ist www.dl1alt.de...Dort findest Du aber nicht diese Schaltung. 
Mein Ausschnitt stammt von einem Prototypen. Wenn es nur um den VCO und 
die Microstrips geht, dann kannst Du aber auch mal in das "NWT-502" 
reinschaun...Dort ist der Aufbau des VCO sehr ähnlich wie bei meiner 
vorher geposteten Schaltung.
Habe mein Gerät jetzt soweit fertig und kämpfe noch mit ein paar 
"Kleinigkeiten",

Alex

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.