www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR32 USART1 RTS/CTS Problem


Autor: Billy __ (slowflyer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Controller ist ein AVR32UC3A. An der USART1 habe ich ein Bluetooth-Modul 
hängen (RX/TX/RTS/CTS verdrahtet), dass mit Hardware Fluskontrole 
arbeitet. Die Hardware Flusskontrolle des AVR32 habe ich aktiviert 
(USART1->mr |= AVR32_USART_MR_MODE_HARDWARE;) und sende nun mit 
DMA-Transfer an das Bluetooth-Modul. Das Problem ist, wenn das CTS 
Signal des Bluetooth-Moduls kommt, sendet die USART unbeeindruckt 
weiter. Bei der Suche nach dem Problem bin ich darauf gestossen, dass 
der UC3A ein Problem mit RTS (von CTS stand da nichts) hat. Wäre es 
denkbar, dass da auch noch ein Fehler schlummert, oder mach ich da was 
falsch? Kann mal wer die Hradwarefluskontrolle mit DMA-Transfer (senden) 
ausprobieren?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.