www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit LM386


Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich beschäftige mich gerade etwas mit Sounderzeugung und habe für den 
Anfang ulrich radigs megalol aufgebaut:

http://www.ulrichradig.de/home/index.php/avr/megalol

soweit kein Problem.
in kleinen Ohrhörern ist der Ton recht klar (so klar 8bit 16kHz halt 
sein können) zu hören.

jetzt wollte ich eine Verstärkerschaltung mit Speaker dahinter klemmen 
und hab mit dem LM386 die Minimalvariante aufgebaut, die im Datenblatt 
beschrieben ist
-> http://www.national.com/profile/snip.cgi/openDS=LM386
(Seite 5, oben links)

außerdem hatte ich auch die "Endstufe" hiervon aufgebaut:

http://avrprojects.info/files/media/MMC-card-wave-...
nur habe ich hier den Gain- und den Bypass-Kondensator weggelassen.

beide Schaltungen ahebn nicht funktioniert und haben abhängig von der 
Poti-Stellung nur mehr oder weniger lauten Krach erzeugt.
wobei ich bei der Datenblattschaltung den Eindruck hatte, dass sich die 
Frequenz je nach Potistellung änderte.


Kann mir jemand weiterhelfen?

Gruß,
Vlad

: Verschoben durch Moderator
Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>http://avrprojects.info/files/media/MMC-card-wave-...
>nur habe ich hier den Gain- und den Bypass-Kondensator weggelassen.

Der Schleifer vom Poti gehört an Pin 3 vom LM386 und nicht an
den uC. Schon mal was von Spannungsteiler gehört?

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>nur habe ich hier den Gain- und den Bypass-Kondensator weggelassen.

Na, da hast Du ja schon den Fehler.
MfG Paul

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
holger schrieb:
> Schon mal was von Spannungsteiler gehört?

das kommt ja nicht von mir.
gewundert habe ich mich deswegen auch schon.

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Na, da hast Du ja schon den Fehler.
> MfG Paul

Ich habs auch mit probiert, aber laut den Schaltungsbeispielen im 
Datenblatt wird damit die Verstärkung gesteuert und die war vorher viel 
zu hoch.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Schon mal was von Spannungsteiler gehört?

>das kommt ja nicht von mir.
>gewundert habe ich mich deswegen auch schon.

Und ich wunder mich da gar nicht. Häng vor das Poti
noch mal einen 100k Widerstand. Dann kannst du evtl.
auch vernünftig die Lautstärke regeln.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>gewundert habe ich mich deswegen auch schon.

Da staunt der Flachmann und der Wunde leiert sich..
;-)

MfG Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn die Kondensatoren nicht dran sind, erregt sich die Schaltung selbst
und Du hast einen Generator für die lustigsten Signalformen.

Zitat Pittiplatsch:
Kannst'e glauben!

MfG Paul

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Zitat Pittiplatsch:
>Kannst'e glauben!

Geh schlafen Paul;)

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vlad Tepesch schrieb:

> jetzt wollte ich eine Verstärkerschaltung mit Speaker dahinter klemmen
> und hab mit dem LM386 die Minimalvariante aufgebaut, die im Datenblatt
> beschrieben ist

Was hast du eigentlich mit dem PWM Ausgang gemacht?
Glättest du den mit einem Tiefpass oder gehst du direkt in dem LM damit?
Wahrscheinlich letzteres.

Da du vom µC sowieso ja schon 5V (wenn aúch in Form einer PWM) bekommst, 
brauchst du doch im Grunde da die Spannung nicht mehr verstärken, wozu 
soll das gut sein? Einzig kann der µC den Strom nicht treiben. D.h. du 
bräuchtest eine Push/Pull Stufe dahinter. Sieh dir mal an wie Hannes das 
gemacht hat

http://www.hanneslux.de/avr/divers/melody/melody03.html

Angeblich macht das Ding einen Höllenradau

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Geh schlafen Paul;)
Erst nach dem Zapfenstreich...
;-)
MfG Paul

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Karl-Heinz
>Angeblich macht das Ding einen Höllenradau

Macht es. Ich habe es mit eigenen Ohren gehört.
MfG Paul

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Geh schlafen Paul;)
>Erst nach dem Zapfenstreich...

Tröt, tröt, trööööt. Fahne ist runter.
Ich glaub du hast für heute genug gezapft;)

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Wenn die Kondensatoren nicht dran sind, erregt sich die Schaltung selbst
> und Du hast einen Generator für die lustigsten Signalformen.
>
> Zitat Pittiplatsch:
> Kannst'e glauben!
Ok, aber warum steht das dann unter typical Applications so im 
Datenblatt?



Karl heinz Buchegger schrieb:
> Was hast du eigentlich mit dem PWM Ausgang gemacht?
> Glättest du den mit einem Tiefpass oder gehst du direkt in dem LM damit?
> Wahrscheinlich letzteres.

Ich hab beides probiert.
einmal habe ich den Tiefpass von Ulrich drangelassen und einmal hab ich 
ihn weggelassen wie in der avrprojects-Schaltung.

Karl heinz Buchegger schrieb:
> Da du vom µC sowieso ja schon 5V (wenn aúch in Form einer PWM) bekommst,
> brauchst du doch im Grunde da die Spannung nicht mehr verstärken, wozu
> soll das gut sein?

Das heißt, die AVR-Projectsschaltung ist nicht zu gebrauchen?

Karl heinz Buchegger schrieb:
> Sieh dir mal an wie Hannes das
> gemacht hat
>
> http://www.hanneslux.de/avr/divers/melody/melody03.html
>
> Angeblich macht das Ding einen Höllenradau

Danke für den Link.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ok, aber warum steht das dann unter typical Applications so im
>Datenblatt?

Das weiß ich auch nicht. Hast Du denn das Boucherot-Glied 
(RC-Kombination
am Ausgang) dran?

MfG Paul

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Das weiß ich auch nicht. Hast Du denn das Boucherot-Glied
> (RC-Kombination
> am Ausgang) dran?

Ja allerdings nur mit 47nF, hatte keine 50

Bei Hannes schaltung wundert mich, dass es gar keine Basiswiderstände an 
den Transistoren gibt. Ist das normal?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ja allerdings nur mit 47nF, hatte keine 50

Das ist sowas von Wurst;)

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bei Hannes schaltung wundert mich, dass es gar keine Basiswiderstände
> an den Transistoren gibt. Ist das normal?

Ja, das sind Emitterfolger.

Autor: Vlad Tepesch (vlad_tepesch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wirklich viel lauter wird es auch nicht.


Habs jetzt so, oder hab ich da doch einen verdreht?

        Vcc
          C
           \
    µC <- B-|) BC337
           /
          E  -> elko +||-   -> SPeaker -> GND
          /
  BC327 (|-B -> µC
          \
           C
           GND

Autor: Daniel A. Maierhofer (amad) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, ich bastle gerade an etwas ähnlichem.
Und zwar habe ich http://elm-chan.org/works/sd8p/report.html nachgebaut.

Allerdings läuft der AVR selbst ja nur mit 3,3V wegen der SD-Karte und 
kann deswegen nicht allzu viel Strom an seinem Ausgang liefern.

Ich hatte ebenfalls die Idee einen LM386 einzusetzen, aber der ist ja 
eben ein linearer Verstärker. Hier braucht man ja nur eine schlatende 
Gegentaktendstufe, wie von Hannes Lux verwendet?

Bei der gehn aber schonmal die Basis-Emitterspannungen für die 
Transistoren verloren sodass ich ja nur mehr 3,3V-2*0,6V = 2,1V 
Amplitude bekomme.

Habt ihr da eine bessere Idee, eventuell mit einem andren IC?

Ein Einfall wäre, einen 74AC14 6-fach Inverter zu nehmen und den dann 
den Lautsprecher ansteuern zu lassen oder würds da was besseres geben?

Wie muss man eigentlich das RC-Glied bei der verlinkten Schaltung für 
die Glättung dimensionieren wenn man in einen Hi-Fi-Verstärker 
einspeisen will?

Schädigt diese PWM nicht einen Lautsprecher, wenn sie direkt anliegt, 
weil ja der Mittelwert nicht 0 ist?

MfG,
Daniel

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte das evtl. jemand in das Analogtechnik-Forum verschieben?
Dazu passt es ja eher und ist nicht so schnell unter den anderen 
Beiträgen verschwunden.

Autor: Daniel A. Maierhofer (amad) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So.

Mit 74AC14 ist die Lautstärke eigentlich schon ganz schön akzeptabel.
Mit LM386 werd ichs aber dennoch, sobald ich einen aufgetrieben habe, 
testen.

Dafür muss ich mir beim 74AC14 auch über den Ruhestrom keine Sorgen 
machen, wenn ich einen Koppelkondensator am Lautsprecher verwende.

Nur mit dem RC-Glied weiß ichs noch nicht ob ich da eins brauch?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.