www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit dem STK500


Autor: Jockl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tachchen,

mit meinem STK500 kann ich keine Controller
im Sockel  SCKT3000D3  mehr Programmieren.
Habs mit dem AT90S8515 und dem ATmega161 probiert.
Dabei erscheint die Fehlermeldung "Entering Programming Mode - FAILED". 
Den ATmega163 kann ich ohne weiteres Programmieren (der kommt in den 
anderen 40 pin Sockel).
Andere Controller konnte ich leider nicht Probieren.

Hat damit jemand erfahrung?

THX jockl

Autor: Remo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Jockl,

ich hatte dieses Problem noch nicht, doch habe ich die Erfahrung 
gemacht, dass fuer die ISP Progarmmierung die gewaehlte Taktfrequenz des 
Boards kritsch ist. Daher folgende (wertvollen???) Tipps:
1) Spiel mal ein bischen mit der Taktfequenz des Boards, bzw versuch mit 
nem Oszi rauszubekommen, ob an dem D3 Sockel noch der Takt anliegt, 
vielleicht hast Du ja einen Haarriss in der Platine.
2) Ist der richtige ISP Sockel gesteckt. Ich weiss ist ganz profan, aber 
wer weiss. Im eifer des Gefechts kanns ja sein, dass man vergisst den 
sechspoligen Stecker entsprechend umzustecken.
3) Noch so'n kluger Rat: gilt das für IPS als auch für high voltage 
parallel Programming. Probiers doch einfach mal aus. So kannst Du das 
Problem besser einkreisen.
4) Hoffe Du bekommst nicht nur so schlaue Ratschlaege, wie die meinen 
und Du hast das Problem bald im Griff.

Viel Glueck Remo

Autor: Jockl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin,

tja, so wie's aussieht liegt der Fehler wohl an dem invertierenden 
Schmitt-trigger vor dem XTAL1 Jumper (U900 laut Schaltplan). Am Eingang 
liegt das Clock-Signal noch an, doch leider kommt hinten nichts raus 
(Versorgungsspannung ist O.K.).

Danke an Remo für die Tips.

Grüße aus Hessen
jockl

Autor: Remo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan???
Kannst Du mir den evtl. irgendwie zukommen lassen oder mitteilen, wie 
ich an den rankommen kann. Ich hab zumindest keinen zu meinem STK500 
geliefert bekommen.

Danke für die Mühe und viel Glück beim Löten des SMDs......

ciao
Remo

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.